LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 11-15-2005, 09:51 PM   #1
Spadge67
LQ Newbie
 
Registered: Nov 2005
Posts: 1

Rep: Reputation: 0
Samba Share access


Greetings! i've come to love this forum over the course of this weekend, as i seem to be one of many strugling to get samba running, all of the previous posts have been very helpful, but i still cant seem to get the kinks out of this - so here goes -

Fresh install of FC4 on my "server" (tired of reisntalling the eval of 2k3 i have)

samba 3.0.14b i believe is what came with it

Here is my SMB.conf file for yall to disect -
login as: root
root@192.168.2.2's password:
Last login: Tue Nov 15 20:35:41 2005 from 192.168.2.3
[root@Onyxsrv ~]# cd /etc/samba
[root@Onyxsrv samba]# vi smb.conf
[root@Onyxsrv samba]# vi smb.conf
_________________________________________
# Samba config file created using SWAT
# from 192.168.2.5 (192.168.2.5)
# Date: 2005/11/15 20:29:10

# Global parameters
[global]
workgroup = PLAY
server string = Spadge's FC4 Fileserver
passdb backend = tdbsam, guest
username map = /etc/samba/smbusers
server signing = auto
preferred master = No
domain master = No
ldap ssl = no
read only = No
case sensitive = No
msdfs proxy = no

[Software]
comment = software
path = /data/software
guest ok = Yes

[Music]
comment = Spadge's Music Collection
path = /data/music
guest ok = Yes

[Multimedia]
comment = Movies and TV Shows
path = /data/multimedia
guest ok = Yes
_________________________________________________

I can see the samba server in the workgroup view, and can access the machine using the guest acct, but cannot get into any of the folders, it gives me that i donot have permission to access this resource.

anything is great, thanks guys

PS if this is in the wrong forum, very sorry

*EDIT
i also did a chmod 777 on each of the 3 share folders (/data/multimedia, /data/music, and /data/software) just to eleminate the perms as a problem

Last edited by Spadge67; 11-15-2005 at 10:04 PM.
 
Old 11-16-2005, 09:58 AM   #2
niux
LQ Newbie
 
Registered: Nov 2005
Posts: 10

Rep: Reputation: 0
hey.. im running FC3, so dont know if this will work

however, by security reasons i recomend you to not use the guest account.
from the SMB gui-configuration (menu->system settings->server settings->samba) you can add users and manage you shares.

add a user from the preferences->samba users.. menu
then select one of you shares and hit properties, from the access tab you can manage what users will have access to that share. and if the can write to it



/niux
 
Old 11-18-2005, 02:07 AM   #3
sirkware
Member
 
Registered: Nov 2005
Location: Philippines
Distribution: Fedora Core 6 Test 1
Posts: 66

Rep: Reputation: 15
Please refer to my post at Linux Forums - Software - Network in KDE. I think this is the same problem with yours.

Hope that helps.
 
Old 11-19-2005, 07:57 PM   #4
poochdog
Member
 
Registered: Jul 2004
Location: United Kingdom
Distribution: Fedora Core 9
Posts: 141

Rep: Reputation: 15
Hi this guide here will also be of help to you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
samba network share access Goma_2 Linux - Software 6 03-06-2005 01:10 PM
Samba: can't access share thorax Linux - Software 4 02-13-2005 01:39 PM
XP user can't access samba share atp777 Linux - Software 0 03-30-2004 06:33 PM
can't access samba share from w2k cliffyman Linux - Software 1 12-10-2003 01:31 PM
Samba share access problem from xp GabeF Linux - Software 2 09-09-2002 03:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 11:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration