LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 07-06-2004, 11:53 PM   #1
Basslord1124
Member
 
Registered: Jun 2004
Location: KY
Distribution: Debian, Mint, Puppy
Posts: 504

Rep: Reputation: 51
samba question, Authentication Mode...


All right, in Samba, under Preferences and Server Settings and under the Security Tab there's a drop down box for Authentication Mode. From reading the documentation on it, I need to put this on User for Windows machine to access it...and it works this way. But everytime I reboot (which isn't all too often) it reverts back to Share. So then I'm forced to go back in and change it back. Is there something in the smb.conf file I need to correct this or is this some Security setting? I know how to get it back and all, it's just becoming a pain to have to keep changing it back.
 
Old 07-07-2004, 10:22 AM   #2
JoAnywhere
Member
 
Registered: Oct 2003
Location: denver
Distribution: Debian
Posts: 97

Rep: Reputation: 15
two thoughts come to mind immediately.
1. Are you running the latest stable release of SAMBA
2. Have you tried modifying the samba.conf (I think thats the file name) directly, rather than through the web interface.

Cheers
Jo
 
Old 07-07-2004, 12:01 PM   #3
Basslord1124
Member
 
Registered: Jun 2004
Location: KY
Distribution: Debian, Mint, Puppy
Posts: 504

Original Poster
Rep: Reputation: 51
Well I am running FC2 and it's very much up to date so I think I am safe there. I have looked through the conf file but not sure what I'd need to change.
 
Old 07-07-2004, 12:09 PM   #4
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
You'd want to look for the section that resembles this:
Quote:
# Security mode. Most people will want user level security. See
# security_level.txt for details.
security = user
 
Old 07-07-2004, 12:34 PM   #5
Basslord1124
Member
 
Registered: Jun 2004
Location: KY
Distribution: Debian, Mint, Puppy
Posts: 504

Original Poster
Rep: Reputation: 51
Here's how mines looks now:

Quote:
# Security mode. Most people will want user level security. See
# security_level.txt for details.
# Use password server option only with security = server
; password server = <NT-Server-Name>
Please bear with me, I'm still a newbie at this.
 
Old 07-07-2004, 12:57 PM   #6
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
There's no security= line somewhere below that?

If not, just add it. Maybe that's why it keeps reverting to the default (which I think might well be share-level security). Of course, it might also be that you aren't logging into Samba-swat or Webmin (whatever you're using), with the root password, and your changes aren't being saved (hint: you have to edit /etc/samba/smb.conf as root, too ).

You might want to swing by the Samba website and read the documentation, as well.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba without authentication maginotjr Slackware 6 11-21-2005 05:07 PM
Samba authentication leeloo2 Linux - Newbie 2 12-13-2004 05:32 PM
PAM Authentication on Native Mode Win2000 Network dilshadkitchil Linux - Networking 2 12-24-2003 06:01 AM
Samba authentication cmoloney Linux - Networking 32 12-01-2003 09:36 PM
Samba authentication ltrain Linux - Networking 1 06-13-2001 03:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 01:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration