-   Fedora (
-   -   rpmbuild doesn't generate rpm package (

bujecas 08-05-2009 01:35 PM

rpmbuild doesn't generate rpm package

I'm trying to do a rpm package that only changes some config files of other installed package. I don't need source and buildroot. Just use the post directive to run some shell script. When I rpmbuild -ba the SPEC file only the src.rpm is generated and the noarch.rpm does not.

Here's my SPEC file:


Name: syslog-clients-config
Version: 0.9
Release: 1
License: GPL
Group: DES/EDS
BuildArch: noarch
Requires: syslog-ng


cp /etc/syslog-ng/syslog-ng.conf /etc/syslog-ng/syslog-ng.conf.`date +"%Y%m%d%H%M%S"`
cat /dev/null >/etc/syslog-ng/syslog-ng.conf
service syslog-ng reload

Any help?

jvhiii 08-06-2009 04:27 PM

Add %files
Try adding %files. I tried this with your example, and even with nothing in the %files section it wrote a noarch.rpm. I'm using rpm- So like:



cp blah blah


bujecas 08-07-2009 10:36 AM

It worked, thanks.

All times are GMT -5. The time now is 05:34 AM.