-   Fedora (
-   -   rm'ing files doesn't free up disk space (

Earlw 03-03-2005 06:44 PM

rm'ing files doesn't free up disk space
Hi folks,

I'm running FC3 and ran out of disk space on my /hda2 partition

After deleting a huge - and I mean approx 5Gb - worth of files, the df output still shows 0% free. None of these files were linked to other files. They should be well truly gone.

Rebooting and forcing a fsck doesn't seem to have solved the problem.

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/hda2 18951536 18025248 0 100% /
/dev/hdb1 240362656 84436260 1437 16596 38% /home2
/dev/hda1 101089 9323 86547 10% /boot
none 54940 0 54940 0% /dev/shm

However, I can now still copy large files to say /usr and delete them, but my Samba mounts see the server as 0 bytes free.

Any ideas?


- Earl

trickykid 03-05-2005 09:04 AM

What files did you delete? Were they files in /var ? If you delete a file that is currently being written to, it won't free up the space til you restart the process that was writing to the file.

And you should really think about having the psuedo type filesystems on their own partitions as well.. like /var and /tmp

KimVette 03-05-2005 11:28 AM

I've ran into the same situation with the 2.6.5-7.145-smp kernel, ended up with 0% space left on my / partition so I deleted ~14GB worth of files - waited a bit, 0% free was still reported. I switched runlevels and 0% free was still reported, and I could not create any files. Only a reboot corrected the situation. It appears there is a bug in the Linux kernel where when it runs totally out of space, it won't recognize freed space until a reboot. I'm sure that if it were to occur on another partition that an umount followed by a mount would correct it. I haven't tried "sync" because sync can be dangerous on mounted partitions at times.

coontie 03-06-2005 01:19 PM

it's not a bug. It's a "feature" of the LVM, the volume manager. It happens on all LVMs, veritas included.

KimVette 03-06-2005 06:40 PM

"undesirable feature" = defect.

All times are GMT -5. The time now is 02:19 PM.