-   Fedora (
-   -   recv function not working with Fedora 12 while working fine with Fedora core 2 (

supreed 03-13-2010 12:36 AM

recv function not working with Fedora 12 while working fine with Fedora core 2

I wrote a program which send a udp broadcast packet from one computer. I am using recv(..) function in a receive program running on another computer. This programs works fine with fedora core 2 while the same program dosent work with fedora 12. Please help.


John VV 03-13-2010 12:58 PM

there have been so many changes to fedora in the last 10 releases that i would NOT expect something built in fedora 2 to work on fedora 12

rewrite the software to comply with gcc 4.4
and rebuild in on fedora 12

supreed 03-14-2010 12:40 AM

recv(..) returns -1
Dear Mr John,

Thanks for your reply. As u suggested I recompiled the program with Fedora 12. The program got compiled without any errors. But still the recv(..) returns -1. I tried to capture the packets using wireshark and the packets are available. I dont know why its not avaiable on the socket which i am listening to.

Again i got my firewall disabled thinking Firewall may stop my application from receiving the packets. But this also didnt work.


John VV 03-14-2010 12:52 AM

can you post the full error from bash ?

supreed 03-16-2010 02:03 AM

I tried to print the error using perror and the error string is "Resource temporarily available" ..i doubt whether the DVD which i used for installation is having some problem becoz certain programs which i wrote in Qt is giving a core dump while executing in this machine, but the same program is running fine in another machine with Fedora 12. Awaiting ur comments.

supreed 03-21-2010 03:11 AM

Select returns 0

I tried to rewrite the receive program using "select". But Select returns 0. Anyway i could see the packets using Wireshark. So the packets are arriving but its not avaiable in the socket i am polling.

Please help.


All times are GMT -5. The time now is 05:47 AM.