-   Fedora (
-   -   Python deps (

crazy8 11-14-2007 11:24 AM

Python deps
I have just upgraded from FC6 to FC7 and all is pretty much well except that I need to do some package updates but I get this error...

Missing Dependency: python(abi) = 2.4 is needed by package authconfig
I have been digging around and have been looking online (im still a bit of a n00b) and cant seem to find what I need to solve this issue. Anyone have any ideas?

Thanks alot for the help.

pixellany 11-14-2007 12:44 PM

If you are using the package manager, then the dependencies should be handled automatically. Otherwise, try a Google search using whatever is in the error message

For example, Google "python abi" looks promising.

crazy8 11-14-2007 01:46 PM

actually I used both yum and the package manager and get the same result. Ill look into python abi in google. I did however do python(abi) and python(abi) = 2.4 in google and got alot of results but didnt find any files that i needed. The files I did find and tryed to install I would get a message saying that I had a newer version of the file installed already. Well ill try what your suggesting and see what i come up with. Thanks for your help

crazy8 11-14-2007 03:23 PM

well still no luck I cant seem to find anything to fix the issue. Any other suggestions? I have looked through the list of packages and there inst a package in the list called "authconfig" so I think its a file/package within one of the packages in the list. Is there anyway for me to find out which package contains "authconfig" without having to go through all 600 and some of the files? Then ill just uncheck it and up grade everything else and do that one last.

reddazz 11-14-2007 08:10 PM

What is the output of doing

$rpm -qa | grep -i python

$rpm -qa | grep -i authconfig
Also try doing the upgrade by doing

$yum -y upgrade

momorabit 11-16-2007 09:35 AM

same problem ... works now ;)

You must have the same problem like me, i guess.

yesterday, i've exactly the same error when i tried upgrade my ferora core 6

  # > yum update yum
  Missing Dependency: python(abi) = 2.4 is needed by package authconfig

reason : in fedora 7, python must be updated to version 2.5 and lot's of packages in fedora 6 (during upgrade or something else) work with python 2.4 :confused:

reason 2: last authconfig package is 5.3.18-0.1.fc6 but during upgrade to FC7, yum tries to install authconfig with version 5.3.15-1.fc7: do you think what i mean ?

which reason is right ? I don't know but I decided to erase authconfig and prayed very extremely :jawa:


  # > yum erase authconfig
 Package                Arch      Version          Repository        Size
 authconfig              i386      5.3.18-0.1.fc6  installed        1.7 M
Removing for dependencies:
 authconfig-gtk          i386      5.3.18-0.1.fc6  installed        183 k
 firstboot              noarch    1.4.23-1        installed        933 k
 firstboot-tui          noarch    1.4.23-1        installed        621 k

Transaction Summary

[y/N]: y

  # > yum -y update yum
  [...] // no else error found

  # > yum -y upgrade

Et voilą

Momorabit (sorry for my english :) )

Edgeman 11-21-2007 11:13 PM

Thanks, I had same problem, first part now seems to be working.

All times are GMT -5. The time now is 02:26 PM.