LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 01-31-2009, 04:46 PM   #1
kidicarus
Member
 
Registered: Aug 2003
Distribution: Debian Sid
Posts: 93

Rep: Reputation: 15
Problems with run level 5 and xorg at startup.


Hi. I'm using Fedora core 6 with NVIDIA-Linux-x86-1.0-8776-pkg1 driver.

Everytime my system boots with /etc/inittab set to "run level 5" the GUI login displays quickly and then just as quickly returns me to a console login. I know that X hasn't crashed, because i hit Ctrl + Alt + f7 and I have my regular login. Of course, I can't restart X from virtual console 1 as it is already running.

Has anybody had this problem? It only happens on occasion. What am I supposed to do?
 
Old 01-31-2009, 05:05 PM   #2
cheftec
Member
 
Registered: Jan 2009
Location: Pennsyltucky
Distribution: Debian, Ubuntu, DeLiLinux, others
Posts: 144

Rep: Reputation: 19
Just to clarify, your login window displays, then before you can even log in it kicks you over to vc1? Can you log in on vc7 after you switch back over to it? Have you tried quitting X on vc7 then restarting it with startx? Which display manager are you using?(gdm/kdm,etc...) Can you boot to level 3 and startx?
 
Old 01-31-2009, 05:12 PM   #3
kidicarus
Member
 
Registered: Aug 2003
Distribution: Debian Sid
Posts: 93

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by cheftec View Post
Just to clarify, your login window displays, then before you can even log in it kicks you over to vc1?
Yes, that's exactly what happens.

Quote:
Originally Posted by cheftec View Post
Can you log in on vc7 after you switch back over to it?
Yes. However, it is kind of annoying to have to do that everytime as I am not somebody who leaves my computer on for all hours.

Quote:
Originally Posted by cheftec View Post
Have you tried quitting X on vc7 then restarting it with startx? Which display manager are you using?(gdm/kdm,etc...) Can you boot to level 3 and startx?
Yes, I've tried that and it's kdm. This didn't used to happen but for a while I was using run level 3, then went back to run level 5 and it started.

I checked /var/log/messages and I didn't notice anything out of the ordinary.
 
Old 01-31-2009, 07:26 PM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,187

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Try looking at /var/log/Xorg.0.log for any X-server error messages. (tail /var/log/Xorg.0.log should suffice.)

Do you have something running in /etc/rc.local that might cause the problem? Or in .kde/autostart?

Once you log on to tty7, try a start -- :1 (as a normal user) to start a new X-session on tty8. If that works, switch back to tty7 to see if any interesting errors are displayed. If it doesn't work, you should be bounced back to tty7 where, hopefully, you'll find a message telling you why you were bounced back.

Last edited by PTrenholme; 01-31-2009 at 07:28 PM.
 
Old 01-31-2009, 07:43 PM   #5
cheftec
Member
 
Registered: Jan 2009
Location: Pennsyltucky
Distribution: Debian, Ubuntu, DeLiLinux, others
Posts: 144

Rep: Reputation: 19
rc.local sounds like the more likely culprit. Post it, along with the error message.
 
Old 02-02-2009, 01:26 PM   #6
kidicarus
Member
 
Registered: Aug 2003
Distribution: Debian Sid
Posts: 93

Original Poster
Rep: Reputation: 15
Well, it did it again this morning.

There are no errors in xorg.conf. here's what's at the end:

Quote:
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(WW) <default pointer>: No Device specified, looking for one...
(II) <default pointer>: Setting Device option to "/dev/input/mice"
(--) <default pointer>: Device: "/dev/input/mice"
(==) <default pointer>: Protocol: "Auto"
(**) Option "CorePointer"
(**) <default pointer>: Core Pointer
(==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
(**) <default pointer>: ZAxisMapping: buttons 4 and 5
(**) <default pointer>: Buttons: 9
(II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded
(II) Open ACPI successful (/var/run/acpid.socket)
(II) NVIDIA(0): Setting mode "1024x768"
(II) <default pointer>: ps2EnableDataReporting: succeeded

I don't have a "start" command but I can "Start New session" from KDE and it seems to work OK.

there's nothing in kde auto start and here's what's in rc.local:

#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local


Basically, it briefly shows the login screen, the system bell rings, and I'm at VC1.
 
Old 02-02-2009, 02:20 PM   #7
cheftec
Member
 
Registered: Jan 2009
Location: Pennsyltucky
Distribution: Debian, Ubuntu, DeLiLinux, others
Posts: 144

Rep: Reputation: 19
maybe instead of start, do startx --:1, might give you different result.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
set your default run level so you will boot to a default run level - vga console Adam555 Linux - Newbie 1 01-21-2008 04:55 PM
problems with run level 5 gnome desktop jb8578 Fedora - Installation 1 02-21-2007 01:02 PM
emacs in run level 3 then switch to X (level 7) then back to level 3 dsoliver Slackware 3 09-01-2006 03:31 AM
Run Level 3 Problems Mr Pleb Mgoo Linux - Newbie 10 09-22-2005 08:31 PM
how do I set run level for startup? jdruin Linux - Newbie 3 09-23-2003 10:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 12:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration