-   Fedora (
-   -   Problem With Installing .rpm Packages On Fedora Core 2 (

FireDemon666 07-25-2004 02:52 PM

Problem With Installing .rpm Packages On Fedora Core 2
hey all i am a linux newb here and after numerous frustrations with red hat 9 i decided to switch to fedora core 2 since i had heard very good things about it. but i am having a mild problem with it. whenever i try to install an .rpm package (I.E. the driver package for my 9600XT) a message window pops up saying that there is no action action associated with this type of file and asks me what program i would like to open it with. any ideas? any help would be greatly appreciated. thanks.

crimsontide 07-25-2004 03:02 PM

This should help. I think. =)

linmix 07-25-2004 03:04 PM

How do you install your .rmp's? You should open a shell and use the "rpm" command. Basically its

$ rpm -i packagename.rpm

(read "man rpm" for more details)

Also, you'll probably have to do this as root ("su")

FireDemon666 07-25-2004 04:25 PM

yet problems still arise...
thanks for the speedy reply guys. the trick you showed me worked. for gnome at least, getting kde to work is another story. but here is my main problem. after i install the fglrx package for my ati radeon 9600XT everything seems to go in just fine. the ati icons are on the start menu and the fglrxconfig command registers with the command shell. but, when i click on the ati control icons or type in fglrxconfig in the shell nothing happens. the busy cursor just sits there and bounces up and down waiting for the program to start and then about 30 seconds later it dissapears as if i had never launched the program at all. this problem is very frustrating and the main reason why i switched from red hat to fedora in hope of results but it looks like my problem has followed me to another OS :( . anyone out there who knows of a workaround or fix for this please help. linux is absolutely useless unless i can get it to properly recognize my video card.

P.S. - I was also sure to use the right version of the package that matched my XFree86 version in redhat 9 so i know that couldnt be it. I'm not sure about fedora since i read that they dont exactly utilize XFree86 anymore...

TheMadHatter1 07-25-2004 05:03 PM

When I patched and installed the ATI drivers for FC2 I spent ages fiddling with the xorg.conf file and eventually managed to get the OS to load (or at least get the GUI to load!). Once it was loaded, I couldn't open the ATI Control program either. Also, when I open my Display Settings it still reports my video card to be "VESA driver (generic)" however Hardware Browser shows "RV350 AP [Radeon 9600]" under Video Cards. On top of that, I still don't seem to be getting 3D acceleration (although I've really got nothing to test it so I don't really know).

Does anyone know a fix to this problem?


FireDemon666 07-25-2004 06:40 PM

yes that seems to be the same problem im having. on the hardware browser it shows my card as a radeon 9600 but if i choose 9600 on the display page it just reverts back to VESA the next time i log in. what a bizarre state that the stock drivers include 9600, 9600 pro, and 9800XT but not 9600XT :mad:

P.S. I am definitely sure that I am not getting 3D acceleration because when i try to play chromium B.S.U it lags like hell :confused:

FireDemon666 07-25-2004 06:45 PM

another problem i forgot to mention, after i installed fedora xp pro fails to boot. when i choose to boot xp pro the xp boot screen flashes for about a second and then the monitor cuts out and the computer resets. ive tried last known good configuration and safe mode and nothing works. fedora also had the courtesy to overwrite my norton goback on the MBR so the rescue screen no longer comes up at system start. so the only other alternative4 is to reinstall xp. so far linux has gotten me pretty bent and im about two steps away from setting up my comp with xp alone and shattering all my linux cd's (exstensive swearing)

krt47 08-01-2004 09:02 AM

hi i am having the same problem with installing *.rpms too in fedora core 2

TheMadHatter1 08-15-2004 08:01 AM

I finally got it working! All you need to do is answer 'y' to 'use external agp gart module' when running fglrxconfig. I now get an error message involving my keyboard settings when I load gnome and my graphics card is still a 'VESA driver (generic)' in the display settings, but running glxinfo shows the radeon module is loaded and I am 3000 odd fps in glxgears. Woohoo!

To get the ATI Control program working, type

ln -s /usr/lib/ /usr/lib/
as root in a console window.

Let me know if anyone gets the same error message and if anyone knows how to resolve it.


All times are GMT -5. The time now is 09:01 AM.