LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 12-31-2003, 06:35 AM   #1
Emp202
LQ Newbie
 
Registered: Dec 2003
Posts: 9

Rep: Reputation: 0
Problem with auto-loading modules on boot (2.6.0, but not specific)


Hi folks,

I managed to compile Kernel 2.6.0 on Fedora Core 1 today and though most things run perfect i have still some small issues:

1. At boot it tries to load modules "mousedev", "keybdev" and "toshiba_acpi" which arent there. Everything runs fine without them, i'd just like turning off the attempt to load.

2. Sound works, but only if i manually insert modules. I read on ALSA (compiled 2.6.0 with ALSA and OSS emulation support) and edited my modules.conf and modprobe.conf (both are identical on my system since i dont know which one does what, enlightenment would be appreciated) to contain this:
Quote:
# ALSA portion
alias char-major-116* snd
alias snd-card-0 snd-emu10k1

# OSS/Free portion
alias char-major-14* soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

install snd-card-0 /sbin/modprobe --ignore-install snd-card-0 && { /usr/sbin/alsactl restore >/dev/null 2>&1 || :; }
remove snd-card-0 { /usr/sbin/alsactl store >/dev/null 2>&1 || :; }; /sbin/modprobe -r --ignore-remove

install sound-slot-0 /sbin/modprobe --ignore-install sound-slot-0 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S >>/dev/null 2>&1 || :; }; /sbin/modprobe -r --ignore-remove
However, only soundcore seems to get loaded at startup.
I still manually need to insmod ac97_codec.ko, insmod sound.ko and insmod emu10k1/ emu10k1.ko from the /lib/modules/2.6.0/kernel/sound/oss dir to have sound working.
Of course, that isnt very satisfying.

I suppose both of the above problems can be solved by editing the files for modules being loaded at startup (i thought this was modprobe.conf, but this cant be cause there is f.e. no mousedev and keybdev in there), but which would those be and what should they contain? Any help is appreciated.
 
Old 12-31-2003, 09:13 AM   #2
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
For the mousedev/keybdev, this has to do with the /etc/modprobe.conf.dist which trying load them during the bootup time. You can safely ignore the error message but if it annoys you, you can always remove the offending lines.

For the sound card, I do have problem with mine too .. I've added few lines of code into /etc/rc.d/rc.sysinit to load the soundcard and BTTV card..

And another annoying thing about 2.6.0, just discovered it today and was wondering before what went wrong when my system was totally locked up .. no idea if this is USB or bluetooth problem but when I accidently disconnected my bluetooth usb adapter, the system is totally locked up .. no way of reviving it, no way to ssh in .. total lock up ..

--
update: my bad .. those error messages can come from the /etc/modprobe.conf.dist but check out the /etc/rc.d/rc/sysinit in the USB section too .. you may want to comment those lines that trying to load the keyboard and mouse .. the Toshiba ACPI thingy comes from the one section above the USB section .. doing modprobe -k in the ACPI module directory .. just remove the offending module will silent it up Anyway .. if you're loading with rhgb (graphical display), you won't see all those error messages anyway..

Last edited by wiraone; 12-31-2003 at 10:24 AM.
 
Old 01-01-2004, 07:23 PM   #3
Emp202
LQ Newbie
 
Registered: Dec 2003
Posts: 9

Original Poster
Rep: Reputation: 0
Hi wiraone,
Thx for the great support. The closer look at rc.sysinit did the job with the clean boot for me. No more nasty red "Failed" there now. I dislike rhgb because i like to see whats going on, and i dont like the big nvidia logo that pops up on every X start with installed nvidia drivers to show up twice when booting.

What i still didnt get right is automatically inserting the 3 modules i need for OSS support. (ac97_codec.ko, insmod sound.ko and insmod emu10k1/ emu10k1.ko) I tried to insmod them at the end of rc.sysinit but when it comes to this at boot time it says unresolved symbol for two of them and doesnt load them (probably because they depend on another module thats not loaded when boot reaches the end of rc.sysinit). Any good idea how i can insmod them at every startup? I wrote a small shell script to do this, only thing i would need is having that executed with root privileges every start..
 
Old 01-02-2004, 03:14 AM   #4
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
I've the following lines added to my rc.sysinit for loading my sound card driver:

Code:
# Added to load sound module
if [ `uname -r` == "2.6.0-1.104" ]; then
  alias=`/sbin/modprobe -c | awk '/^alias sound-slot-0 / { print $3 }'`
  if [ -n "$alias" -a "$alias" != "off" ]; then
      action $"Loading sound module ($alias): " modprobe sound-slot-0
      action $"Loading BTTV module : " modprobe bttv
  fi
fi
The above, I checked my kernel release so that it won't try to load my sound card driver twice when I'm in kernel 2.4 .. make sure that you've the /etc/modprobe.conf configured correctly .. What sound card do you have? Soundblaster I guess? Try do a '$ modprobe snd-emu10k1 ' and see if it is working for you.

And, if ALSA driver doesn't work for you, you may want to try the old OSS driver instead.

Last edited by wiraone; 01-02-2004 at 03:41 AM.
 
Old 01-02-2004, 03:23 AM   #5
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
BTW, to remove the Nvidia splash screen .. add this into your /etc/X11/XF86Config

Option "NoLogo" "1" #Turn off logo display
 
Old 01-02-2004, 11:26 AM   #6
Emp202
LQ Newbie
 
Registered: Dec 2003
Posts: 9

Original Poster
Rep: Reputation: 0
Got both right now, thx :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I auto start modules that aren't auto loaded on boot? darkbluedrew Debian 2 09-18-2005 10:10 AM
Boot problem after loading modules into kernel scr02bcg Linux - General 2 07-21-2005 11:23 AM
auto loading modules saravkrish Fedora 3 12-13-2004 10:34 AM
Help with auto-loading modules in Fedora americanloki Fedora 2 01-14-2004 01:57 PM
How to disable auto fsck during boot for specific volumes mansonmuni Linux - General 5 12-21-2003 10:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 01:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration