-   Fedora (
-   -   Problem updating redhat-config-packages (

Seventh 02-25-2004 10:34 AM

Problem updating redhat-config-packages
I'm unable to add packages from CD. I checked the Fedora Core 1 Troubleshooting Guide, and found:


Fedora's CD Package Manager Fix

Too fix the CD package manager to access the rpm's on your cd's well here is the link to get the lastest one which should be patched up and fixed
I downloaded 1.2.7 and tried to install it. Clicking it gave me this error:


"This package must be unselected before package removal can contiue: redhat config-packages".
So I went into the control panel, unchecked it, tried to update, got this:


"the following package could not be found on your system. Installation cannot continue until it is installed:


So I assume that since the program needs itself to uninstall itself (heh), I figured I'd try it from the command line.


[root@server]# rpm -e redhat-config-packages
error: Failed dependencies:
    redhat-config-packages is needed by (installed) firstboot-1.2.4-1

So I'm a bit stuck here. I had to put on a base install because for some reason the installer hated changing CD's. I have a base system with KDE and Apache on it, and that's about it. I can't add packages through the package manager, because I have this error. I can't fix this error because... Well, it's this error. :)

Any advice appreciated. Thanks in advance.

Capt_Caveman 02-25-2004 11:01 PM

Maybe using the upgrade option?

rpm -Uvh new-package-handler-version

or you can be lazy and just let YUM do it for you. I set up a FC1 box not to long ago and was surprised when then the GUI package handler actually worked (turns out YUM auto-updated it).

All times are GMT -5. The time now is 11:18 PM.