-   Fedora (
-   -   Problem running fsck on LVM (

Magmagal 05-16-2008 05:12 PM

Problem running fsck on LVM
Hi all,

I'm trying to manually run fsck on my Fedora 8/Windows XP dual-boot machine (Dell Inspiron 6000), on which the Fedora install is hosed in some mysterious way. I don't think I understand how to do this correctly, since I am running into the following situation:

I insert the F8 rescue CD and boot up. When asked whether I want to mount the filesystem, I choose 'Skip' and go straight to a command line. I want to run

>fsck -c /dev/mapper/VolGroup00-LogVol00 (I believe this is correct.)

However, because I haven't mounted the filesystem, there is no 'VolGroup00-LogVol00' in /dev/mapper.

If I instead boot from the rescue CD and choose to mount the filesystem in /mnt/sysimage, an entry for VolGroup00-LogVol00 appears in /dev/mapper. However, running the above command gives the following warning:

fsck 1.40.2(12-Jul-2007)
WARNING: couldn't open /etc/fstab. No such file or directory.
e2fsck 1.40.2(12-Jul-2007)
/dev/mapper/VolGroup00-LogVol00 is mounted.
WARNING!!! Running e2fsck on a mounted filesystem may cause SEVERE filesystem datage. Do you really want to continue(y/n)?

I of course choose no. I understand that one shouldn't run fsck on a mounted filesystem, but how do I run it on an unmounted filesystem from the rescue CD???

Many thanks in advance for any advice.

rayfordj 05-17-2008 12:36 PM

you can either a) umount the mounted LVs under /mnt/sysimage
or b) bring up the LVM after saying 'no' to finding and mounting filesystems

if b), then

lvm pvscan
lvm vgscan
lvm lvchange -ay
lvm lvscan

the lvscan should show the expected LVs and then you should be able to safely fsck the ones you need to run it on since they will not be mounted.

fsck /dev/VolGroup00/LogVol00 (or whatever the device name ;))

Hope this helps.

Magmagal 05-18-2008 02:42 PM

Thanks - option b solved my problem nicely.

JZL240I-U 05-19-2008 04:21 AM

As a simple workaround for those weary of picking the right PVs:
As root (or user allowed to shut down the box) type at a console "shutdown -r -F now". That'll perform an immediate reboot with a forced file system check (-F option) for all partitions and you can watch the results during boot...

All times are GMT -5. The time now is 07:42 PM.