LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 05-19-2004, 11:48 PM   #1
dhrivnak
Member
 
Registered: Oct 2003
Location: USA
Distribution: Slackware 9.1
Posts: 50

Rep: Reputation: 15
Unhappy Please help! Windows won't boot from grub.


I just installed FC2 on my 'big' computer. I already had WinXP on the primary drive (hda). I put Fedora on hdb. During the install, I chose to use grub, and it saw windows and stuff, so I thought it would be ok. Got Fedora all configured, and decided to try Windoze to make sure it still works. No luck! When I choose it in grub, it simply goes to a black screen and displays the information from /etc/grub.conf that is under the "windows" data. Here are 2 grub.conf files I tried (I've been doing a lot of googling to no avail).

-----after the install-------
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,0)
# kernel /vmlinuz-version ro root=/dev/hdb2
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd1,0)/grub/splash.xpm.gz
title Fedora Core 2
root (hd1,0)
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5-1.358.img
title Windows XP
rootnoverify (hd0,0)
chainloader +1


------after googling-------------(same errors)
default=0
timeout=10
splashimage=(hd1,0)/grub/splash.xpm.gz
title Fedora Core 2
root (hd1,0)
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5-1.358.img
title Windows XP
unhide (hd0,0)
hide (hd0,1)
rootnoverify (hd0,0)
chainloader +1
makeactive
boot


Any help would be GREATLY appreciated! My email and music and stuff is still on the Windows drive, and it is NTFS, so I can't access it from Linux....
 
Old 05-20-2004, 12:53 AM   #2
Ed-MtnBiker
Member
 
Registered: Oct 2003
Location: Reno, NV
Distribution: Fedora Core 3
Posts: 88

Rep: Reputation: 15
For your reading:
http://bugzilla.redhat.com/bugzilla/....cgi?id=115980

Follow all the links and references for a thorough reading.
 
Old 05-20-2004, 01:48 AM   #3
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
Exactly the same installer bug that I've experienced .. follow the instruction on how to recover it back .. or .. just do like what I did .. reformat everything and go back to FC1
 
Old 05-20-2004, 07:38 AM   #4
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Quote:
My email and music and stuff is still on the Windows drive, and it is NTFS, so I can't access it from Linux....
No Fedora expert here, but is there some reason that you can't mount the partition with at least your music so that you could play it? Mail is, of course, a slightly different story, but you would be able to import it into a Linux client, or (if you use Mozilla or Thunderbird under both OSes), you could move the mail folder to a small FAT32 area if you have one available, and then it would be available to Linux and to Windows as well when you get back into it.

Does Fedora 2 not include NTFS read support? I thought that was half of the point of the thing, but I could be mistaken, as I don't follow Fedora closely.
 
Old 05-20-2004, 12:12 PM   #5
dhrivnak
Member
 
Registered: Oct 2003
Location: USA
Distribution: Slackware 9.1
Posts: 50

Original Poster
Rep: Reputation: 15
THANKS!

Thank you to everyone who replied! I ended up changing the HD access mode to LBA, as mentioned in one of the bugzilla reports, and it worked!

Thanks again - you guys are what makes Linux as great as it is!
 
Old 05-20-2004, 01:22 PM   #6
Bambino
LQ Newbie
 
Registered: May 2004
Posts: 16

Rep: Reputation: 0
Hey,

Do you mind posting EXACLY what you did to make it work?
We are a lot of users having the same problem, and still havent been able to solve it...

Thanks in advance
Bambino
 
Old 05-20-2004, 01:31 PM   #7
Ed-MtnBiker
Member
 
Registered: Oct 2003
Location: Reno, NV
Distribution: Fedora Core 3
Posts: 88

Rep: Reputation: 15
I've been reading through bugzilla, and following some of the other threads on this bug. The best "workaround" is to change your BIOS setting from either "auto" or "C/H/S" to "LBA" for the hard drive. Apparently Kernel 2.6 prefers to address the world with LBA and *something* corrupts the partition table in the process. I'd say if you can't change that setting in your BIOS and can't afford to lose your XP partition, then hold off until more is understood about this problem.

Many people are quoting a workaround that says, "boot from your XP cd and fixmbr". Many other people are also saying this doesn't repair the partition and allow booting.

I'm actually *very* disappointed that Fedora was released with this bug. It sure takes the "community" out of the "community-oriented" distro. I'm all for it being a testbed for RHEL, but there are a lot of things that are annoying (mp3 support, usb pen drive automount, disabled NTFS read support, my Olympus Stylus 300 STILL not supported, SELinux, this bug). I've only used RH distros since 6.2, but now I'm thinking about trying out Gentoo and maybe a few others. I've read the threads on the RH devel mailing list, and I was really disappointed at the tone and nature of the responses.

I'm happy to deal with bugs that have workarounds, but this is *serious*. It doesn't happen on all boards & systems--and be thankful if you have a system that just works.

I'm sorry for my rant, but this is something so serious that I can't give my buddes a copy of the FC2 CDs, and say "go for it, you won't mess anything up."

Last edited by Ed-MtnBiker; 05-20-2004 at 06:05 PM.
 
Old 05-20-2004, 05:19 PM   #8
dhrivnak
Member
 
Registered: Oct 2003
Location: USA
Distribution: Slackware 9.1
Posts: 50

Original Poster
Rep: Reputation: 15
This is what I did:

- boot computer
- go into BIOS
- go to the section that shows the HDs
- go into the menu for the HD
- change 'access mode' from 'auto' to 'LBA'

Of course, this may be a bit different depending on your BIOS...

Hope that helps!
 
Old 05-20-2004, 05:59 PM   #9
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
Quote:
Originally posted by Ed-MtnBiker
I've been reading through bugzilla, and following some of the other threads on this bug. The best "workaround" is to change your BIOS setting from either "auto" or "C/H/S" to "LBA" for the hard drive. Apparently Kernel 2.6 prefers to address the world with LBA and *something* corrupts the partition table in the process. I'd say if you can't change that setting in your BIOS and can't afford to lose your XP partition, then hold off until more is understood about this problem.
I don't think it is the kernel .. but most probably more on FC2/Grub specific .. I don't have problem running kernel 2.6.6 on FC1 .. definitley it wasn't the kernel that 'corrupts' the partition table ..
 
Old 05-20-2004, 06:07 PM   #10
Ed-MtnBiker
Member
 
Registered: Oct 2003
Location: Reno, NV
Distribution: Fedora Core 3
Posts: 88

Rep: Reputation: 15
Quote:
Originally posted by wiraone
I don't think it is the kernel .. but most probably more on FC2/Grub specific .. I don't have problem running kernel 2.6.6 on FC1 .. definitley it wasn't the kernel that 'corrupts' the partition table ..
You're definitely right. Apparently this issue is also showing up in Mandrake 10, and one of the other big distros. Likely suspects seem to be GRUB and parted, but I haven't read anything where someone quotes some code and says, "THIS is the problem!"

I just hope it gets resolved soon!
 
Old 05-20-2004, 06:42 PM   #11
windeath
Member
 
Registered: Feb 2004
Location: Melbourne - Australia
Distribution: Any and all
Posts: 65

Rep: Reputation: 15
This is unbelievable!!!! I have just had to reformat my entire 80Gb and reinstall WinXP. I have been through http://bugzilla.redhat.com/bugzilla...g.cgi?id=115980 and am still dumb founded. I am lucky in what was on my HDD wasn't all that important (mind you I think my wife is about ready to divorce me) but this is just bulls&*t. FC1 was an absolute dream to install I have had NO issue at all with any part of FC1 but I'm looking at FC2 with dagger eyes at this stage.

I'm bloody furious with what I'm having to do just to get an OS installed. Please don't get me wrong I can't stand the clunkiness of XP, but by God it's nowhere near as frustrating just to get on the hard drive and booting.

Now that thats out of the way, I'm going to try the LBA change tonight and see if that works.....if not another post will be forth coming with more expletives.
 
Old 05-20-2004, 07:01 PM   #12
rberry88
Member
 
Registered: Aug 2003
Location: Arlington Heights, IL USA
Distribution: Fedora Core 1 & WinXP Pro & Gentoo 1.4 & Arch Linux
Posts: 558

Rep: Reputation: 30
You guys do know that you could just boot with your WinXP installation disc and instead of installing Windows again just go to recovery and type in "fix boot" without the quotes. This will correct how Grub passes off to Windows at boot time. If you really screw things up, you can also do "fix mbr" from the recovery console and then re-install Grub and configure to your liking.

I don't see it as a problem with FC2, pretty much all distros have this problem if something quirky happens when Grub attempts to pass of booting to Windows. Its more to do with Windows wanting to be in the mbr and not wanting to share with Grub.

Just my 2 cents.

rberry88
 
Old 05-20-2004, 07:39 PM   #13
Ed-MtnBiker
Member
 
Registered: Oct 2003
Location: Reno, NV
Distribution: Fedora Core 3
Posts: 88

Rep: Reputation: 15
Quote:
Originally posted by rberry88
You guys do know that you could just boot with your WinXP installation disc and instead of installing Windows again just go to recovery and type in "fix boot" without the quotes. This will correct how Grub passes off to Windows at boot time. If you really screw things up, you can also do "fix mbr" from the recovery console and then re-install Grub and configure to your liking.
The Bugzilla reports seem to say that that XP cannot repair itself in this situation, such as the report below:
http://bugzilla.redhat.com/bugzilla/...i?id=115980#c9

Last edited by Ed-MtnBiker; 05-20-2004 at 09:58 PM.
 
Old 05-20-2004, 07:52 PM   #14
windeath
Member
 
Registered: Feb 2004
Location: Melbourne - Australia
Distribution: Any and all
Posts: 65

Rep: Reputation: 15
Tried that rberry88...no effect.
 
Old 05-21-2004, 12:30 AM   #15
rberry88
Member
 
Registered: Aug 2003
Location: Arlington Heights, IL USA
Distribution: Fedora Core 1 & WinXP Pro & Gentoo 1.4 & Arch Linux
Posts: 558

Rep: Reputation: 30
Okay, by reading the bugzilla posting from the link you provided it seems it pretty much only affects the users that are setting up Linux partitions when installing FC2 (or FC1) for that matter.

If you were previously dual booting with WinXP and FC1 and you are doing a upgrade then I would do just that, upgrade. Don't re-partition your drive(s) on an upgrade because that is what, it seems, is causing the problem -- if you want to re-partition your drive then you should first back up (onto disc) the info that you want carried over and do a fresh install and partition accordingly.

If you did a normal "upgrade" (i.e. no repartition, just update grub etc) then there would be no reason for the geometry readings on the partitions/drives to change which seems to be the common denominator of this problem. If you read the last few entries in that bugzilla link then you will see that the problem has been minimized to these instance (upgrade w/ re-partition) otherwise the simple "pop in the WinXP install (recovery) CD and fix boot or fix mbr" has worked fine for the others that have encountered this problem with a "normal upgrade".

rberry88
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grub question changing boot order making windows boot first nfsutim Linux - Newbie 29 10-27-2012 12:53 PM
GRUB boot loader blocking windows boot julienroger Linux - Newbie 3 10-12-2004 01:11 PM
GRUB using /boot partition for multiple Linux/Windows boot? cpv204 Linux - Newbie 7 04-01-2003 03:54 PM
Boot windows 98,windows XP and linux by GRUB Swift&Smart Linux - General 6 02-22-2003 09:11 AM
How to add a boot record which used to startup windows under my Grub boot loader? yunxiang Linux - Newbie 6 02-01-2003 02:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 07:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration