-   Fedora (
-   -   PATA IDE RAID device exclusion (

penguinpages 09-05-2007 10:30 AM

PATA IDE RAID device exclusion
Shuttle Motherboard
2x 250 Maxtor PATA HDD Master and slave primary channel
2x DVD Burners PATA Master and slave secondary channel
Goal: This first set of drives was to be RAID1 for OS. Next four drives will be off a SATA RAID controller and be RAID 5. I had to move from Redhat 8 due to drive failure. The Promise 6channel ATA RAID controller did not support any of the newer kernels so I have to rebuild from scratch.

The new master system will run my VMs for my lab. I acquired a new motherboard which has P-ATA controller integrated. If I use Fedora 7 or the latest Fedora 8 Test1 I have the system come up with drive detection as /mapper/pdc_dijfeefigd vs the expected /dev/hda /dev/hdb

'cat /proc/partitions' shows the drives as /dev/sda /dev/sdb and 'lsmod' shows two devices bound to 'sd_mod'

I booted SLES 10 DVD I had and it sees the drives as IDE with a note that the motherboard had basis RAID but due to support it was going to talk to the drives as IDE devices. I do not want to use SLES due to familiarity of RH, that 98% of the work I will do on that server is to be shell only for maintenance,(it runs my VMs so is lean and mean), and that I have scripts setup to fire VMs up based off the original RedHat 8 base.

I have two options:
1) Use the PATA RAID function. The BIOS has no option to enable mirroring of the two devices. I found no "windows gui" or such to configure it.

2) Disable the kernel from treating it as a hardware RAID device. I DO want to mirror them but LVM was what I was expecting to do anyways.

kuitang 09-06-2007 07:28 PM

I'm assuming your integrated RAID is really BIOS-assisted software RAID as it usually is. If so, use LVM. It's a hell of a lot more flexible than BIOS-assisted rate and won't cause any major performance impact because the RAID is software either way.

penguinpages 09-07-2007 08:01 AM

That would be the desire. But the question stands. How do I get the Fedora installer to see the drive definition as


At the moment it is classifying the drives on a raw level as

Is their a boot kernel parameter I can send to the system to NOT attempt to load the specific RAID configuration? My fall back is to load the system with older version of Fedora and then do upgrade.. Which is likely what I will be doing today. Load Zod(FC6) and doing upgrade to 7.9.

penguinpages 09-11-2007 09:32 AM

This is annoying....

SLES 10 install with basic server and I manually laid out the drives
/dev/hda1 (100M)
/dev/hdb1 (100M)
/boot md0 (Raid1)

/dev/hda2 (1024M)
/dev/hdb2 (1024M)
swap md1 (RAID1)

/dev/hda3 (20G)
/dev/hdb3 (20G)
/ md2 (RAID1)

/dev/hda4 (220G)
/dev/hdb5 (220G)
/home md3 (RAID1)

System works fine. But I go to install Fedora and reuse the existing partitions and all the installer can detect is this mapper/pcd_dijfeefigd 239367 MB (Linux Device-mapper)

I simply want to install Fedora on the drives and use software RAID.

Is their any way to force Fedora to look at the drives partition definition which I would think would require me to force a generic IDE module to load and to unload this RAID module. I would assume these would have to be passed to the Anaconda installer at boot time.

PTrenholme 09-11-2007 10:21 AM

You did note, I hope, that Fedora 7 uses /dev/sda for PATA drives as well as SATA drives. So the fdisk output you show is what's expected for two PATA hard drives.

I'd suggest that, instead of FC6, you use the Fedora 7 live cd and LVM to set up your RAID configuration on the drives, leaving room for a simple ext3 partition on one of them for /boot to live in since GRUB doesn't understand LVs.

Then install Fedora 7 from the live CD to the RAID drives. (You'll, of course, need to update once the system's installed.)

Note: This advice is from "book learning," not experience, and should have salt added before being taken.

penguinpages 09-12-2007 03:05 PM

I followed a similar path. I did a full install of SLES 10 on the RAID devices.

Is the "Live CD" any different from the Fedora 8 test1 CD for the function of creating RAID sets.

If I go into the anaconda installer it shows the /dev/sda partitions but the anaconda script only allows me to see the /dev/mapper (hardware abstracted RAID device.

Is their a way to get anaconda to see the /dev/sda /dev/sdb devices at a raw level as selectable?

penguinpages 09-20-2007 04:57 PM

Wanted to post update.

I got time to come back to this test / system and found out some odd things.

Did a full install of SLES 10 on the system and it addressed the drives as /dev/hda

It did note that their was a basic RAID controller but that it was not able to be used.

Tried to complete an 'upgrade' to the system via FC7 (and later a FC8) CD and both only saw
/dev/md0 type Software RAID
/dev/md1 type Software RAID
/dev/md2 type Software RAID

I figured I would see what would happen if I let Fedora address the drives as RAID (/dev/mapper) target and then hope that it was enabled as RAID1

Did the install and formated the partitions. Completed install and set BIOS to accept boot order as: HD0, HD1, Disabled.

Booted system and created a text file.

Shut system off and unplugged power from HD0 drive.

The system booted, Grub loaded and started to boot then hangs with kernel error:

ioctl: 4.11.0-ioctl (2006-10-12) initialised:
device-mapper: table: 253:0: mirror: Device lookup failure
device-mapper: ioctl: error adding target to table
device-mapper: reload ioctl failed: No such device or address
Unable to access resume device (LABEL=SWAP-pdc_dijfee)
mount: could not find filesystem '/dev/root'
setuproot: moving /dev/ failed: No such file or directory
setuprooot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!
I assume this means that the drive configuration is some form of RAID0 then by default. But no GUI or interface / menu in BIOS to change definition (nor even a Windows Gui to set it and reload with Linux)

So. I tried Fedoa 5 and it also sees the drives as /dev/mapper (and from shell as raw /dev/sda /dev/sdb) is their ANY way to allow them to see the drives as /dev/hda /dev/hdb like SLES 10 does?

I guess my only option is to use SLES.

All times are GMT -5. The time now is 03:14 PM.