-   Fedora (
-   -   Partition 1 does not end on cylinder boundary. (

Galaxy_Stranger 08-11-2009 10:33 PM

Partition 1 does not end on cylinder boundary.
I just built a new machine this last weekend to use as a file server with 64bit Fedora 11. At the end of the install, I get a very long error window that looked something like this:

"/usr/lib64/python2.6/site-packages/firstboot/" line 87, in loadModules
loaded = imputil.imp.load_module(module, found[0], found[1], found[2])

"/usr/share/firstboot/modules/" line 34, in <module> import functions

Import Error:  No module named functions

So, I hit OK and proceed with the boot. The desktop comes up and I go about my business. Along the way I do an "fdisk -l" and get this:

$fdisk -l

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0004ed49

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1  *          1          13      102400  83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2              13        535    4194304  83  Linux
Partition 2 does not end on cylinder boundary.
/dev/sda3            535      38913  308271937  83  Linux

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000e8fd7

  Device Boot      Start        End      Blocks  Id  System
/dev/sdb1              1      121601  976760001  83  Linux

I've only found a couple vague threads about this issue that date back to 2005 or so. After a few reboots, I get this horrible "screw you - i'm not gonna boot" error that was very cryptic and long so I didn't write it down.

Am I having this issue because I'm using multiple file systems on one drive? I have /boot, /, and swap. /boot is ext3 and / is ext4. Can this be fixed w/ gparted?

Laurens73 08-12-2009 09:13 AM

Different types of partitions shouldn't be a problem. You even can use Windows on the same hard disk. In my opinion the use of more partitions, especially a separated /home is better than using everything on one root partition. I've heard a lot about problems with ext4 partitions used as root, the system hangs or gives a few minor looking errors, and after the next reboot the system won't start anymore. The people who I know who had this problem too tried to fix the ext4 partitions with fsck.ext4 and all lost their data on it. A solution for the problem you discribe is something I don't have at this moment. I hope some one else has.

Galaxy_Stranger 08-13-2009 01:55 PM

Well, I'm going to reinstall w/ 32bit Fedora 11. I have never had a 64 bit version of any operating system that didn't have weird little problems like this. Frankly, I've never seen any particular advantage.

I'm not living with the drive in this state - I can't get an answer one way or the other just what the problem is and I don't want it biting me in the ass later on...

I'll post the results after the dust has settled.

Laurens73 08-13-2009 01:59 PM

I think the 32bits or 64bits install shouldnt give problems with your partitions. Are you going to install it with ext4 again?

Galaxy_Stranger 08-13-2009 09:04 PM

I know that 64 bit OS's shouldn't have these kinds of problems, but the Fedora 11 partitioning software might. MANY more retarded things that this have happened.

I'm going to use EXT3 w/ the 32 bit installer, check it out, and then try the 64 bit installer without repartitioning.

Galaxy_Stranger 08-14-2009 01:05 PM

I repartitioned with the 32bit Fedora 11 live cd. /boot and / are EXT3. There was an option to end on the cylinders.

I then started the 64bit Fedora 11 DVD installation - there was no option to end on cylinders, so I didn't repartition. The installation went as normal, but I still get the "Firstboot" error.

I can only assume that a firstboot error only misconfigured something minor on the system.

Laurens73 08-14-2009 04:41 PM

Sorry, I haven't got a clue at this moment :(

Robert Carnegie 08-21-2009 11:31 PM

I've just been searching the Web for an explanation of the particular error message,

"Partition X does not end on cylinder boundary"

Nowhere attached to a comprehensive answer, I think it just shows that even power users regard disk partitioning as black magic.

I'm actually attempting to use Knoppix 6.0.1 Live CD to backup and fine-tune a new Windows XP Home computer, a Gigabyte M912. But many Linux systems have issues here, particularly with Windows involved.

Some promising accounts are in:

But you can sound like you know what you're talking about when really you don't.

But according to these sources, what's going on is:

1. Historically hard disk space was addressed by cylinder/head/sector. A hard disk drive has multiple platters (actual discs) on which separate concentric data tracks are recorded (a set of corresponding tracks on multiple platters being a "cylinder"), each track containing multiple 512 bytes storage spaces (sectors). This is CHS and is supported by BIOS.

2. On a modern hard disc, that design either is not true or may as well not be, because modern discs exceed one or more of the limits of the CHS specification, which are 1024 cylinders, 255 heads(!), 63 sectors. This is addressed either by using a false CHS design - say a disc with 1 head and 255,000 cylinders reports itself as 255 heads and 1,000 cylinders - or by giving up on this altogether, simply selecting hard disk ssectors by numbering them (0), 1, 2, 3, ... across the entire disk, and calling it "Logical Block Addressing" or LBA.

3. When launched, at least, some BIOS did not understand LBA discs, which matters because BIOS must find and boot your operating system on disc (if that's where it is). CHS had to still work well enough to find the OS on those computers.

4. A further limitation, although not necessarily compulsory, was that a disk partition would be sized to whole cylinders - that is, to start at cylinder X, head 1, sector 1, and also to end at the last sector in one cylinder. However, a modern partition table also contains LBA addresses of a partition start and end.

5. Two other claimed features of CHS on an LBA disk: (1) different operating systems may generate their own fake CHS addressing, and with different results, including a disc where the LBA sectors do not leave CHS with a number of full cylinders. One of the imaginary cylinders may be only half actually existing as disk space.

6. Microsoft Windows XP or Vista, now able to use LBA, are liable to create or use partitions that don't respect cylinder boundaries or last cylinder size. None of the Linux partition tools (fdisk, sfdisk, cfdisk, parted) like that, even if the rest of Linux as well as Windows recognises the partitions as working, valid, and bootable. cfdisk crashes, calling it a "fatal error".

For instance, my computer reports /dev/sda1 in cylinders 1-10,444 (that's Windows XP boot on NTFS), /dev/sda2 in 10,444 or 10,445 till 18,965 or 18,966 (FAT32), and /dev/sda4 in 18,965 to 19,457, which is pretty uch the end of the disk. And that is a system re-install partition for Windows XP Home but apparently held in ext2. And apparently the filesystem is smaller than the partition.

So it's better just for these tools to respect imaginary cylinder boundaries on the disk - if my sources are wrong and tools do agree on what and when those boundaries are.

GrapefruiTgirl 08-21-2009 11:48 PM

Hi you guys :)

You're (Lauren & Robert) pretty new here, so "Welcome to LQ!!", and hello Galaxy!


The message about the partition/cylinder boundaries is merely informational. It's nothing to be alarmed about. I believe you'll find some other references to that exact message, elsewhere here on LQ, so don't take my word for it -- have a look around ;)

For the record: I have been running Slackware64-current for umm... I can't remember exactly how many weeks now, or maybe better than 5-6 weeks anyhow.. But my point: I've been using Ext4 for the first time with this system (and incidentally it's my first 64 bit Linux too) and I haven't had any troubles with Ext4. Now, this isn't to say there are NO PROBLEMS or BUGS -- there may well be, but I haven't yet experienced any.

As for having different filesystems on different partitions, on the same drive, that's no problem either. However, it helps to have the necessary support (modules, drivers) for all of the filesystems, enabled within each OS you might have installed. This way, you can access each of your filesystems/partitions, from any OS, whenever you want.

It's worth noting that Ext2, Ext3, and Ext4 are basically the same; it's evolution ;) and it's even possible to 'upgrade' Ext2 --> Ext3 (with small limitations) and also perhaps to upgrade Ext2/3 --> Ext4 (again with some limitations) but deep down, they're very similar. Ext3/4 have journaling, while Ext2 does not.

Also, for the record, Fedora tends to be a 'bleeding edge' distro, and so I suspect F64 is probably even *more* bleeding edge, and therefore may be prone to less stability than something regarded as "more stable".

I hope this helps :)

Best of success,

Laurens73 08-22-2009 11:19 AM

GrapefruiTgirl, thanks for your welcome and thanks for the info bout Fedora Core /64 and its stability

GrapefruiTgirl 08-22-2009 11:26 AM

No worries, glad you found it informative.

Enjoy the forums,


karamarisan 08-22-2009 12:19 PM

If I may offer a counterargument, in my experience, there is no reason to doubt 64-bit software, at least for Fedora. x86_64 is a fully-supported architecture, and we aren't talking about something fundamentally different from the baseline i586, either. FWIW, I've been using 64-bit distros almost exclusively for at least two years now, mostly Fedora, and I can't recall running into any architecture-specific problems (Flash, etc. aside, because that's not what we're talking about here).

OP, I'm glad you got it working, but I'm worried you're coming away from this with some serious misinformation. 64-bit/32-bit has nothing to do with disk partitioning, mixing filesystems is absolutely fine (as that is the entire point), and as Robert Carnegie's very thorough post explains, the geometry being referenced there is imaginary.

From the stable, happy, x86-64 Fedora 11 I am typing on:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf3176fb9

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1              1          26      204800  83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2              26      19457  156083521  83  Linux


/dev/sda1 on /boot type ext3 (rw,noatime,nodiratime)
/dev/sda2 on / type ext4 (rw,noatime,nodiratime)

In the future, if you run into such issues, you shouldn't be so quick to blame specific things like this. Had I gotten here sooner, I'd have suggested you switch to the DVD installer (or live CD, if you tried the DVD first), as I am entirely sure that the problem you ran into is not related to the way your disk is partitioned, and the only way it could be an x86_64 problem would be if someone failed to test the install disk sufficiently (which is unlikely given that it's #2 on their list of supported architectures).

GrapefruiTgirl 08-22-2009 12:30 PM


Originally Posted by karamarisan (Post 3653630)
If I may offer a counterargument...

But of course :) -- and as a Fedora user, especially so.


Originally Posted by karamarisan
in my experience, there is no reason to doubt 64-bit software,

Nor in mine, so far. And I don't plan on switching back to 32 either.


Originally Posted by karamarisan
at least for Fedora. x86_64 is a fully-supported architecture, and we aren't talking about something fundamentally different from the baseline i586, either. FWIW, I've been using 64-bit distros almost exclusively for at least two years now, mostly Fedora, and I can't recall running into any architecture-specific problems (Flash, etc. aside, because that's not what we're talking about here).

Particularly important information above; if I neglected to mention it earlier, I use Slackware, not Fedora, and have never even tried Fedora. My comment about relative stability ( sounds like a meteorological term :scratch: ) is based on reading in umpteen dozens of places, that Fedora is (whether officially/unofficially) the "testing platform" for RedHat. If this is not so, please Karamarisan correct me on this.

Thanks Karamarisan,

karamarisan 08-22-2009 01:00 PM

Sort of. As I understand it, first, there was Red Hat (the company and the distro). Red Hat (the company) realized that since their business model was built around GPL-compliant OSS, they might as well build a community like Debian, etc. have, so they created Fedora, which was the community offshoot. At some point, releases of RHEL started being based off versions of Fedora - for example, I believe the current F11 is due to become RHEL 6. It's its own distro, its own project, its own community, etc., it just receives a lot of support from Red Hat because they have a commercial interest in it. I like that model, personally - at least in theory, you get all the benefits of both community-driven OSS and having a corporation with money and people on payroll contributing its resources.

So, yes, the Red Hat people provide a Enterprisey distro, and so they are interested in tested, stable, world-tested software, at the expense of features if need be. Fedora is totally community-driven and values being up to speed, feature-wise, so they're much closer to the bleeding edge. This may be slightly outdated, but for a good part of 2008, I was as up on Ubuntu as I am on Fedora (it paid), and my impression was that Fedora is usually one step behind it, though not always (Fedora got Firefox 3 beta before Ubuntu, I believe).

And please, call me Ted. No one has ever pronounced my handle correctly on the first try; its primary and sole useful attribute is that it is never, ever taken. :)

GrapefruiTgirl 08-22-2009 01:21 PM

Heh :) thanks for the feedback here, both for myself, and for the OP.

And, I *think* I "pronounced" your nickname correctly, though pronouncing stuff with a keyboard is a funny thing ;)

Cheers, Ted


PS - at least I spealt it correct :p

All times are GMT -5. The time now is 06:59 AM.