-   Fedora (
-   -   nVidia GL Tearing (

FLOODS 04-07-2005 05:46 PM

nVidia GL Tearing
After installing the nvidia-glx and kernel-module-nvidia as per instructed here, I get a lot of tearing when playing OpenGL based games (UT2004, Wolfenstein: Enemy Territory). I've went into /etc/security/console.perms and commented out the dri sections with no luck, so I put the file back to how it was just to keep things simple until I get it fixed. I have no idea where to start. I've turned off all antialiasing, anistropic filtering, and texture sharpening. Under the OpenGL section in Nvidia X Server Settings, I have Allow Flipping checked (it seemed important, said applied immediately), with Sync to VBlank off. Tried VBlank on with no luck, either. Under X Server XVideo Settings, I also tried Sync to VBlank in both areas (Video Texture Adapter, Video Blitter Adapter).

I have also tried manually installing the drivers with the same outcome.

This is on a P4 System with an ASUS P4P-800E Motherboard. The card is an Nvidia GeForceFX 5600. Here the information clipped from the Nvidia program.

Graphics Processor: GeForceFX 5600
Bus Type: AGP
VBIOS Version:
Video Memory: 128MB
IRQ: 10
Operating System: Linux-x86
NVIDIA Driver Version: 1.0-7167

glxinfo | grep OpenGL returns

[fragile@acheron ~]$ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce FX 5600/AGP/SSE2
OpenGL version string: 1.5.3 NVIDIA 71.67
OpenGL extensions:

also tried this with no luck

Edit your .bashrc file (or /etc/bashrc as root) and add this line:

export __GL_SYNC_TO_VBLANK=1

So how can I fix this tearing problem? Searching through the net didn't produce any help either, I only found one person who had this problem and they never responded if they actually have it fixed or not. Has anyone seen this fixed?

Thanks ahead!

EDIT: My refresh rates for my monitor in my xorg.conf are ..

Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "Monitor Vendor"
        ModelName    "SAMSUNG"
        DisplaySize  320        240
        HorizSync    30.0 - 85.0
        VertRefresh  50.0 - 160.0
        Option      "dpms"

This is a Samsung 700DF, and I think the only difference is the monitor is able to HorizSync at 30 - 96, I'll try changing it and see if it works afterwards. I changed it once and was getting a monitor out of sync message during boot, but once gdm starts it disappeared. Strange

EDIT: Also uninstalled the latest nvidia driver and installed 6629 from nvidia's site with same outcome. Now am trying NvAGP "1" with no luck, maybe 2 will do it. er, tried with NvAGP "2" with no luck either. I'm running out of ideas fast. I guess I'll try pulling the 6800GT out of my other machine and plug it in here.

FLOODS 04-09-2005 11:04 AM

There's a slight screenshot of it if it's able to be made out. Had to hit escape to take it since it won't let me while in game. If you look at the right edge, however, you can tell it's there. A lot of corruption.

All times are GMT -5. The time now is 06:09 PM.