-   Fedora (
-   -   NVidia drivers with Fedora 1 (

jlacroix 11-07-2003 10:35 PM

NVidia drivers with Fedora 1
How the heck do I install the NVidia drivers? I got them to work in RH9 but it won't install with Fedora.

It says it can't find something or other for my kernel, and if I force the install it returns with an unexplainable error. What gives?

opafire 11-07-2003 10:51 PM

copy the kernel source code from your fedora disk 3, and install it. It is an rpm file and you'll install it like this, 'rpm -i kernel-source.rpm'. after that run the driver program again and read your options carefully. Say "no" to searching for one on the net then you'll have to say "ok" to compiling one from the kernel source code. It will compile a module and install it for you.

jlacroix 11-07-2003 10:55 PM

I'll try that, but when I installed it I chose the "everything" install.

opafire 11-07-2003 11:22 PM

before you install the driver one thing you need to do (sorry I forgot to mention this before) is as root run the line "export CC=gcc32" that will set the proper C compiler to be used for the driver compilation and install.

jlacroix 11-07-2003 11:38 PM

Do I run that in the shell, exactly as is?

Like Bash#: export CC=gcc32

Or something like

Bash#: nvidia-installer export CC=gcc32

opafire 11-08-2003 12:31 AM

Like Bash#: export CC=gcc32

just like you have it there.

Bobmeister 11-08-2003 05:23 AM

Yes, this should work. The reason is that GCC 3.3 is the default GCC in Fedora, but the kernel was compiled with GCC 3.2. So, modules using the source code should be built
with GCC 3.2 also. Exporting this variable will force the installer to use GCC 3.2 and will avoind the mismatch warning. Worked perfectly for me.

FXRS 11-08-2003 03:09 PM

Heres my deal.......

Well I reinstalled XFree86-Mesa-libGL after I uninstalled it to get the vid driver to work right. I wanted to install mplayer well it need that app, so I reinstalled it, no I can't play E.T.

So now what do I do?


DrD 11-12-2003 02:32 AM

Ah freaking A-
Ok, this is like hurtle number 3 (and hopefully the last) in the process of trying to get the Nvidia drivers installed.
Ok, I went to install the rpm kernel source package. It told me it had failed dependencies -
Thisis what it said, actually:

error: Failed dependencies:
gcc >= 2.96-98 is needed by kernel-source-2.4.22-1.2115.nptl
gcc32 is needed by kernel-source-2.4.22-1.2115.nptl

Rats, I said. So I ran export CC=gcc32 first, ran it again. Same exact error.
So, I though I'd just double click the rpm file and install it that way. Only problem is, it started to work, then asked for Fedora CD-2. Only it didn't mount it or something, and had an error and stopped. AH!
I went to install it again, it said it was already installed
So I went into add/remove applications, and figured it would be under "kernel develoupment" (I was just going to uninstall it) Only it won't uninstall it, it's dumb enough that it stops trying when it notices there's afile it was expecting to erase but it's not there (you think someone would be smart enough to just have it remove whatever files it finds).
ANYway... I tried rpm -e kernel-source*.rpm, from the terminal, and it says it's not installed!!!!! Double checked my spelling. SO, the terminal thinks that RPM is not isntalled, the X windows system does.

Summed UP:
All I need is the kernel source installed, so I can install the nvidia drivers, so I can play freaking tux racer. Anyone know how to make Fedora think a package isn't installed anymore? Please help!

wiraone 11-12-2003 03:36 AM

Read this thread:

What you need is the development kit to be installed first. Download the latest redhat-config-packages (link is available from the above thread, the one from Fedora Core 1 is buggy), run Add/Remove Packages and add the Development Tools and Kernel Development.

cybrjackle 11-12-2003 10:43 AM

You can also go here:

bluester 11-12-2003 12:09 PM

Try this site:

All times are GMT -5. The time now is 12:13 AM.