-   Fedora (
-   -   ns2.33 intallation and path setting (

vahitha 07-08-2010 01:24 AM

ns2.33 intallation and path setting
i want clear installation and path setting steps for installing ns2.33 in linux fedora 12.please any one of linux experts help me.thankyou.

knudfl 07-08-2010 03:39 AM

Welcome to LQ. .. .. :)

All ns2 threads at LQ are tagged ns2.
LQ Search → Tag Name = ns2

Fedora 10 - 11 - 12 : post #3 here

Path : Either try with the path settings suggested, when
you have finished ' ./install ' for ns-allinone-2.33,
Or : install some very few files to a system path :
cd ns-allinone-2.33/otcl-1.13/ &&
./configure --prefix=/usr --enable-release --enable-devel
&& make , # make install
cd ../tclcl-1.19/ &&
./configure --prefix=/usr --enable-release --enable-devel
&& make , # make install
cd ../ns-2.34/
# make install
cd ../nam-1.14/
# make install

vahitha 07-21-2010 01:00 AM

hello sir,
thank you sir.
your instructions were helpful.
i followed following instructions to install ns2.33 in fedora 12

cd ns-allinone-2.33

sudo gedit ~/.bashrc
#environment values for NS2/NAM
OTCL_LIB=/your directory/ns-allinone-2.33/otcl-1.13
NS2_LIB=/your directory/ns-allinone-2.33/lib

TCL_LIB=/your directory/tcl8.4.18/library

XGRAPH=/your directory/ns-allinone-2.33/bin:/your directory/ns-allinone-2.33/tcl8.4.18/unix:/your directory/ns-allinone-2.33/tk8.4.18/unix
NS=/your directory/ns-allinone-2.33/ns-2.33/
NAM=/your directory/ns-allinone-2.33/nam-1.13/

source ~/.bashrc
cd ns-2.33

now i cleared ns in installation.when i type ns whereever in commandpropt i can get %. but i m struggling with nam.when i type nam i got instruction like following.
[code omitted because of length]
: no event type or button # or keysym
while executing
“bind Listbox {
%W yview scroll [expr {- (%D / 120) * 4}] units
invoked from within
“if {[tk windowingsystem] eq “classic” || [tk windowingsystem] eq “aqua”} {
bind Listbox {
%W yview scroll [expr {- (%D)}] units
bind Li…”

what steps should be follow to rectify this inconvinent.
please help sir

knudfl 07-21-2010 01:17 AM

1 Attachment(s)
Please read post #2
REPEAT : Fedora 10 - 11 - 12 : post #3 here

ns-allinone-2.3x also requires the tk-8.4-lastevent.patch :

cd ns-allinone-2.33/tk-8.4.18/
patch -p0 < tk-8.4-lastevent.patch

And run ./install again : Only tk4.8.18 and nam-1.xx will change,
and you should now get a 'nam' that works. _ _ _ :) _

vahitha 07-21-2010 09:17 PM

ns2.33 installation and path setting in fedora12
thankyou sir
i patch the tk-8.4-lastevent.patch file from /ns-allinone/tk8.4.18/
nam is also worked well.

now i executed one tcl program.i can view the result in nam sucessfully.
then,when i execute it with ns program_name.tcl from command prompt the part of my program is executed and i can see the calculated through put and delay terminal window.

i couldn't get it in graph.
error :ns: proc_name: couldn't execute "xgraph": no such file or directory

what are the steps should be followed and what are the possibilities to get these?

i check well in path setting for xgraph also.
please help me to execute my program successfully.


knudfl 07-22-2010 01:26 AM

'xgraph' is not considered important, and was never created.
It's a old tool, 2001 and will usually not build on a new Linux.

But you can use a binary from a Debian package :
> xgraph_12.1-10_i386.deb
Unpack with : 1) ar -x xgraph_12.1-10_i386.deb
2) tar xvf data.tar.gz , and copy 'xgraph' to /usr/local/bin/

Can be tested with ns-allinone-2.34/xgraph-12.1/examples/...

vahitha 07-22-2010 11:41 PM

i followed your suggestions to install xgraph.
it is installed sucessfully.
when i execute builtin xgraph from /xgraph-12.1/example/
it is executed sucessfully.
but when i execute my program,i received "problem in input" message.
in which part i should concentrate?

part of my program
# Plot Recorded Statistics

exec xgraph -geometry 800x400 -t "NO OF PACKET RECIVED AT SINK" -x "Time" -y "Receive packets" &

exec xgraph -geometry 800x400 -t "Throughput-Perfomance-Evaluation" -x "Time" -y "Receive packets" &

exec xgraph -geometry 800x400 -t "Bandwith" -x "Time" -y "Received bytes" &

exec xgraph -geometry 800x400 -t "End-to-End-Delay" -x "Time" -y "Received bytes" &

please help me.

knudfl 07-23-2010 03:34 AM

Not a subject I know much about, but is xgraph supposed to use
.tr files directly ?
Or should "" be filtered into a new file = "out.xgr" ?

Google .. ns2 display .. ( 1,000,000 hits ) Examples :
QUOTE : "awk filters the trace file using filter fil2.awk and
directs the output to out2.xgr (to be displayed with xgraph later on).
Same with fil4.awk and fil6.awk."

vahitha 08-25-2010 02:39 AM

thankyou sir.
i need to know how to uninstall ns2.33 from fedora 12. i cannot delete ns-allinone-2.33 folder from root directory.
if i delete the message displays as "permission denied"
please tell me how to delete ns2 permanantly.

DukeSSD 08-25-2010 06:55 PM

Hang on a minute...
Why is this thread on the AIX forum?

Shouldn't it be over here:

dev_crazy56 03-12-2011 12:52 AM

hello Sir knudfl,

Your solution was fantastic and my nam worked perfectly well with your patch file. But after a few runs it failed to work again. It gave some weird message like.....

[code omitted because of length]
: no event type or button # or keysym
while executing
"bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D / 120) * 4}] units
invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D)}] units
bind Li..."

And when i tried.....

/ns-allinone-2.33/tk8.4.18$ patch -p0 < tk-8.4-lastevent.patch.txt

it gave a message like......

patching file generic/tk.h
Reversed (or previously applied) patch detected! Assume -R? [n] n
Apply anyway? [n] y
Hunk #1 FAILED at 635.
1 out of 1 hunk FAILED -- saving rejects to file generic/tk.h.rej

Sir i am using Ubuntu 9.10 and in the middle of my college project. I will be always grateful to you if you could help me.

thank you

knudfl 03-12-2011 02:11 AM

Post # 11, @dev_crazy56 : Welcome to LQ. .. .. :) ..

Nam is a separate application : Any 'nam' can be used.
> > nam-1.14.i586.tar.gz

Untar the package to /usr/local/bin/ : And it is in a system path.
Or 'tar xvf nam-1.14.i586.tar.gz' anywhere and : sudo cp nam /usr/local/bin/
> > Tested on Ubuntu 9.10 → → Works perfect.

More info here, post # 8


dev_crazy56 03-12-2011 03:30 AM

thank you so much sir for your interest.

I did as per your instruction and then......


debasish@debasish-laptop:~/Downloads/nam$ tar xvf nam-1.14.i586.tar.gz
debasish@debasish-laptop:~/Downloads/nam$ sudo cp nam /usr/local/bin/
[sudo] password for debasish:
cp: cannot stat `nam': No such file or directory
debasish@debasish-laptop:~/Downloads/nam$ sudo cp nam/usr/local/bin/
cp: missing destination file operand after `nam/usr/local/bin/'
Try `cp --help' for more information.

and now whenever i try to run nam in my terminal it shows the same result.


debasish@debasish-laptop:/usr/local/bin$ nam
[code omitted because of length]
: no event type or button # or keysym
while executing
"bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D / 120) * 4}] units
invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D)}] units
bind Li..."


But when i graphically go to usr/local/bin/ and double click on the 'nam' executable icon, it runs which is a little bit unsatisfactory.

sir i m purely a newbie, apologies for the trouble i m causing.....

sincerely dev

knudfl 03-12-2011 04:08 AM

# 13

tar xvf nam-1.14.i586.tar.gz && cd nam-1.14.i586/ && sudo cp nam /usr/local/bin/


dev_crazy56 03-12-2011 04:24 AM

that worked perfectly sir,

thank you very much for you time,


All times are GMT -5. The time now is 05:39 PM.