LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 11-09-2004, 03:16 PM   #1
malegria
LQ Newbie
 
Registered: Oct 2004
Location: Los Angeles
Distribution: Ubuntu 4.10 (Warty) & Debian (Sarge)
Posts: 27

Rep: Reputation: 15
No sound in FC3


I´ve just installed FC3, and had already purchased the OSS license when I was running FC2. Now that I´ve upgraded the sound doesn´t work. I raised the muted volumes and still nothing. Is there an incompatibality issue? Do I need to re-install OSS?

Any ideas?
 
Old 11-09-2004, 04:04 PM   #2
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
OSS is now obsolete for linux and you need to use alsa. Try unmuting PCM, WAVE and MASTER if they are muted.
 
Old 11-09-2004, 04:12 PM   #3
malegria
LQ Newbie
 
Registered: Oct 2004
Location: Los Angeles
Distribution: Ubuntu 4.10 (Warty) & Debian (Sarge)
Posts: 27

Original Poster
Rep: Reputation: 15
Any tips on how to Install ALSA? A certain order to install the drivers, libs, et c?

How would I uninstall or turnoff OSS?

Last edited by malegria; 11-09-2004 at 04:22 PM.
 
Old 11-09-2004, 04:45 PM   #4
Samsara
Member
 
Registered: May 2003
Distribution: Ubuntu, Mac OS X Tiger
Posts: 481

Rep: Reputation: 32
Best method would be to recompile your kernel, and include only those modules that correspond to your audio hardware.

Regards,

Samsara
 
Old 11-09-2004, 04:49 PM   #5
malegria
LQ Newbie
 
Registered: Oct 2004
Location: Los Angeles
Distribution: Ubuntu 4.10 (Warty) & Debian (Sarge)
Posts: 27

Original Poster
Rep: Reputation: 15
i apologize for sounding like such a newbie, but i´ve only been running fedora for about 2 months now and when you say something like : ¨recompile the kernel¨ i have no idea as to what you mean, or as to how to go about doing it.
 
Old 11-09-2004, 04:59 PM   #6
malegria
LQ Newbie
 
Registered: Oct 2004
Location: Los Angeles
Distribution: Ubuntu 4.10 (Warty) & Debian (Sarge)
Posts: 27

Original Poster
Rep: Reputation: 15
...........

Ok. So I logged on as root and was FINALLY able to run alsaconf and raise the muted volumes. But mp3s play all glitchy, but movie sound plays fine. But when I log on to my regular user account the sound is still muted, and when I try to open alsaconf in a terminal as root IT DOESN´T OPEN! ARGH!
 
Old 11-09-2004, 06:01 PM   #7
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
try running "alsamixer" in a console and unmute the volumes. Once you have done that run "alsactl store" as root. hopefully this will set the volumes to a default level for all users on the system.
 
Old 11-09-2004, 06:29 PM   #8
malegria
LQ Newbie
 
Registered: Oct 2004
Location: Los Angeles
Distribution: Ubuntu 4.10 (Warty) & Debian (Sarge)
Posts: 27

Original Poster
Rep: Reputation: 15
i´m really regretting having upgraded to FC3 now. Yes, before I was running OSS but it worked well when I couldn´t get ALSA to work.

I can access alsamixer, put the volume up, but nothing. No sound. My card IS detected, but nothing.

Qué ridiculo!
 
Old 11-10-2004, 12:15 AM   #9
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
just putting the volume up with alsamixer won't help unless you unmute the some of the options. The key that mutes and unmutes stuff is "m" I think on you keyboard.
 
Old 11-10-2004, 04:37 AM   #10
daspooky
LQ Newbie
 
Registered: Nov 2004
Posts: 23

Rep: Reputation: 15
I had a similar problem..

Thing I found on the net in my desperate search to fix alsa:

- I ran 'alsactl conf', my sound card was detected fine

- I ran 'alsamixer', set my volumes

_ then ran 'alsactl store'

BUT, i didn't get sound anywhere..


In my quest for sound someone told me to MUTE some of the weird mixer bars, result SOUND WORKED FINE

CONCLUSION: if your soundcard is detected but you don't get sound, try to MUTE some of the weird-named bars in alsamixer and do 'alsactl store'

If after that you don't get sound in KDE, run 'alsactl restore' and all should be working fine

Another problem i had, alsamixer is allways returned to default values at login of KDE, so i have to do 'alsacatl restore' after every login.. i then made a script that runs at login wit hthe line: '/usr/sbin/alsactl restore'


Hope this helps
 
Old 11-10-2004, 10:17 PM   #11
malegria
LQ Newbie
 
Registered: Oct 2004
Location: Los Angeles
Distribution: Ubuntu 4.10 (Warty) & Debian (Sarge)
Posts: 27

Original Poster
Rep: Reputation: 15
Thank you daspooky. I muted one of the bars (specifically SPDIF out) and it works just fine now! yay!

What I was wondering is where you added that script to run "alsactl restore" at load. Thanks.

But another problem: mp3s play choppy. Any ideas for that problem? [Sometimes the sounds seem to clear...then gets choppy again]

Last edited by malegria; 11-10-2004 at 10:47 PM.
 
Old 11-11-2004, 03:29 AM   #12
daspooky
LQ Newbie
 
Registered: Nov 2004
Posts: 23

Rep: Reputation: 15
hello malegria,

Glad it worked for you too. for the script, i put it in home/[your uesr name]/.kde/Autostart
All the scripts in there are loaded at login

But i in the meantime i found the real problem to alsactl restore not loading. In fact, alsactl restore is loading at boot before kde starts, and the problem is that KDE has it's own mixer settings and loads those at login so your alsamixer settings get overridden. To fix this go to settings -> control center -> sound & multimedia -> mixer

And untick load volumes on login. With this you won't need the script i told you about, and you will have fixed the problem at the source.

About the mp3 problem i can't figure out what the problem is
 
Old 11-11-2004, 05:41 AM   #13
Strixy
Member
 
Registered: Apr 2004
Location: Nowhere, Oblivion
Distribution: Ubuntu
Posts: 48

Rep: Reputation: 15
Here is a great article on some tips and tricks to help you with MP3 issues.
FC3 Tips and Tricks
 
Old 11-11-2004, 07:00 AM   #14
malegria
LQ Newbie
 
Registered: Oct 2004
Location: Los Angeles
Distribution: Ubuntu 4.10 (Warty) & Debian (Sarge)
Posts: 27

Original Poster
Rep: Reputation: 15
I was using Kaffeine to play mp3s....but since I couldn´t fix the buffer, I opted for XMMS and now mp3s play fine. Once again, thanks for all the very HELPFUL help.
 
Old 11-11-2004, 09:04 PM   #15
zavulon
LQ Newbie
 
Registered: Nov 2004
Location: Finland
Distribution: Fedora Core 3
Posts: 2

Rep: Reputation: 0
FC3: no sound

I have had problems with sound both in ASPLinux 9.2 (based on Red Hat 9.2) and Fedora Core 3.
I have integrated sound card SiS, which uses snd-intel8x0 driver.

In ASPLinux I had to launch xmms with OSS output plugin and drag the volume control off the zero point. But still I had to switch after that to esound output plugin to be able to adjust the sound volume.
Fedora Core 3 appeared to be even worse. I could not enable the sound with any way I knew. At this forum I have read that switching off "IEC958 Capture Monitor" helps, - it really has solved my problem.

So, this is the solution:
- Launch alsamixer
- Go with cursor to the far right end. There must be a bar "IEC958 Capture Monitor", its short name below is "IEC958 C".
- Mute that bar by pressing M.
This really helps. Of course, the "Master" bar must have non-zero value.
The alternative way is to use K-mix (the graphical front-end).

However, in Fedora Core 3, I still cannot adjust the sound volume. My earlier solution with using esound does not work: the volume do become adjustable but in FC3 the esound plugin makes distortions to the sound.
Who knows how to solve the problem with adjusting the volume?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Poor sound quality on ALC850 onboard sound (FC3) c_ryan Linux - Hardware 3 05-20-2005 03:58 AM
Sound Problem In Fc3(jittery Sound) rag_mg Fedora - Installation 1 05-03-2005 06:44 PM
No sound, FC3 brandor Linux - Hardware 15 04-27-2005 11:29 PM
Help with Sound on FC3!!!! dreyes81 Linux - Newbie 7 01-25-2005 01:42 AM
FC3 - No Sound HMike Linux - Newbie 17 01-05-2005 05:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 05:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration