-   Fedora (
-   -   No shutdown, reboot or start session option (

godzero 06-15-2005 11:11 AM

No shutdown, reboot or start session option
In KDE, the log out menu usually has the options to logout, shut down, reboot, or start new session; But I'm only getting the logout option.

I assumed it was a security thing (I saw simmilar behavior under mandrake at high security settings), so I checked the ususal suspects. No dice.

Then I thought it may be a bug, or normal behavior. The later, I doubt.

Anyone else have this prob? Any ideas?

FC4 x86 DVD, Installed everything. did a update. SELinux is on. No real modifications (yet), just the desktop has been customized, and some packages from the default repos. (was same before and after)

reddazz 06-15-2005 11:25 AM

Are you using KDM or GDM. If you are using the GNOME Display Manager, KDE will not show the options you mentioned in your post.

godzero 06-15-2005 11:46 AM

Possable, I see 2 procs called gdm-binary. I'll look into how to switch to kdm(?).

Any pointers? My login looks Gnome-ish. is this what's invoking it?

reddazz 06-15-2005 12:13 PM

If you have gdm running then you won't have the logout options. To change to kdm, edit /etc/sysconfig/desktop as follows,


Note new versions of KDM look like GDM.

godzero 06-15-2005 03:47 PM

Thanks. That gave me shutdown and reboot.. but fast user switching is gone.
I was able to edit /etc/kde/kdm/Xservers to:

:0 local /usr/X11R6/bin/X :0 vt7
:1 local /usr/X11R6/bin/X :1 vt8
:2 local /usr/X11R6/bin/X :2 vt9
:3 local /usr/X11R6/bin/X :3 vt10
:4 local /usr/X11R6/bin/X :4 vt11
:5 local /usr/X11R6/bin/X :5 vt12
:6 local /usr/X11R6/bin/X :6 vt13

... That gave me the abilty to "startx -- :1" etc to get another desktop (for who's logged in the shell at the time), then I can ctrl-alt-Fx around but still not perfect. I think it's 'cause they're perm, not reseved... will dig more...

Oh, about the "looks like gnome" thing... even when kde and gnome are themed the same.. etc.. I can tell the difference. Maybe in the rendering, or palette or something, but it has a different look/feel.

[EDIT 2]
I tried every version of reserve I could think of... no dice. :(

All times are GMT -5. The time now is 07:09 AM.