-   Fedora (
-   -   No repositories in Fedora-17 with Trinity desktop (

kwill 02-05-2013 05:35 PM

No repositories in Fedora-17 with Trinity desktop
I installed Fedora 17 with Trinity desktop (love the KDE3.5). No problem. Installed mc and synaptic using yum. yum also updated the existing files where needed. However synaptic only shows the existing programs from the CD.

I cannot find any way to update the repositories to allow installing other things?

I'm not very familiar with recent Fedora. Last try was about 12 and it never worked right, each time I started up it took 1/4 hour to get the network to go.

Ztcoracat 02-05-2013 10:26 PM


Congrads on the installation!

To enable a repo which is disabled in the config run:

yum --enablerepo= reponame install packagename
The repo's in Fedora are located in /etc/yum.repos.d/dir
Try this webpage-

Hope this helps

kwill 02-06-2013 10:17 PM

Unfortunately while it works it does not help.

First one has to find ( I managed to this time) and get the Trinity repositories. (Why are they not on the CD?) Then they can be enabled. I installed Synaptic with yum. However there is no way to setup the repositories in Synaptic other than the base install of Fedora. The default GUI Kpackage is even less useful - it never was any good.

I used apt-get update and it updated, even Synaptic agreed there were updates but it wouldn't let me install them as there "Two broken packages" - "setup" & "filesystem". I reinstalled them with yum but still the same. So used yum to update the system. Synaptic now shows no new files or updates but still the two broken packages. It was obviously not looking for any online files. There appeared to be a problem with the site apt-get was using as another try to update failed with 503 error.

I'm not sure how useful "filesystem" is but "setup" is necessary to install new users, an item which is totally lacking from the "settings" menu. New users have to be added from the control line. I tried adding during the install but it locked up. They did install but one had stuffed password.

This is obviously a BIG problem with Trinity Desktop not putting their own repos in the distro CD. A month of wasted effort trying to get Ubunbtu 12.04 Trinity (defaults to Polish and no cursor keys on keyboard or the usual CLI prompt) or Fedora 17 going with Trinity. I won't be bothering to try Fedora with KDE4 either as with no effective graphical installation it's like going back to 1999. So much for "Modern easy to use system". Reminds me of Debian from last century.

Ztcoracat 02-07-2013 08:55 PM


Do you suspect that the Live CD/DVD Iso file could be corrupt?


I tried adding during the install but it locked up
Leading me to believe that something is up with that ISO/install-


This is obviously a BIG problem with Trinity Desktop not putting their own repos in the distro CD
When I installed Fedora 17 I had to open the terminal and literally tell the terminal about rpm Red Hat Package Manager which is the standard for Fedora. The repo's where automatically in the ISO file and put them in the /etc/yum.repos.d/dir. Do you have that directory?

Having trouble understanding why you used( "apt-get update and it updated") APT on a distro that it's main utility tool is YUM-

I wouldn't use Trinity. So far XFCE has been fine-

Ztcoracat 02-07-2013 09:02 PM

Here's a few article's on:
How to fix broken packages

If it were me; Kwill:
I would go get a fresh ISO Image/File of Fedora (other than Trinity)and re-install the OS. The current version of Fedora is 18 you could consider it but I am waiting until March for a fresh install as it gives the developers time to get the bugs out-
Verify the integrity of that file before you burn it and install it to ensure it is not corrupted.

Hope this helps

kwill 02-08-2013 04:07 PM

The computer is set up to dual boot PCLinuxOS (KDE4 but made to nearly look like 3.5) and Kubuntu8.04.

I tried both Fedora 17 & Ubuntu12.04 Trinity editions because I liked and still like the style. What ever I install will replace the Kubuntu 8.04 which was last version to use KDE3.5

In neither are the Trinity repos included on the CD. Because the machine, a HP-Compaq made by the millions only takes a CD I am restricted in what I can install. The lack of network install these days is restrictive. I wanted to try the GNUradio and DVB-T capabilities of these distros as they supposedly support it (I cannot get to install/run on PCLinuxOS), also Arduino and similar micro controllers. However neither would produce any sign of accepting the DVB-t dongle. Never even got as far as trying GNUradio. In the Ubuntu I could only get Arduino to run as root.

I used apt to update to try and get synaptic to work as I am familiar with it. Yum is the main way, commandline only but Kpackage is included as a gui update system. It never was any good and is still no good. I checked both the downloads and Cd's md5's so there is no problem with them.

Yes I installed the repos in /etc/yum.repos.d/dir but synaptic would not accept/find them and it also only had the ability to accept dep or deb-src. It locked up the second time I installed it because I attempted to install another user at install time as that is not feasible (apart from via the CLI) after installation. Presumably due to the problem synaptic claims exist with "setup".

Do not worry any more, it has been wiped and kubuntu8.04 will go back on. It works always has and is KDE3.5. Pity about GNUradio and DVB-t but I am not that much out of pocket, the DVb-t dongle was cheap enough and I haven't got around to buying a radio that would need GNUradio. Also I was going to use GNUradio with the DVB-T dongle for VHF radio reception.

Thanks for suggestions, seems like "don't use Trinity" is the best.

Ztcoracat 02-09-2013 11:43 AM


I tried both Fedora 17 & Ubuntu12.04 Trinity editions because I liked and still like the style
I can appreciate that. I really like KDE and XFCE-

Hadn't realized that you are restricted in what you can install (only takes a CD) Got it-


Presumably due to the problem synaptic claims exist with "setup".
Agreed; most likely-

Your Welcome on the suggestions.;) Hope it helps.

All times are GMT -5. The time now is 12:44 PM.