LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 02-26-2010, 11:55 PM   #1
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,555

Rep: Reputation: 45
no net


Two days ago, my Internet connection stopped working under Fed 12. It works under Win, and Ubuntu, so there is no hardware failure. Maybe the result of an update?

How can I fix this? Anyone else had this problem. It simply won't connect to the connection 'Zuhause'. I haven't had the opportunity to try another connection. Monday at work I can see if it will connect to a different connection.
 
Old 02-27-2010, 12:04 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
How are you trying to connect? What sort of network?
In fedora, I remember having to remove the connection settings completely then reinstating them when something went wrong.
 
Old 02-27-2010, 12:26 AM   #3
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,555

Original Poster
Rep: Reputation: 45
It's a dsl connection. Username, password.
 
Old 02-27-2010, 01:00 AM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,218

Rep: Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517
when you open the " network" GUI and reset it -- dose it reset?

have you read the fedora guide/user manual page ???
http://docs.fedoraproject.org/
http://docs.fedoraproject.org/user-g..._Internet.html

http://docs.fedoraproject.org/user-g...ing_PPPoE.html

you might need to turn off the fedora default " network" daemon and turn on the "networkmanager" daemon
the second one IS NOT the default.
 
Old 02-27-2010, 01:43 AM   #5
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,555

Original Poster
Rep: Reputation: 45
Not sure what you mean. I see no button 'reset' I have the nm applet running, and like I said, up to 2 days ago, it worked fine. This must be related to an update. I check everyday for updates. I have Debian on an external HD. I installed WICD there. But it doesn't seem to have a rubric 'dsl', just 'wired network'. But I'm writing this in Ubuntu, and everything works.
 
Old 02-27-2010, 02:11 AM   #6
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,555

Original Poster
Rep: Reputation: 45
I deleted the connection and re-wrote it, but that didn't help! I felt a bit silly when the technician came. He started Windows and there was nothing wrong!
I was so happy with Fed 12, everything seemed to work! Knew it was too good to be true!
 
Old 02-27-2010, 02:49 AM   #7
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
if f12 is dual booted with windows - make sure that windows is not putting your nic to sleep.

this is a wired connection?
do you use dhcp or static ip? (ubuntu default is dhcp - make sure that is set in fedora).

how are you testing the connection?
does the nm applet tell you there is a wired connection at all?
 
Old 02-27-2010, 03:11 AM   #8
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,555

Original Poster
Rep: Reputation: 45
Dual boot no. I only use Win for AutoCAD. I use the same nm in Ubuntu, the Gnome nm. I just set the username and password. nm says I have a connection Home, but it never connects. I get a white x on a red background next to the double monitor icon, then it switches to syseth0, which goes nowhere. This is a dsl connection working now under Ubuntu, and previously under Fed 12
 
Old 02-27-2010, 03:42 AM   #9
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,555

Original Poster
Rep: Reputation: 45
That is to say: Win is on the same hard disc, but never had this problem before. I don't know if you can boot both at once. A friend runs win under a VM inside Linux, if that's what you mean by dual boot
 
Old 02-27-2010, 09:45 AM   #10
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
http://www.pcmag.com/encyclopedia_te...i=42074,00.asp
Quote:
A computer with two operating systems. At startup, a boot manager program lets the user choose which one to load.
... so, yes, you have a multi-boot computer. All the operating systems are running on the same hardware from the same HDD (but not simultaniously).

On some systems, windows will put the nic to sleep when it shuts down - then, when you boot the same computer to another OS, the nic stays asleep and the OS cannot use it.

However - looking at your description, I need you to check something else.
Quote:
nm says I have a connection Home, but it never connects. I get a white x on a red background next to the double monitor icon, then it switches to syseth0, which goes nowhere.
This sounds contradictory to me.

The X on the nm applet means there is no connection. Our object is to get rid of that little red X. If the red x goes away when it "switches to syseth0", then you have a connection - but you may just get a timer animation that keeps going - is that what you mean?

If you left-click on the applet, you should see the available networks. I get a wired connection called "auto eth0" and my network setup uses a router/adsl-modem with dhcp. If I right-click on it I see a checkbox next to "enable networking": this has to be ticked.

There is also an option to edit connections - you should compare the settings with those in Ubuntu - which you know works.

When the little red x goes away, then you have a connection.

After you've got back to me with the result of these checks, I'll see if I need to give you some commandline stuff to do. I have to work slowly because you are very new to this and I want to be sure I'm getting it right. If I was right there it would take about 10mins.
 
Old 02-27-2010, 06:00 PM   #11
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,555

Original Poster
Rep: Reputation: 45
Thanks

This is a weird problem. The settings I have in Ubuntu are exactly the same in Fed. But I'll check again like you said.
 
Old 02-27-2010, 06:37 PM   #12
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,555

Original Poster
Rep: Reputation: 45
Ok.
A right click on the nm icon brings up a menu with check boxes 'enable networking' some other stuff and 'edit connections'
The check boxes are automatically checked on boot. But I unchecked them and then rechecked them. I made a new dsl connection, 'homeagain' with my username and password. It won't connect, lil x shows up. Then Fed goes to system eth0, and it says I have a connection. This is a wired connection with no ip, going nowhere. I have a static ip in the library here. I will walk over there later, and see if Fed lets me connect to the wired network there.

If I had a net connection under Fed, I would re-install nm. Must be a bug in it, I think. It was working up to 3 days ago. But I will wait and heed your advice. As I said, I like Fed 12, so I'd like to keep it.

Under the tab dsl in the nm gui there is no option 'enable dhcp', just username, service (I leave this blank, don't know what it is, works without it)and password. There is a checkbox 'allow other users to use this connection' which I've checked. Apart from that there is nothing. Well, at the top I can give the connection a name.
 
Old 02-27-2010, 09:38 PM   #13
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,555

Original Poster
Rep: Reputation: 45
Well, I'm in the library, and the wired network here (fixed ip) worked first time under Fed 12. My update manager is telling me there is a new release of NetworkManager. It is installing the update now. I will walk home again after that and see if it can connect to the dsl connection.

If not, it's pull my hair out time!!
 
Old 02-27-2010, 10:34 PM   #14
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,555

Original Poster
Rep: Reputation: 45
Keep your hair on Pete! I have a dsl connection again at home! Must have been a glitch in a previous update! Thanks for your advice! Don't s'pose I'll ever know what it was!
 
Old 02-28-2010, 08:56 AM   #15
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Well done - it is also possible that there was a rogue setting someplace that got cleared in the update. It can clean things up like that, as well as break them.

One of the things I suspected was that you may have had your browser etc in offline mode. So nmapplet would say you are connected but you cannot do anything. Making a new network connection could also have reset everything.

Should you see this again, you'll want to look at the commandline method of getting a connection through ifconfig and dhpcd. The advantage of this is that you get more detailed error messages as well as exact information about your potential and actual connections.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ava.net.ProtocolException: Already connected at gnu.java.net.protocol.http.HTTPURL trfunite Linux - Newbie 0 07-11-2008 07:04 AM
Linux/BSD VPN software for net-to-net with DynDNS at both ends? jantman Linux - Security 5 03-10-2008 01:20 PM
Lost ability to net-surf with toast.net dsl under openSUSE 10.3 DeekBeek Linux - Networking 5 02-10-2008 01:26 PM
LXer: How the Net was Lost - the real story behind Net Neutrality LXer Syndicated Linux News 0 06-20-2006 10:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 10:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration