LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 10-05-2004, 11:30 PM   #1
p1az
Member
 
Registered: Jul 2003
Location: State College, PA
Distribution: Slackware 10.0
Posts: 40

Rep: Reputation: 15
Network printing


I've been struggling to get my Samsung ML-1710 printer shared between two FC2 systems. The printer works fine on both systems when locally connected (via USB) but I am unable to share it on my server. I should have the correct port open on my firewall (631), but even with my firewall disabled I can't print to the shared printer. I'm assuming its now an issue of CUPS not accepting the external print request. I tried editing cupsd.conf file (adding ALLOW ip_address) but I'm not sure if I added the line in the right place. The cupsd.conf file is rather large so heres the section regarding allowed network hosts: (if more is needed let me know).

----------

## Restrict access to local domain
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
Allow From 10.100.36.31

#Encryption Required
</Location>

#
# End of "$Id: cupsd.conf.in,v 1.13 2003/04/10 20:14:04 mike Exp $".
#
<Location /printers/lp>
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
AuthType None
</Location>
# Lines below are automatically generated - DO NOT EDIT
<Location /printers/printer>
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
AuthType None
Allow from All
</Location>
<Location />
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
</Location>
Browsing On
BrowseProtocols cups
BrowseOrder Deny,Allow
BrowseAllow from @LOCAL
BrowseAddress 255.255.255.255
Listen *:631

--------

The "Allow From 10.100.36.31" line is the line I added to try to get CUPS to accept requests from that IP. Also according to my (server) print manager my printer is marked as being shared. In the (client) print manager the networked printer's description is "Unable to get printer status (client-error-forbidden)!", other than that I'm not getting any errors to help with this problem. Nothing happens when I send a file to that shared printer. What am I missing?
 
Old 10-06-2004, 03:17 PM   #2
Biased turkey
Member
 
Registered: Jan 2002
Location: Canada
Distribution: redhat7.2
Posts: 169

Rep: Reputation: 30
My setup is almost exactly the same as yours: My printer server has an USB samsung connected to it and my client is running a triple boot Windows2000, Fedora Core2 and Slack 10.
I'm at work and don't have my cupsd. conf config file in front of me ( I used to run Linux at work but my stupid manager obliged me to scrap my Linux partition ).
Just 1 question: you post on the Fedora Forum, but your distro is Slack 10.0 which one do you run ?
I have both on my client ( as previously mentioned ) and was unable to connect to the printer server because on Slack the cupsd service is desabled by default.
I'll post my cupsd.conf tonight, 3 or 4 extra lines only must be added to the default one.

P.S. If you run Fedora on the server, you can share the printer using KDE printer manager, select the printer and on the action menu click "share" or something like that
 
Old 10-06-2004, 08:37 PM   #3
Biased turkey
Member
 
Registered: Jan 2002
Location: Canada
Distribution: redhat7.2
Posts: 169

Rep: Reputation: 30
First, here are my own network iP adresses:
192.168.0.1 Printer server
192.168.0.2 Client

Here are the lines I added or changed in my /etc/cupsd.conf:
#
# End of "$Id: cupsd.conf.in,v 1.13 2003/04/10 20:14:04 mike Exp $".
#

# Added by Biased turkey
Browsing On
BrowseAddress 192.168.0.2
<Location /printers>
Order Deny,Allow
Deny from All
BrowseAllow from 127.0.0.1
BrowseAllow from 192.168.0.2
Allow from 127.0.0.1
Allow from 192.168.0.2
</Location>
 
Old 10-07-2004, 01:01 AM   #4
p1az
Member
 
Registered: Jul 2003
Location: State College, PA
Distribution: Slackware 10.0
Posts: 40

Original Poster
Rep: Reputation: 15
Still not working. Biased, I made the changes you made to your cupsd.conf file. When you add a new printer, i assume you select Networked CUPS, then what path is yours? mine defaults to /printers/queue1, but in my cupsd.conf file there are multiple references to /printers/lp. I tried both paths with no success. It sounds like you've accomplished what I've been working at, so I have to be missing something. As for why I'm posting in the FC forum when I have Slack in my profile, its because my HDD crashed and I'm giving FC2 a whirl. So far everything has been going great except for this printer issue. This problem will not get the best of me, so I'm going to continue reading deeper into the wonderful world of CUPS. Hopefully someone will save me. Maybe I'll have better luck doing this via samba?
This is my new cupsd.conf file with the changes I thought I needed:
Whats up with the automatically generated section? Should my changes be present in there?

-------

## Restrict access to local domain
Order Deny,Allow
Deny From All
Allow From 127.0.0.1

#Encryption Required
</Location>

#
# End of "$Id: cupsd.conf.in,v 1.13 2003/04/10 20:14:04 mike Exp $".
#
Browsing On
BrowseAddress 10.100.36.31
<Location /printers/lp>
Order Deny,Allow
Deny From All
BrowseAllow From 127.0.0.1
BrowseAllow From 10.100.36.31
Allow From 127.0.0.1
Allow From 10.100.36.31
AuthType None
</Location>
# Lines below are automatically generated - DO NOT EDIT
<Location /printers/printer>
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
AuthType None
Allow from All
</Location>
<Location />
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
</Location>
Browsing On
BrowseProtocols cups
BrowseOrder Deny,Allow
BrowseAllow from @LOCAL
BrowseAddress 255.255.255.255
Listen *:631

------
 
Old 10-07-2004, 09:23 AM   #5
Biased turkey
Member
 
Registered: Jan 2002
Location: Canada
Distribution: redhat7.2
Posts: 169

Rep: Reputation: 30
First, a small question:
Did you configure the printer on the server with gnome, kde or via the web interface
http://localhost:631/admin ?

To make a clean start,
1) On the client, use gnome or kde to remove any printer
2) Do the same on the server + erase anything you added to the /etc/cupsd.conf
3) reboot the server and use ONLY the web interface to add a new printer on the server.
When using the web interface, nothing will be added to the cupsd.conf file, you'll have to edit it by hand ( that fact is mentionned in the cups administrator manual ).
On the other side, using gnome or kde will add automatically stuff to your cupsd.conf and that's bad.
Then restart server and client.
The client should ( as mentioned in the cups manual ) "automagically detect the shared printer
I've been through the 150+ pages Cups manual, but at least I got it working
It looks like your problem is that you try to config a printer using both ways.


If you want, tonight I can email you my complete cupsd.conf
 
Old 10-09-2004, 11:50 AM   #6
p1az
Member
 
Registered: Jul 2003
Location: State College, PA
Distribution: Slackware 10.0
Posts: 40

Original Poster
Rep: Reputation: 15
Originally I tried configuring the printer in the Gnome print manager, but after that didn't work I tried configuring it in the CUPS web interface. I'm away from home right now but when I get back I'll remove everything and start new. I'll work with just the CUPS web interface then add the proper lines to the cupsd.conf file. Quick question tho, where would the automatically detected printer show up? Where should I be able to browse to it? Thanks for all your help.
 
Old 10-12-2004, 08:14 PM   #7
Biased turkey
Member
 
Registered: Jan 2002
Location: Canada
Distribution: redhat7.2
Posts: 169

Rep: Reputation: 30
To see on the client if the printer was detected, go to the KDE menu->System Settings->Printing.
Under the "queue name" title you should see "Browsed Queues" then click on the little triangle next to it.
You should then see the name of the printer located on the server.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Printing Over Network eggoz Linux - General 7 02-01-2005 11:12 AM
Network printing with OS/2 Nychold Linux - Networking 0 04-29-2004 09:56 PM
network printing help please pcdunx Linux - Networking 0 11-14-2003 05:48 AM
printing on the network jj71 Linux - Newbie 1 07-31-2003 03:21 PM
Network Printing esael Linux - Networking 1 08-29-2002 12:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 02:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration