-   Fedora (
-   -   Network connection problem Fedora Core 1 - Kernel issues too! (

skybolt_1 11-10-2003 09:59 PM

Network connection problem Fedora Core 1 - Kernel issues too!
Hi there! I just upgraded to Fedora Core 1 and I have been having some issues getting the network connection to establish itself on startup. During the startup sequence I get the message that there is no cable hooked up to the card and that I should check the connection. However, once I am successfully logged on, if I go into the network properties and activate the connection, it gets an address just fine.

Why would it do this? I tried unchecking the box in the ethernet device window that says "activate this device on startup", rebooting, and then re-checking the box, but this didn't do anything. Is there a file that maybe I need to delete and re-generate so that it can complete the connection???

Also, on another topic... I have tried to rebuild the shipping kernel to my machine's specific hardware, but every time I run the series of "make" commands, I ultimately get the following errors before the "make" routine ends:
: undefined reference to `acpi_table_print_madt_entry'
arch/i386/kernel/kernel.o(.text.init+0x5402): In function `acpi_boot_init':
: undefined reference to `acpi_table_init'
arch/i386/kernel/kernel.o(.text.init+0x541a): In function `acpi_boot_init':
: undefined reference to `acpi_table_parse'
arch/i386/kernel/kernel.o(.text.init+0x5445): In function `acpi_boot_init':
: undefined reference to `acpi_table_parse_madt'
arch/i386/kernel/kernel.o(.text.init+0x547a): In function `acpi_boot_init':
: undefined reference to `acpi_table_parse_madt'
arch/i386/kernel/kernel.o(.text.init+0x5498): In function `acpi_boot_init':
: undefined reference to `acpi_table_parse_madt'
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.22-1.2115.nptl'
make: *** [vmlinux] Error 2
[root@Fedora linux-2.4.22-1.2115.nptl]#

I have tried downloading the standard kernel source from and that compiles just fine, but this fedora-customized version doesn't want to behave in the least.

Has anyone had experience with this type of error???

Any help would be appreciated. :Pengy:

Bluesuperman 11-11-2003 12:31 AM

To solve the kernel issue, do a make menuconfig -- remove all the acpi options, save your configuration to a file, do a "make mrproper" , then a make menuconfig again, load the file, save it and then build the kernerl -- that may solve your issue.

It seems that your hardware may not be fully supported by the linux kernel -- ACPI

to build the kernel, make dep ; make clean ; make bzImage ; make ; make install ; make modules ;make modules_install

Not sure about the network card -- may it is a path or evironmentaly variable -- that needs a login to work.

stuNNed 11-11-2003 01:00 AM

the config script for network and such are in /etc/sysconfig

blaroe 11-11-2003 01:40 AM

There are a couple threads here on NIC card drivers (particularly 3COM) not functioning correctly with kudzu. I also had this issue after installing Fedora Core 1.

The fix was to stop kudzu from checking for new hardware at boot by turning kudzu off. To do this, enter the following as root:

chkconfig --level 345 kudzu off

Works for now anyhow....


All times are GMT -5. The time now is 02:56 AM.