-   Fedora (
-   -   Need help for usb flash drive using Fedora 2 (

matrim 03-16-2007 08:48 PM

Need help for usb flash drive using Fedora 2
If I dual boot, don't I need an entry like:

/dev/sda1 /mnt/flash vfat noauto,rw,exec,unmask=0 0 0

where the 'sda1' is different because windows is on hda1? This used to work, now it doesn't. How can I tell if my usb port is working? I plug my flash drive in and it keeps saying 'sda1 is not a valid block device'. What do I need to do?

Lenard 03-17-2007 05:41 AM

Well after you plug in the USB device as root check the /var/log/messages file;

tail /var/log/messages

Adjust the /etc/fstab entry as needed. If you do not get any report about the USB drive being connected then make sure the usb drivers are being loaded;

cat /proc/modules | grep _hcd

matrim 03-18-2007 12:03 PM

Hi and thanks for the reply.
I'm still having trouble with this. Checking messages showed no change, and indeed the light on the flash drive doesn't go on like it should. I'm guessing the drivers for some reason aren't installed?(they worked before)The 'cat' commanded just returned a line; no results I guess. What can I do now? I think yum showed I have usbutils and others installed...

ps. the fstab i have: /dev/sda1 /mnt/flash vfat noauto,owner,kudzo 0 0 It is sometimes overwritten(erased) when I reboot though :/

Lenard 03-18-2007 09:06 PM

Turn off the service kudzu, it causes more problems then it solves.

chkconfig --level 345 kudzu off

Your /etc/fstab entry would be better if changed slightly;

/dev/sda1 /mnt/flash vfat noauto,user,rw 0 0

The drive light should work if the usb port has power and nothing else is wrong. This is true even if the usb modules do not load. Check you BIOS maybe the usb ports are disabled, maybe the usb port(s) or usb interface(s) on the motherboard have gone bad. It might be something related to the usb interface of the usb enclosure.

matrim 03-18-2007 09:29 PM

Thanks for the reply. The drive light works in windows and even lights up when I run the linux rescue disk. So it has to be related to the drivers or something like that once FC2 loads.

Lenard 03-19-2007 04:58 AM

Why are you still running FC2, it is old and has no support??? Any good reason to????

As a suggestion try something that is supported like CentOS or SL. both are freely available 100% binary compatible 'clones' of RHEL.

With that said try manually loading the usb modules before attaching the usb device;

modprobe -v <usb_module_name_here>

Use the typed command 'sbin/lspci -v' minus the single quotemarks to assist you with which usb interfaces you have. The kernel module names can be found in the directory /lib/modules/<kernel-version-number-here>/kernel/drivers/usb/host


matrim 03-19-2007 04:57 PM

At this point I just want to get the stupid USB flash working so I can save my info and then,
yes I'll upgrade. Thanks for hanging in there with me. I'll try these new suggestions and get back with ya.

Actually how do i know what usb_modules I have?

Lenard 03-19-2007 06:26 PM

You should have all three of them, they are in the directory location I already said.

ls -al /lib/modules/`uname -r`/kernel/drivers/usb/host

That is the backtick character (by the "Tab" key) in the command above not the single quotemark (').

matrim 03-19-2007 08:42 PM

I did watch the boot up closer and it does indeed appear that the usb controller doesn't load properly(says it fails), though I know it worked earlier and works fine in Windows.

After issuing the lspci command I found:

00:07.4 USB Controller: Advanced Micro Devices [AMD] AMD-756 [Viper] USB (rev 06) (prog-if 10 [OHCI])
Flags: bus master, medium devsel, latency 16, IRQ 10
Memory at febff000 (32-bit, non-prefetchable)

Under usb folder:
atm class host image input media misc net serial storage

Lenard 03-20-2007 07:45 AM

Please run (exactly as provided, feel free to cut and paste) the command I provided from the console or xterm session, it will tell you if the ohci-hcd kernel module is present or not. If you get nothing back then something is wrong, then re-install the kernel;

rpm -ivh kernel-<the_rest>.rpm --force

The kernel module is in the last updated kernel for FC2, for example;


$ rpm -qlip kernel-2.6.10-1.771_FC2.i686.rpm | grep ohci-hcd

If it is present then try as root typing; modprobe ohci-hcd

FC2 updates are here:

matrim 03-20-2007 03:22 PM

It's fixed! Thank you.

I think after all of that it was just the modprobe I needed(even though previously it didnt work), because after I did that I could mount it.

Lenard 03-20-2007 07:38 PM

Your welcome, but it not really fixed. It would be a good idea to find out why the kernel module is not being loaded at boot time. Start by checking the /etc/modprobe.d/modprobe.conf.dist and /etc/modprobe.conf for any recent changes.

matrim 03-20-2007 08:28 PM

Of course after I took out to transfer files and then put it back in for more, it wouldn't work.

Originally Posted by Lenard
Start by checking the /etc/modprobe.d/modprobe.conf.dist


# default modutils aliases
# snipped
install usbmouse /sbin/modprobe --first-time --ignore-install usbmouse && { /sbin/modprobe hid; /bin/true; }
remove binfmt_misc { /bin/umount /proc/sys/fs/binfmt_misc > /dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time --ignore-remove binfmt_misc
remove ov518_decomp /sbin/modprobe -r --first-time --ignore-remove ov518_decomp && { /sbin/modprobe -r ov511; /bin/true; }
remove usbmouse { /sbin/modprobe -r hid; } ; /sbin/modprobe -r --first-time --ignore-remove usbmouse
remove sunrpc { /bin/umount /var/lib/nfs/rpc_pipefs > /dev/null 2>&1 || :; } ; /sbin/modprobe -r --ignore-remove sunrpc
remove nfsd { /bin/umount /proc/fs/nfsd > /dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time --ignore-remove nfsd
alias usb-uhci uhci-hcd
alias usb-ohci ohci-hcd
alias uhci uhci-hcd


Originally Posted by Lenard
and /etc/modprobe.conf for any recent changes.

This shows:
alias eth0 8139too
alias usb-controller1 uhci-usb

Lenard 03-20-2007 10:10 PM

Hmmm....... your need the ohci-hcd kernel module to load at boot time correct?!?

Then why in /etc/modprobe.conf do you have: alias usb-controller1 uhci-usb
Should this not be more like: alias usb-controller1 usb-ohci

But let's cover both and add/use: alias usb-controller2 usb-ohci

All times are GMT -5. The time now is 11:21 PM.