-   Fedora (
-   -   need Evolution for Fedora development release (

cdrobsonjr 02-26-2004 11:08 PM

need Evolution for Fedora development release
I guess I'm in what is known as dependency hell.
I had recently gotten Fedora running with the 2.6 kernel and went to use Evolution
and it blew up. (Can't remember now if it was seg faulting, or what, but it never came up.
Here's my version of Fedora:
Linux version 2.6.1-1.65 ( (gcc version 3.3.2 20040119 (Red Hat Linux 3.3.2-8)) #1 Fri Jan 30 17:28:54 EST 2004

Anyway, I rpm -e evolution, thinking I could just go and download the rpm and reinstall it.

I get a list of dependancy errors.

Trying to find and install the correct version of the files it claims it needs has proven
more than a match for me. The files already exist on my system, but are later revisions
due to the fact that I'm running the development release and not the stable release.

I've tried getting the version of Evolution from the Fedora Core 1 repositories with no success.
I even went to Ximian's site, but found they only support the stable releases of Redhat only
up to RH9 - no Fedora whatsoever, and their nifty little installer script tells me it does
not recognise my version of Linux and promptly says goodbye. I didn't find a version of
Evolution in the development tree. That about exhausts my pea brain.

So what's a fella to do to get his Evolution back when in my situation????

Anybody faced this kind of situation or just knows how to resolve, please render

Doug :scratch:

LordMorgul 02-27-2004 01:22 AM

The development branch has decided to revert to 1.4.5 based on the late release time of Evolution 2.0 (sometime in May?) and Fedora Core 2 will release sometime in April. These times don't match up.

You can find the 1.4.5 release currently being used at:

Or if you're trying to find the 1.5.x release that Development switched to temporarily (its buggy.. use at your risk) you can find them here:

I suggest you try and install 1.4.5 and fix any individual dependencies as they show themselves. I'm running 1.5 simply because I like pain, but it is awfully buggy, despite the cool new features. I believe Jeremy Katz will continue to play with it as he develops toward the 2.0 release, but as I said it will not be part of FC2. Good luck with getting back to working order.

cdrobsonjr 02-28-2004 10:49 AM

Well, I actually already tried to get that version (1.4.5-7) working and that is where I threw up the white flag of surrender.
I only got one of four dependency errors resolved.
When I try to install that particular version of evolution, I now am left with the following

[root@localhost i386]# rpm -ivh evolution-1.4.5-7.i386.rpm
/etc/security/selinux/src/policy/file_contexts/file_contexts: No such file or directory
error: Failed dependencies: is needed by evolution-1.4.5-7 is needed by evolution-1.4.5-7 is needed by evolution-1.4.5-7

I already have the following libgtkhtml libraries and none of these will satisfy the
rpm script dependency requirements of the evolution rpm:


as well as this version of libsoup: # (don't you just love the names in linux?)


Trying to install the rpm packages which contain the revisions that the dependency
requirements stated in the errors always fail because of the newer versions already
installed on my system.

I'm curious to know why later revisions won't satisfy packages written needing earlier
revisions. Isn't later better, fuller, more error-free, more feature laden, etc? Why must
it insist on exact version correctness to work? I just need a little education here along
with some help to get evolution back on my system. (please)
So here is where I'm stuck and don't know how to fix.


P.S. While I'm asking for help, someone explain what all this new nooise I'm getting
about "/etc/security/selinux/src/policy/file_contexts/file_contexts: No such file or directory"
is all about. Something not set up right? Something I need to take care of?

P.P.S. One other area of confusion which I would like squared away in my mind is,
I can sometimes find library revision dependency levels satisfied in file names that
I Google for provided by packages that were made for Suse, Mandrake, or some other
distribution other than RedHat, or more specifically for Fedora. Am I correct to assume
that to use an RPM from one of these would be disastrous for me with a Fedora

LordMorgul 02-28-2004 05:38 PM

If a package has a dependency on exact file versions that must be met; sometimes the package has those in error (it isn't really necessary), but in most cases it is. Having a newer file version does not guarantee that the capabilities needed from the old version are still there! The package really can't determine if it will or will not work using the new version, so it rejects it. You can try to manually force the installation, and then run the program and see if things go smoothly (but as I said most of the time the dependency is legitimate).

For downgrading to evolution 1.4.5 you'll need to get the older versions of gtkhtml3, and libsoup. Try these from the current devel tree (these are older versions that I'm using with ev 1.5.4, so they should be correct for 1.4.5)



Install these with rpm -U --force package.rpm.
When you downgrade your current versions to these you may find even more dependency issues, which you'll have to work through one at a time. This mess was caused by the necessary downgrade.

Regarding SELinux error messages, at present you don't need to worry about them unless you're going to learn about the SELinux system and configure it. I upgraded my system into development rather than fresh installing and there are many things to configure to make SELinux work correctly (which I haven't done yet). Yes, it would be good to get it working properly and help test the system, but if you don't have the time now don't worry about those messages. Keep an eye on /var/log/messages if something isn't working at you expect tho, because there could be some problems caused by it.

In some cases using an RPM built for another distribution will work, but it frequently will cause you more pain than its worth. You should not find any dependency that cannot be resolved in the Fedora repositories (you might need to include and for some things). If the RPM is for a base install library file then do not go looking elsewhere, you're right to assume that will not work well; for applications there is a little bit of room to try something.. but its better to stick to properly built packages for your distro.

cdrobsonjr 03-01-2004 12:26 AM

Thank you for both your replies.

I guess I'm not that advernturesome. Downgrading my libraries and breaking who
knows what other software that depends on them would only serve to prolong an
already traumatic nightmare.

I have no idea why Evolution was broken right from the get-go. I haven't seen
anybody else complaining about it. I also ran the checksums on my install media
and found no problems there. Really strange.

I guess that's the price I must pay by using "rawhide". Well, my hide feels pretty
raw right now.

I suppose it's up to someone in Redhat to massage the latest release of Gnome and
other Ximian products to work with Fedora, since Ximian says it will only support
RH9 as the latest release with it's packaging.

Makes it tough on a newbie. :cry:

Thanks again. But, no thanks.


LordMorgul 03-01-2004 10:48 PM

Well perhaps you better hang tough until FC2 test 2 is released, and install it from cds (hopefully you can get evolution put back in for you then). Either that or reinstall to downgrade. Unfortunately the first test release for FC2 was very raw, mostly because of the rush time in moving to kernel 2.6 and SELinux. Anyway, good luck to you.

All times are GMT -5. The time now is 01:46 AM.