-   Fedora (
-   -   ndiswrapper doesn't work with Dell TrueMobile 1300 in FC2 (

llimllib 05-28-2004 07:02 PM

ndiswrapper doesn't work with Dell TrueMobile 1300 in FC2
I'm trying to get my Dell TrueMobile 1300 wireless network card to work with a stock FC2 kernel and ndiswrapper .7 - I saw a message that 2.6.6 works, but I'm going to try and get it to work without that first.

Anyway, I get farther than most people seem to. Using drivers that I got from HP (link) on a tip from here, I have been able to insert the ndiswrapper into the kernel successfully. It is properly recognized by ndiswrapper -l and iwconfig.

It is here that I get stuck. Next I run system-config-network, go to new, wireless, ndiswrapper, and set the auth key for my network. Everything looks fine at this point. When I go to activate the card, however, a text box pops up to inform me that ifup has segfaulted at line 40. This line is the end of a block whose main statement is /usr/sbin/usernetctl ${CONFIG} up. I assume that CONFIG is wlan0, and that this statement is supposed to actually bring the card online.

At this point, system-config-network won't close, I can't kill iwconfig even with kill -9, and the system is generally F'ed up. Furthermore, when I try to reboot, the system will not cleanly reboot.

Does anyone have any suggestions? I'm going to try a beta version of ndiswrapper .8 next - I'll report the results here.

llimllib 05-28-2004 08:35 PM

ndiswrapper .8-rc1 works with the drivers that I linked above. So, the steps that I followed (as root) were:

1) Download and extract ndiswrapper .8-rc1 as well as the HP broadcomm drivers linked above
2) go to the directory where you extracted ndiswrapper and run "make install"
3) go to the directory where you extracted the HP broadcomm drivers and run "ndiswrapper -i bcmwl5a.inf"
3a) As jeffman pointed out below, you should run, as root, "ndiswrapper -m".
4) run "modprobe ndiswrapper". If you want to make sure this worked, type "dmesg | tail"; at the bottom you should see a line like "wlan0: ndiswrapper ethernet device xx:xx:xx:xx:xx:xx". I had errors that said "Buggy ndis driver trying to use unintilized spinlock"; I ignored them, and everything works fine.
5) run "system-config-network" and click the "new" icon at the top left. Select "wireless connection" then "ndiswrapper" on the next screen. On the third screen, enter your WEP key if your network is encrypted. Leave all the rest of the options as they are.
6) at the main config-network screen, select the wireless device, and click "activate" at the top right of the screen.

You should now be connected.

jeffman12 06-17-2004 09:10 PM

When I run "system-conffig-network" and try to add a wireless card, ndiswrapper is not there!!

Also, when I run ifconfig, at the bottom of wlan0's information, the last line reads:
Interrupt:11 Memory:faffc00-faffdff

llimllib 06-17-2004 09:28 PM

I dunno

dunno what to tell you; all I know is that when I followed the above steps on FC2, everything worked for me. Are you sure you're working with .8-rc1? Sure you're using the drivers that I linked above? I get more or less the same bottom line from ifconfig, just with a different memory address.

jeffman12 06-18-2004 12:30 PM

I got it working, had to run "ndiswrapper -m" and then I was able to add the wlan card to in "system-config-network".

llimllib 06-18-2004 01:04 PM

ok, I think I did ndiswrapper -m when I first compiled ndiswrapper, but that I didn't need to do it when I wrote up the instructions. Glad it worked.

jeffman12 06-18-2004 05:44 PM

What laptop do you have? If it's a Dell, any luck with getting the blacklight to turn off when the lid is shut? I have a program that will do that, but it does not stay off , it flicks back on every 5 seconds.

llimllib 06-18-2004 11:18 PM

never checked
it doesn't seem that it goes off, but I haven't examined it well.

shaneq 06-22-2004 06:45 AM


I had been trying to get my belkin broadcom card to work for the past 5 days.

I thought I had tried everything...

Recompiling my core to 2.6.7 and using the a version of the .inf sorted the job for me.

You have no idea how nice it felt to finally see it working.

Just wanted to say thanks...


llimllib 06-22-2004 10:37 AM

glad to see it worked.

Carlm81 06-25-2004 09:53 PM

Thank You SOOO much.

With your small guide i just got my wireless working on my dell 8600 laptop :D

How can i tell what the link speed is?

jeffman12 06-25-2004 10:05 PM

I think (I am just in the middle of upgrading to Slackware 10.0) that you can use
# iwconfig <your wifi interface eg. wlan0>
to show the current status of your wireless connection. If you don't have iwconfig, just search it at Search for wireless tools i think...

llimllib 06-25-2004 10:10 PM

I'm gonna guess here...
Well, I didn't google for the answer, but digging around my system seems to have provided an answer. Seems like, to find the link speed, you want to look at the files in /proc/net/ndiswrapper/wlan0 (assuming wlan0 is your card name). For example, typing, as root, "cat /proc/net/ndiswrapper/wlan0/hw" yields the following:

beacon_period=100 msec
atim_window=0 msec
frequency=2437000 kHZ
dwell_time=0 msec
tx_power=19 mW
bit_rate=11000 kBps
rts_threshold=2347 bytes
frag_threshold=2346 bytes

and "cat /proc/net/ndiswrapper/wlan0/stats" yields:

signal_level=-52 dBm

I recommend that you read the ndiswrapper faq, which contains some more helpful info.

llimllib 06-25-2004 10:15 PM

re: jeffman
Jeff, iwconfig does not display correct statistics when ndiswrapper is used; it always shows a perfect connection. I think you do have to dig into the alternate location I pointed to in my last post to get accurate statistics.

All times are GMT -5. The time now is 07:57 PM.