Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 09-16-2017, 07:20 AM   #16
LQ Newbie
Registered: Oct 2010
Distribution: Gnewsense
Posts: 4

Rep: Reputation: 0

Are you still having this problem?

I recently had a similar problem on an Ubuntu machine and it turned out GRUB was taking 2 seconds to load the kernel and 6 seconds load the initial ram disk. You can check if that's the case for you by putting "echo" statements in /boot/grub/grub.cfg before the "linux" and "initrd" commands in your default GRUB menu entry.

echo 'Loading Linux kernel ...'
linux /boot/vmlinuz-4.4.0-93-generic root=UUID=b2e326f9-bf78-46e2-bb27-b0703cd0361e ro
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-4.4.0-93-generic

Note that this isn't a permanent change as the grub.cfg file will be overwritten next time you run update-grub. I don't know how Fedora configures things, but in Debian and Ubuntu you can make those echo statements be added automatically by editing /etc/grub.d/10_linux and changing the variable "quiet_boot" from 1 to 0.
Old 09-16-2017, 09:36 AM   #17
Registered: Apr 2005
Location: USA
Distribution: Mageia,Fedora,RHEL,CentOS
Posts: 94

Original Poster
Rep: Reputation: 16
We are not having the problem anymore. One of my staff fixed it and I do not recall what he did and apparently I forgot to come back here and update this thread with the solution. My bad. I believe it was related to grub and/or kernel flags.
Old 09-18-2017, 09:06 AM   #18
LQ Newbie
Registered: Feb 2016
Location: Kerala, India
Distribution: Fedora
Posts: 5

Rep: Reputation: Disabled
Nice to know that you solved the issue. Unfortunately, I am still facing this annoying problem with fully updated fedora 24.
I have inserted the echo statements in grub.cfg as 'hackerb9' suggested. These are my findings.

Loading kernel ... (2 seconds)
Loading initial ramdisk... (6 seconds)
Probing...... (Booting starts)
So I am loosing 8 seconds everytime my computer starts. (Apparently I already lost 8 seconds per day for 365 days which is about 48 minutes!.. hahaa..). If you can recall how you corrected this issue, it will be really helpful.
Old 09-18-2017, 09:48 AM   #19
Senior Member
Registered: Aug 2009
Distribution: CentOS
Posts: 4,093

Rep: Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840
I just fixed a similar problem in a CentOS 6 installation by copying the initrd to a new file and then moving that file back to the original name. I have no idea why the original allocation of the file on the drive was causing GRUB to take a long time to load it, but the problem went away. This was on an SSD, so seeks should not have been an issue, and both files showed a similar pattern of ext4 extents when examined by debugfs. No, S.M.A.R.T. was not reporting any issues on the SSD.

Last edited by rknichols; 09-18-2017 at 09:50 AM.
Old 09-18-2017, 06:41 PM   #20
LQ Newbie
Registered: Feb 2016
Location: Kerala, India
Distribution: Fedora
Posts: 5

Rep: Reputation: Disabled
Thanks for your advice, but it doesn't solve my issue. I copied the file to home, deleted the original one, then copied it from home. And similar to your case, this problem started after I installed a new SSD.

This is a snippet of my grub.cfg. Could you find anything suspicious?

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (4.11.12-100.fc24.x86_64) 24 (Workstation Edition)' --class fedora --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-4.8.16-200.fc24.x86_64-advanced-9aa1950b-1716-4243-8397-f8c57071da83' {
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root='hd0,msdos1'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1' 8eae9d83-a05e-49fc-b739-4d7b6d7e5c20
search --no-floppy --fs-uuid --set=root 8eae9d83-a05e-49fc-b739-4d7b6d7e5c20
echo 'Loading Kernel...'
linux16 /vmlinuz-4.11.12-100.fc24.x86_64 root=/dev/mapper/fedora-root00 ro LANG=en_IN.UTF-8
echo 'Loading ramdisk...'
initrd16 /initramfs-4.11.12-100.fc24.x86_64.img


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How come I can't edit /boot/grub/grub.conf or /boot/grub/menu.lst in Fedora 14? trien27 Fedora 4 01-22-2011 05:02 PM
grub ide=nodma not working with CF card - boot delay srfeo Linux - Hardware 1 03-28-2007 09:42 AM
Grub - Delay before showing boot menu IK81 Linux - General 3 10-02-2006 12:02 PM
Mysterious F: partition on dual boot system bigoli Linux - Software 2 01-21-2005 01:15 PM
timeout (delay) in [RedHat] Grub southsibling Linux - Software 4 12-28-2003 12:24 PM > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 04:21 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration