LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 05-17-2007, 04:40 PM   #1
thedelicious
LQ Newbie
 
Registered: May 2007
Location: Maryland
Distribution: Ubuntu Edgy, soon Fedora Core 6
Posts: 7

Rep: Reputation: 0
Exclamation My situation with Ubuntu / Fedora


Ok, my situation is the following. I have my Sony VAIO notebook running Ubuntu Edgy 7.04, yesterday I bought an external hdd, My Book (250 GB), i use it and ubuntu immediatly recognized it via USB. What i would like to do, is to be able to still boot Ubuntu from my internal hdd and boot Fedora Core 6 through the external hdd. I would love to have grub recognize both OS and give me a choice of which to boot, what is the best way I can go about doing this? I would not like to lose any of my current data on the main filesystem or anything that I have copied to my external hdd already.

Thank you in advance to whoever can assist me.

Mike
 
Old 05-17-2007, 05:50 PM   #2
ctkroeker
Senior Member
 
Registered: May 2005
Location: Paraguay
Posts: 1,565
Blog Entries: 1

Rep: Reputation: 50
Just edit grub to recognize fedora on the external hdd.
http://www.linuxquestions.org/questi....php?p=2750347
http://ubuntuforums.org/showthread.php?t=443734
 
Old 05-17-2007, 07:04 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 347Reputation: 347Reputation: 347Reputation: 347
Mike, here's an edited copy of my GRUB boot file on my Gateway laptop:
Code:
$ sudo cat /boot/grub/grub.conf
 Password:
# grub.conf generated by anaconda
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,1)/splash.xpm.gz
#hiddenmenu
title Fedora Core (2.6.20-1.2948.fc6)
        root (hd0,2)
        kernel /vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.20-1.2948.fc6.img
title Fedora Core (2.6.20-1.2948.fc6) when USB is connected
        root (hd1,2)
        kernel (hd1,2)/vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd (hd1,2)/initrd-2.6.20-1.2948.fc6.img
title Fedora Core (2.6.20-1.2948.fc6) From USB
        root (hd0,1)
        kernel (hd0,1)/vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/USB_Fedora/Base rhgb quiet
        initrd (hd0,1)/initrd-2.6.20-1.2948.fc6.img
title WinXP
        rootnoverify (hd0,0)
        chainloader +1
title WinXP USB Connected
        rootnoverify (hd1,0)
        chainloader +1
Note the change of boot drive (hd0) to (hd1) when I boot while the USB drive is connected. That's because the Gateway laptop finds the USB drive before the HD, and GRUB changes the drive number assignments. (I sometimes also have a USB stick attached, which further complicates things, but -- since I don't often boot from it -- I usually just leave it unpluged 'till after the boot is finished.)

Since you're using GRUB, you can use the GRUB editor (and command line compleation) to help you discover what your hard drive and usb drive are called when you boot with the USB drive connected, and then chnage the GRUB configuration file as needed to match.

Note that, when you install Fedora on the USB drive, you can let it configure the USB drive to be bootable and install GRUB on it, but (unless you BIOS supports it) booting directly from the USB drive can be hard to do. (My Gateway can't do it, as far as I've been able to tell.) Also, I don't know if your Ubuntu installation uses Logical Volumes on you internal drive, but, if it does, make sure you edit Fedora's default Volume Group names so that they don't conflict with any used by Ububtu. Also, the Fedora installation may create a boot partition (labeled "/boot" by default) on the USB drive. That label may also conflict with one used by Ubuntu, and should be changed durng the install as well as the LV names. (From my config file above, you can see that I used a VG name of USB_Fedora with a LV name of "Base" for the "/" volume. You can't see it there, but the boot partition on that drive is labeled "/boot2" and the swap LV is named "Swap.")

Here's copies of what I use on the internal Linux to access the USB drives:
Code:
$ cat Scripts/MountUsb # Used to mount the USB Volume Group and Logocal vaolume
#! /bin/bash
# Mount /dev/sda if it exists
if [ -b /dev/sda ]; then
    sudo /sbin/vgchange -a y USB_Fedora
    sudo mount /usb
    sudo mount /usb/boot
    sudo mount /usb/shared
else
    echo Drive /dev/sda was not found.
fi

 $ cat /etc/fstab   # This is how the fstab on the internal drive is set up
/dev/VolGroup00/LogVol00 /                      ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                   swap    defaults        0 0

# Added by hand for acccess to the XP partitions
/dev/hda1               /hd/c                   ntfs-3g rw,uid=root,gid=disk 1 0
/dev/hda2               /hd/d                   vfat    uid=root,gid=disk 1 2
#
# SMB file system (Handelled by automount: See /etc/auto.master and /etc/auto.cifs)
#
# USB Drive -- Note the "noauto" option so there is no attempt to mount these during the boot of the HD
/dev/USB_Fedora/Base    /usb                    ext3   defaults,noauto  0 0
LABEL=/boot2            /usb/boot               ext3   defaults,noauto  0 0
LABEL=/shared           /usb/shared             ext3   defaults,noauto  0 0

Hope this helps.
 
Old 05-17-2007, 10:22 PM   #4
thedelicious
LQ Newbie
 
Registered: May 2007
Location: Maryland
Distribution: Ubuntu Edgy, soon Fedora Core 6
Posts: 7

Original Poster
Rep: Reputation: 0
Smile

Quote:
Originally Posted by PTrenholme
Mike, here's an edited copy of my GRUB boot file on my Gateway laptop:
Code:
$ sudo cat /boot/grub/grub.conf
 Password:
# grub.conf generated by anaconda
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,1)/splash.xpm.gz
#hiddenmenu
title Fedora Core (2.6.20-1.2948.fc6)
        root (hd0,2)
        kernel /vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.20-1.2948.fc6.img
title Fedora Core (2.6.20-1.2948.fc6) when USB is connected
        root (hd1,2)
        kernel (hd1,2)/vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd (hd1,2)/initrd-2.6.20-1.2948.fc6.img
title Fedora Core (2.6.20-1.2948.fc6) From USB
        root (hd0,1)
        kernel (hd0,1)/vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/USB_Fedora/Base rhgb quiet
        initrd (hd0,1)/initrd-2.6.20-1.2948.fc6.img
title WinXP
        rootnoverify (hd0,0)
        chainloader +1
title WinXP USB Connected
        rootnoverify (hd1,0)
        chainloader +1
Note the change of boot drive (hd0) to (hd1) when I boot while the USB drive is connected. That's because the Gateway laptop finds the USB drive before the HD, and GRUB changes the drive number assignments. (I sometimes also have a USB stick attached, which further complicates things, but -- since I don't often boot from it -- I usually just leave it unpluged 'till after the boot is finished.)

Since you're using GRUB, you can use the GRUB editor (and command line compleation) to help you discover what your hard drive and usb drive are called when you boot with the USB drive connected, and then chnage the GRUB configuration file as needed to match.

Note that, when you install Fedora on the USB drive, you can let it configure the USB drive to be bootable and install GRUB on it, but (unless you BIOS supports it) booting directly from the USB drive can be hard to do. (My Gateway can't do it, as far as I've been able to tell.) Also, I don't know if your Ubuntu installation uses Logical Volumes on you internal drive, but, if it does, make sure you edit Fedora's default Volume Group names so that they don't conflict with any used by Ububtu. Also, the Fedora installation may create a boot partition (labeled "/boot" by default) on the USB drive. That label may also conflict with one used by Ubuntu, and should be changed durng the install as well as the LV names. (From my config file above, you can see that I used a VG name of USB_Fedora with a LV name of "Base" for the "/" volume. You can't see it there, but the boot partition on that drive is labeled "/boot2" and the swap LV is named "Swap.")

Here's copies of what I use on the internal Linux to access the USB drives:
Code:
$ cat Scripts/MountUsb # Used to mount the USB Volume Group and Logocal vaolume
#! /bin/bash
# Mount /dev/sda if it exists
if [ -b /dev/sda ]; then
    sudo /sbin/vgchange -a y USB_Fedora
    sudo mount /usb
    sudo mount /usb/boot
    sudo mount /usb/shared
else
    echo Drive /dev/sda was not found.
fi

 $ cat /etc/fstab   # This is how the fstab on the internal drive is set up
/dev/VolGroup00/LogVol00 /                      ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                   swap    defaults        0 0

# Added by hand for acccess to the XP partitions
/dev/hda1               /hd/c                   ntfs-3g rw,uid=root,gid=disk 1 0
/dev/hda2               /hd/d                   vfat    uid=root,gid=disk 1 2
#
# SMB file system (Handelled by automount: See /etc/auto.master and /etc/auto.cifs)
#
# USB Drive -- Note the "noauto" option so there is no attempt to mount these during the boot of the HD
/dev/USB_Fedora/Base    /usb                    ext3   defaults,noauto  0 0
LABEL=/boot2            /usb/boot               ext3   defaults,noauto  0 0
LABEL=/shared           /usb/shared             ext3   defaults,noauto  0 0

Hope this helps.

It certainly does help out quite a bit, i appreciate it. One question, for the 2nd section of code, is that just to get Linux to recognize the USB drive? Because, when i plugged it in Ubuntu recognized it right away. Oh, in your GRUB file it says "From USB", did you just put that because you have Fedora loaded onto the USB drive as well as the main filesystem? Is the "kernel (hd1,2)/vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/VolGroup00" part the same if i were to install Fedora? Also, if i discover i do have "/dev/VolGroupx" directories within Ubuntu, do i configure the Fedora installation to create alternative folders in lieu of the normal ones due to already existing ones? Would it actually affect Ubuntu? Ubuntu is on a different hdd. I'm just so lost, im sorry! ^_^
 
Old 05-18-2007, 02:29 PM   #5
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 347Reputation: 347Reputation: 347Reputation: 347
Quote:
Originally Posted by thedelicious
I'm just so lost, im sorry! ^_^
Well, we'll try to lead you through the forest. In any case, all I wrote may all be irrelevant if Ubuntu doesn't use logical volumes, or if you override the defaults, and install Fedora without using them.

So, let's start by looking at your Ubunu system's fstab. That'll tell us how Ubuntu have been configured, since that's the file almost all Linux systems use to map the systems internal device names to actual physical system. (Just to keep you confused, there's another system, udev that lets you assign physical device name by, for examle, things like the devices serial number, or it's size, or that type of device it actually is, etc. But I'm going to assume that Ububtu is fairly standard as far as device names are concerned. If nothing I say seems to correspond to what you see, them I'm probably wrong, and you'll need some Ububtu specific help.)

Anyhow, here we go:

First open a terminal window in Ubuntu ans enter the command cat /etc/fstab to "concatinate" the contents of the file to the terminal display. You should see something like the first seven lines of the output of my use of that command I showed you above. The first column in the output tells you the physical location of the data, and the second column tells you what the data is called in the Ubuntu system. There should be a line with "/boot" in the second column, one with "swap" and one with "/".

If there's a /dev/hda1 (or 2 or 3 at the end) in the first column, it's pointing to a specific partition on your first hard drive, and you can just do the default Fedora installation to the USB drive because Ububtu won't care. Unless having the USB drive connected when you boot causes a boot failure, which would mean that the USB drive was added before the HD (like my Gateway system does it), so the dirve letters are changed.

If there's something like the /dev/VolGroup00/LogVol00 line in my file, then Ubuntu is using a logical volume, and you need to worry about the stuff I was describing. Basically, the "VolGroup00" (or whatever you have) is a "logical name" for a set of physical devices. (Usually that set has only one member, but it can be as large as 256 different drives. Or more. Sorry, I tend to digress. Which probably adds to your confusion.)

Anyhow, only if you see the lines like dev/VolGroup00 will you need to worry about the Fedora installation defaults. If you don't see them, just run a default installation to your USB drive, but be sure to uncheck the box that the Fedora installer will, by default, check which gives the installer permission to use your Ubuntu drive as well as the USB drive for the Fedora installation.

Quote:
It certainly does help out quite a bit, i appreciate it. One question, for the 2nd section of code, is that just to get Linux to recognize the USB drive? Because, when i plugged it in Ubuntu recognized it right away.
No, that's because the Fedora on the USB drive is set up in the default Fedora configuration using a Volume Group/Logical Volume to store the root file system, and I wanted to access it from the Fedora on the HD. (The logical volume is not accessable from the XP on the HD since the ext2 driver can't handle a logical volume. Thats the point of the "shared" partition.)
Quote:
Oh, in your GRUB file it says "From USB", did you just put that because you have Fedora loaded onto the USB drive as well as the main filesystem?
Yes.
Quote:
Is the "kernel (hd1,2)/vmlinuz-2.6.20-1.2948.fc6 ro pci=assign-busses,nommconf enable_8254_timer root=/dev/VolGroup00" part the same if i were to install Fedora?
No, that is specific for my system, and the stuff from pci= to timer is a "fix" for the Gatway BIOS .
Quote:
Also, if i discover i do have "/dev/VolGroupx" directories within Ubuntu, do i configure the Fedora installation to create alternative folders in lieu of the normal ones due to already existing ones? Would it actually affect Ubuntu? Ubuntu is on a different hdd.
Well, first of all, volume groups are not "directories." They're names assigned by the LVM system to sets of, usually, disk drive partitions on, potentially, several different hard drives. They can usually be thought of a "virtual" hard drives. That's why you find them listed in the /dev directory with all the other physical devices. This is sometimes a difficult concept for new Linux system users, but a convention was established in the 1970's that "everything" in a Unix system is a file, and that includes physical devices. Also, Linux does not distinguish physical devices like hard drives when setting up the file system. For example, in the fstab I've been discussing, there's a line for "/" and another for "/boot" which is on a different partition from "/". But if you do a ls /, you'll see "boot" listed as a directory under "/". On a system like Windows, the two directories would have to have different "drive letters," any you couldn't make one of them a subdirectory of the other.

The problem is that Fedora, by default, uses Volume Groups. If, Ubuntu also uses a volume group with the same name as used by Fedora (i.e. VolGroup00), then the volume manager will only access the first volume group it finds with the specified name. (Think of a "Volume Group" as a named hard drive, and you can see the problem the computer would have if you named two 'hard drives" with the same name. How would the computer be able to tell what you meant when to referred to the name?)
 
Old 05-24-2007, 11:55 AM   #6
thedelicious
LQ Newbie
 
Registered: May 2007
Location: Maryland
Distribution: Ubuntu Edgy, soon Fedora Core 6
Posts: 7

Original Poster
Rep: Reputation: 0
Fedora created a /boot that i can view from Ubuntu, it also has a second mount of sda2 which is LVM. I have altered my grub.conf alot but grub never can find the fedora image for some reason. I have put /media/usbdisk/imagefilenamehere, /dev/sda1/imagefilenamehere, and so on. I think maybe because Ubuntu has a /boot? How can i fix this?
 
Old 05-24-2007, 10:48 PM   #7
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 347Reputation: 347Reputation: 347Reputation: 347
Quote:
Originally Posted by thedelicious
Fedora created a /boot that i can view from Ubuntu, it also has a second mount of sda2 which is LVM. I have altered my grub.conf alot but grub never can find the fedora image for some reason. I have put /media/usbdisk/imagefilenamehere, /dev/sda1/imagefilenamehere, and so on. I think maybe because Ubuntu has a /boot? How can i fix this?
None of those "image names" you've suggested look like valid GRUB names. I'd expect to see something like (hd1,0)/<image_name>. You can easily see what GRUB wants by using the GRUB "editor" mode. That mode supports "tab completion" so, for example, entering (hd<tab> should list that available "completions" for {hd -- which would probably be hd0 hd1 for your situation. Assuming your correct value is (hd1,0) then a (hd1,0)/vm<tab> will list all the files in that partition with names starting with "vm," and so on.

The easiest way to get into the GRUB editor mode is to press <Esc> when GRUB first starts, select the menu entry you want to work on, and press the "e" key to display that entry. Then select the line you want to check, and press "e" again to edit that line. Or, if GRUB has failed to find the file you specified, it should have stopped then and offered to let you edit the entry, so, in that case, all you need to do is select the offending line and type "e" to get to the editor.

Once you've got what you think is the correct entry, write it down (if your memory is as unreliable as mine) and press "b" to have GRUB try to boot from it.

--------------------------------------------

In order to change the label of /dev/sda1 (if that's where the Fedora /boot is located) to, say, /boot2.

Procedure: Boot from the Fedora install media and boot in linux rescue mode (or, I suppose, just boot the Ubuntu system and open a terminal window and do a su - to get into "superuser" mode), and enter the command (again, making the assumption that sda1 is correct)

tune2fs -L /boot2 /dev/sda1

You will also need to change the /etc/fstab file to refer to the new label. If Ubuntu supports the LVM system, the command vgchange -a y should activate the logical volume, and then (still in Ubuntu) you can do a mount -t ext3 /dev/mapper/VolGroup00-LogVol00 /mnt to mount the Fedora root file system on /mnt. (The -t argument can usually be omitted, but it doesn't hurt.)

Once you've got the logical volume mounted, use whatever editor you wish to change the LABEL=/boot entry to LABEL=/boot2in /etc/fstab (which would be /mnt/etc/fstab if you've mounted the logical volume on /mnt as I suggested above).

Then change the GRUB entries to reference (hd1,0)/boot2/....

Oh, I picked /mnt as the place to mount the Fedora root file system because that's a common mount point. But you can create any directory in Ubuntu's file system to use as a mount point. For example, if you wanted to have your Ubuntu system "share" with the Fedora on your removable drive, you could create a top-level directory called, for example, "Fedora," with a mkdir /Fedora and then mount the Fedora root file system onto it. (See my prior comments for one way to create a script to mount the USB drive to your Ubuntu system. You don't want to just add an entry into Ubuntu's /etc/fstab to do the mount because the USB drive may not always be connected or turned on, and you'd get a boot error (not fatal, but annoying) when you booted Ubuntu.)
 
Old 06-06-2007, 07:54 PM   #8
thedelicious
LQ Newbie
 
Registered: May 2007
Location: Maryland
Distribution: Ubuntu Edgy, soon Fedora Core 6
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by PTrenholme
None of those "image names" you've suggested look like valid GRUB names. I'd expect to see something like (hd1,0)/<image_name>. You can easily see what GRUB wants by using the GRUB "editor" mode. That mode supports "tab completion" so, for example, entering (hd<tab> should list that available "completions" for {hd -- which would probably be hd0 hd1 for your situation. Assuming your correct value is (hd1,0) then a (hd1,0)/vm<tab> will list all the files in that partition with names starting with "vm," and so on.

The easiest way to get into the GRUB editor mode is to press <Esc> when GRUB first starts, select the menu entry you want to work on, and press the "e" key to display that entry. Then select the line you want to check, and press "e" again to edit that line. Or, if GRUB has failed to find the file you specified, it should have stopped then and offered to let you edit the entry, so, in that case, all you need to do is select the offending line and type "e" to get to the editor.

Once you've got what you think is the correct entry, write it down (if your memory is as unreliable as mine) and press "b" to have GRUB try to boot from it.

--------------------------------------------

In order to change the label of /dev/sda1 (if that's where the Fedora /boot is located) to, say, /boot2.

Procedure: Boot from the Fedora install media and boot in linux rescue mode (or, I suppose, just boot the Ubuntu system and open a terminal window and do a su - to get into "superuser" mode), and enter the command (again, making the assumption that sda1 is correct)

tune2fs -L /boot2 /dev/sda1

You will also need to change the /etc/fstab file to refer to the new label. If Ubuntu supports the LVM system, the command vgchange -a y should activate the logical volume, and then (still in Ubuntu) you can do a mount -t ext3 /dev/mapper/VolGroup00-LogVol00 /mnt to mount the Fedora root file system on /mnt. (The -t argument can usually be omitted, but it doesn't hurt.)

Once you've got the logical volume mounted, use whatever editor you wish to change the LABEL=/boot entry to LABEL=/boot2in /etc/fstab (which would be /mnt/etc/fstab if you've mounted the logical volume on /mnt as I suggested above).

Then change the GRUB entries to reference (hd1,0)/boot2/....

Oh, I picked /mnt as the place to mount the Fedora root file system because that's a common mount point. But you can create any directory in Ubuntu's file system to use as a mount point. For example, if you wanted to have your Ubuntu system "share" with the Fedora on your removable drive, you could create a top-level directory called, for example, "Fedora," with a mkdir /Fedora and then mount the Fedora root file system onto it. (See my prior comments for one way to create a script to mount the USB drive to your Ubuntu system. You don't want to just add an entry into Ubuntu's /etc/fstab to do the mount because the USB drive may not always be connected or turned on, and you'd get a boot error (not fatal, but annoying) when you booted Ubuntu.)

Ok, weeks later and i am still struggling. I have tried booting up with a cd in the drive named 'Super Grub Disk', and navigating through trying to locate the fedora stuff, but no luck. I think i may have to reinstall, if fedora uses LVM, would it conflict with ubuntu? It seems that Fedora used LVM, which doesnt cooperate well with Ubuntu. Also, after i took my external hdd to a windows pc for reformatting, it only recogized a partition with 232gb free, when my external hdd is 250gb. Any way to locate that lost partition, reformat it and then combine with the first 232gb partition one i just reformatted? I am sorry im so lost here. Thanks for all your help so far.
 
Old 06-07-2007, 11:39 AM   #9
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 347Reputation: 347Reputation: 347Reputation: 347
Quote:
Originally Posted by thedelicious
Ok, weeks later and i am still struggling. I have tried booting up with a cd in the drive named 'Super Grub Disk', and navigating through trying to locate the fedora stuff, but no luck. I think i may have to reinstall, if fedora uses LVM, would it conflict with ubuntu? It seems that Fedora used LVM, which doesnt cooperate well with Ubuntu.
I really don't know if Ubuntu uses LVM, but if you are going to reinstall Fedora, you can avoid the conflict by selecting the "Do my own thing" drive configuration option when it's offered. (Sorry, I've forgotten the real option name -- somthing like "Edit the configuration settings" or "Manual drive configuration." IIRC, it's the only check-box on the drive partion/configuration screen.)

Anyhow, once you get to screen where Fedora presents its proposed configuration, select, first, the boot partition, right click on it, and select "edit." Then change the proposed label from /boot to, e.g., /boot2 or /fedora-boot (note the leading slash). (Um, that description is from memory. It might be "left click" of "double click." Sorry to be vague, but it should be fairly easy to get the fields editable.)

Then select the proposed volume group, change its name to, again for example, Fedora, and the two volumes in the volume group should be named something like Root (the larger volume) and Swap.

Then let the install proceed. If you tell the intaller to put GRUB on the USB drive, the section in the /boot/grub/grub.conf (on the USB drive, not your HD) that's created will show you what you need to put into the Ubuntu grub.conf file to boot the USB. (Except, of course, that the root (hd0,1) value will need to be changed.)

Again, just so you have it handy, here's what my grub.conf file on the hard drive looks like:
Code:
$ sudo cat /hd/boot/grub/grub.conf
default=0
timeout=5
splashimage=(hd0,1)/splash.xpm.gz
title Fedora (2.6.21-1.3194.fc7)
        root (hd0,2)
        kernel (hd0,2)/vmlinuz-2.6.21-1.3194.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd (hd0,2)/initrd-2.6.21-1.3194.fc7.img
title Fedora (2.6.21-1.3194.fc7) USB Connected
        root (hd1,2)
        kernel (hd1,2)/vmlinuz-2.6.21-1.3194.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd (hd1,2)/initrd-2.6.21-1.3194.fc7.img
title Fedora Core (2.6.20-1.2952.fc6) From USB
        root (hd0,1)
        kernel (hd0,1)/vmlinuz-2.6.20-1.2952.fc6 ro root=/dev/USB_Fedora/Base rhgb quiet
        initrd (hd0,1)/initrd-2.6.20-1.2952.fc6.img
title WinXP
        rootnoverify (hd0,0)
        chainloader +1
title WinXP USB Connected
        rootnoverify (hd1,0)
        chainloader +1
title Gateway Recovery
        rootnoverify (hd0,1)
        chainloader +1
title Gateway Recovery USB Connected
        rootnoverify (hd1,1)
        chainloader +1
(I removed comments and the stuff used to "fix" my Gateway's BIOS to make the example a little less confusing.)

For your Ubuntu system, the first two entries would be the Ubuntu boot stuff, and you'd only need one entry if your BIOS attaches the USB drive after the HD. I need the two entries because GRUB finds the USB as (hd0) when it's connected, and the HD as (hd0) when the USB drive is not connected. That's also why I had to duplicate the XP and Recovery entries. Hopefully you will not need such complications.
Quote:
Also, after i took my external hdd to a windows pc for reformatting, it only recogized a partition with 232gb free, when my external hdd is 250gb. Any way to locate that lost partition, reformat it and then combine with the first 232gb partition one i just reformatted?
Remember, some systems report HD sizes in 1024 bit units, but manufactures usually use units of 1000 bits. Thats because the later system yields a larger number that can be printed in the advertising.

In any case, just let the Fedora install use the whole disk, and it will re-partition it using everyting that's available.
Quote:
I am sorry im so lost here. Thanks for all your help so far.
I wish that the help I've offered had actually solved you problem. Ah well, think of it as a "learning experience."
 
Old 06-07-2007, 04:22 PM   #10
thedelicious
LQ Newbie
 
Registered: May 2007
Location: Maryland
Distribution: Ubuntu Edgy, soon Fedora Core 6
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by PTrenholme
I really don't know if Ubuntu uses LVM, but if you are going to reinstall Fedora, you can avoid the conflict by selecting the "Do my own thing" drive configuration option when it's offered. (Sorry, I've forgotten the real option name -- somthing like "Edit the configuration settings" or "Manual drive configuration." IIRC, it's the only check-box on the drive partion/configuration screen.)

Anyhow, once you get to screen where Fedora presents its proposed configuration, select, first, the boot partition, right click on it, and select "edit." Then change the proposed label from /boot to, e.g., /boot2 or /fedora-boot (note the leading slash). (Um, that description is from memory. It might be "left click" of "double click." Sorry to be vague, but it should be fairly easy to get the fields editable.)

Then select the proposed volume group, change its name to, again for example, Fedora, and the two volumes in the volume group should be named something like Root (the larger volume) and Swap.

Then let the install proceed. If you tell the intaller to put GRUB on the USB drive, the section in the /boot/grub/grub.conf (on the USB drive, not your HD) that's created will show you what you need to put into the Ubuntu grub.conf file to boot the USB. (Except, of course, that the root (hd0,1) value will need to be changed.)

Again, just so you have it handy, here's what my grub.conf file on the hard drive looks like:
Code:
$ sudo cat /hd/boot/grub/grub.conf
default=0
timeout=5
splashimage=(hd0,1)/splash.xpm.gz
title Fedora (2.6.21-1.3194.fc7)
        root (hd0,2)
        kernel (hd0,2)/vmlinuz-2.6.21-1.3194.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd (hd0,2)/initrd-2.6.21-1.3194.fc7.img
title Fedora (2.6.21-1.3194.fc7) USB Connected
        root (hd1,2)
        kernel (hd1,2)/vmlinuz-2.6.21-1.3194.fc7 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd (hd1,2)/initrd-2.6.21-1.3194.fc7.img
title Fedora Core (2.6.20-1.2952.fc6) From USB
        root (hd0,1)
        kernel (hd0,1)/vmlinuz-2.6.20-1.2952.fc6 ro root=/dev/USB_Fedora/Base rhgb quiet
        initrd (hd0,1)/initrd-2.6.20-1.2952.fc6.img
title WinXP
        rootnoverify (hd0,0)
        chainloader +1
title WinXP USB Connected
        rootnoverify (hd1,0)
        chainloader +1
title Gateway Recovery
        rootnoverify (hd0,1)
        chainloader +1
title Gateway Recovery USB Connected
        rootnoverify (hd1,1)
        chainloader +1
(I removed comments and the stuff used to "fix" my Gateway's BIOS to make the example a little less confusing.)

For your Ubuntu system, the first two entries would be the Ubuntu boot stuff, and you'd only need one entry if your BIOS attaches the USB drive after the HD. I need the two entries because GRUB finds the USB as (hd0) when it's connected, and the HD as (hd0) when the USB drive is not connected. That's also why I had to duplicate the XP and Recovery entries. Hopefully you will not need such complications.
Remember, some systems report HD sizes in 1024 bit units, but manufactures usually use units of 1000 bits. Thats because the later system yields a larger number that can be printed in the advertising.

In any case, just let the Fedora install use the whole disk, and it will re-partition it using everyting that's available.
I wish that the help I've offered had actually solved you problem. Ah well, think of it as a "learning experience."
I played around with the Super Grub Boot CD and found that i can somehow find an initrd image to use that gets me into Fedora, now theres a new problem, a problem with my X configuration for my mouse. The first boot it just asked me to do some simple fedora config stuff, time, date, etc. Now it goes to the X config mouse problem, and keeps asking me to automatically search and configure, which never works. Maybe I'm just not meant to use Fedora? Haha..
 
Old 06-08-2007, 04:54 PM   #11
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 347Reputation: 347Reputation: 347Reputation: 347
Well, at this point, if I were you, I'd start a new thread about the mouse problem. Post the contents of /etc/X11/xorg.conf for people to look at, and also describe the type of mouse you have.

You might compare your Ubuntu xorg.conf file with the one on the Fedora. Perhaps you could just copy the mouse stuff from your Ubuntu setup to the Fedora one. (Hey, it might work.)

Remember, though, that Fedora (by policy) does not include any drivers that are not released under one of the Gnu Public Licenses. So, if you need a non FOSS driver, you'll need to look elsewhere (e.g., the [blivna[/b] repositories) for it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Situation coffeekid Linux - Newbie 10 02-18-2007 11:28 PM
Which distro for this situation amlucent23 Linux - General 4 06-20-2006 12:43 PM
Serious situation, please help wardialer Mandriva 10 04-22-2005 02:43 AM
my situation thing0 Linux - Newbie 9 02-18-2005 01:22 PM
L 99 99 99 situation after Suse 8.x Wizno Linux - Newbie 3 10-26-2003 03:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 08:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration