-   Fedora (
-   -   Mouse right-click issues (

andygmorris 07-11-2012 11:51 PM

Mouse right-click issues
Can anyone help with this issue? :-

I run F17 / 64-bit / Gnome on a laptop with a usb mouse and keyboard attached as I use an external monitor 99% of the time instead of the laptop display.

Right-click on the laptop works fine, and always has.
Right-click on the usb mouse works sometimes, mostly (95%) not.

In the System Settings / Mouse and Trackpad, there is a smiley face for me to test the mouse settings.
When I first run this and right-click the usb mouse on the smiley face (numerous times), face doesnt change.
When I right-click with the laptop button, the face changes as expected.
When I go back to right-clicking on the usb mouse, it eventually gets recognised and the face changes.
At this point, right-click in apps start working with the usb mouse then too!!
Possible hardware conflict/setting between laptop and usb mouse? If so, how to fix it?

All ideas appreciated.

Until now, I've just been bearing with it, but I need a fix. It's reducing my usage fluency.

It's causing far too many problems for my general usage now, and many times I have to stretch over to the laptop to press the right-click on the mouse to get to context-menus in applications and on websites that make use of right-click functionality.

Perhaps someone knows of the settings which need to be checked, set or tested?

Fingers crossed someone else's had this problem and got it fixed before.

I'm a daily linux user (of multiple machines), so you're welcome to ask me to dig into command line and any config settings. Just tell me where to look, and/or what to change.

Thanks (in advance)...

RockDoctor 07-12-2012 06:50 AM

Defective right button on the usb mouse? How well does the mouse work with one of the other machines?

andygmorris 07-21-2012 03:03 AM


Originally Posted by RockDoctor (Post 4725954)
Defective right button on the usb mouse? How well does the mouse work with one of the other machines?

Thanks for the reply.

I tried the mouse on two other machines and it worked fine. I tested it on a laptop and on a desktop (both running Fedora 17 32-bit). Both were fine, and no noticeable problems with right-click.

Bought a new mouse anyway, and that's working ok now on my F17 64-bit ... so there must've been something wrong with that original mouse's hardware even though the problem didnt show up on the other two machines.

I can consider this issue closed, and I can't point any finger at F17 or Gnome without further evidence.

All times are GMT -5. The time now is 02:04 AM.