-   Fedora (
-   -   Mouse Issues (

lehumphr 05-04-2004 10:44 PM

Mouse Issues
I moved my system from colleg back home this week and I was experiencing refresh rate issues(different monitor) but fixed those and the mouse isnt working at all.

The mouse is the same one that was previously working(Logitech MX500). IT is now connected to a kvm switch via a usb to ps2 adaptor then plugged into the ps2 port on my computer. I doubt it is the kvm switch because my keyboard is working fine with it.

I am thinking it is something inside my xf86config file and I found the section for the mouse but I have no clue what i need to change nor what i need to change it to.

Fedora Core 1
Logitech MX500
I believe it is the 4.3 ver of Xfree86.

Thanks for the help

dhbiker 05-05-2004 03:50 AM

if you could post what you currently have in your mouse section of XF86Config that'd make it easier to find what you have wrong

motub 05-05-2004 04:00 AM

It probably is something with your XF86Config file, but we can't psychically know what it says and tell you what to change if you don't post it, now can we ;) ?

Did you do more than simply physically move your machine? If your monitor problems were caused by a connection that was loosened during the move, you could reasonably guess that maybe that's what happened to your mouse as well and fix it yourself. If the problem was not a loose connection, but some kind of configuration fluke-- well, that's not caused by moving the machine from one physical location to another without upgrading something.

So I'm wondering if perhaps you changed your kernel from the 2.4 series to the 2.6 series (which would change your mouse device from /dev/psaux to /dev/mouse), or something similar that you have not mentioned.

lehumphr 05-05-2004 12:25 PM

All my connections internally are good. Thge monitor issues had nothing to do with connection problems they had to do with vertical and horizontal rates. I did not upgrade the kernel to 2.6 I am currently running 2.4. Following is the contents of the XF86 config file related to the input device:

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/mouse"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

# Option "Protocol" "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

# Option "BaudRate" "9600"
# Option "SampleRate" "150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"

# ChordMiddle is an option for some 3-button Logitech mice

# Option "ChordMiddle"

# **********************************************************************
# Other input device sections
# this is optional and is required only if you
# are using extended input devices. This is for example only. Refer
# to the XF86Config man page for a description of the options.
# **********************************************************************
# Section "InputDevice"
# Identifier "Mouse2"
# Driver "mouse"
# Option "Protocol" "MouseMan"
# Option "Device" "/dev/mouse2"
# EndSection
# Section "InputDevice"
# Identifier "spaceball"
# Driver "magellan"
# Option "Device" "/dev/cua0"
# EndSection
# Section "InputDevice"
# Identifier "spaceball2"
# Driver "spaceorb"
# Option "Device" "/dev/cua0"
# EndSection
# Section "InputDevice"
# Identifier "touchscreen0"
# Driver "microtouch"
# Option "Device" "/dev/ttyS0"
# Option "MinX" "1412"
# Option "MaxX" "15184"
# Option "MinY" "15372"
# Option "MaxY" "1230"
# Option "ScreenNumber" "0"
# Option "ReportingMode" "Scaled"
# Option "ButtonNumber" "1"
# Option "SendCoreEvents"
# EndSection
# Section "InputDevice"
# Identifier "touchscreen1"
# Driver "elo2300"
# Option "Device" "/dev/ttyS0"
# Option "MinX" "231"
# Option "MaxX" "3868"
# Option "MinY" "3858"
# Option "MaxY" "272"
# Option "ScreenNumber" "0"
# Option "ReportingMode" "Scaled"
# Option "ButtonThreshold" "17"
# Option "ButtonNumber" "1"
# Option "SendCoreEvents"


motub 05-05-2004 01:56 PM

This is a PS/2 mouse? If so, then /dev/mouse normally should be a symlink to /dev/psaux (or vice versa, but iirc under 2.4 kernels /dev/psaux is the real device and /dev/mouse is the symlink). Check and see if the link got broken, since /dev/psaux is now a USB device. In fact, as the USB device is now a redirect (from the hotplug USB device which reperesents the KDM switch) to a real device (/dev/psaux) which has to be linked to a symlink (/dev/mouse), the whole thing begins to sound like a recipe for trouble to me. So if I was you, I would just cut out the middleman, and set the mouse device directly to /dev/psaux in the config file.

Hope this helps.

lehumphr 05-05-2004 02:10 PM

It works now. woohooo back in the game. :-)

I appreciate it Motub.

motub 05-05-2004 02:21 PM

Hurrah! Glad to be of service :) .

drake42 05-27-2004 10:31 AM

Check if you are using a PS/2 -> USB converter
All of my KVM problems went away when I noticed that the actual mouse I was using was connected to the
KVM through one of those PS/2 (round plug) to USB (rectangle plug) converters.

I found another mouse that didn't need the converter, but still has the wheel and everything works great.

For me the IMPS/2 didn't matter and getting rid of the scroll wheel in XF86Config didn't help but getting that converter out of the way made everything work like magic.


bmzf 06-01-2004 05:44 PM

Similar issues with FC2 / KVM switch
I have similar problems with my setup. I use a KVM switch between two machines. Everything worked fine before.
I recently did a clean install to Fedora Core 2 and my mouse doesn't work at all with my linux box. The linksys KVM switch is working fine because the keyboard and monitor work on both computers but the mouse stopped working only on the Linux box.


The mouse is a logitech MX300 USB scrollmouse, connected to the KVM with a PS/2 adapter. Any help would be appreciated.

This is my xorg.conf file (I've tried the original /dev/input/mice and /dev/psaux) :

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "ViewSonic A72f-2"
DisplaySize 320 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "RIVA TNT2"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1152x864" "1024x768" "800x600" "640x480"

Section "DRI"
Group 0
Mode 0666

benk 07-25-2004 04:03 AM

Urm...sorry, I'm a bit lost in the above conversation, but I think you guys are talking about something that can help this newbie. I installed Fedora 2 on my laptop, getting the hang of it, but now I want to add a USB mouse to it and pluggin it in doesn't work. I recall somewhere that the system was hot-plugable? No? So, anyway, do you reckon I can get some help on setting up a USB mouse? I get the feeling that it's a terribly easy thing to do, but just can't figure it out. :scratch:

All times are GMT -5. The time now is 08:58 AM.