LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   Mouse goes crazy when switching to left hand mode in FC2 (https://www.linuxquestions.org/questions/fedora-35/mouse-goes-crazy-when-switching-to-left-hand-mode-in-fc2-197843/)

speedbird 06-26-2004 01:35 AM

Mouse goes crazy when switching to left hand mode in FC2
 
Apparently I could be considered affortunate, for I am the only left-handed user of Fedora Core 2 with mouse problems... :)

Irony aside, I would appreciate if someone could give me some pointers on how to solve my problem:

I recently upgraded from FC1 to FC2, it all went smooth and dandy, minor glitches such as the known "ln -s xorg.lst xfree86.lst" issue were promptly fixed thanks to the kind people posting in this forum.

I had switched to "right-hand" mode before I started the FC2 installation, "just to be safe" (FCx installations default to right-hand mode anyway), then when I booted up FC2 I tried to switch my mouse to "left-handed" mode, and the fun begun:

GNOME:
Clicking on the main menu will not "stick" the menu down, as soon as I release the mouse, the menu drop-down goes away. same for the context menus, any clickable menu have the same problem. I cannot click on any of my panel's icons, one button gives me the context menu help the other just "selects" the icon, can't execute any of my apps in that section.

I have a Logitech Wheelmouse USB (the blue/gray one), which I had been using in the "ps/2" mode from the RH 7 days, I just removed the adaptor and plugged it directly in the USB port, but with texacly the same problems, I read a posting where someone said that is was because there were two "mouse" Drivers in the the XF86Config file, using different devices, but in my case I have two entries for mouse but both with the same device, I do not know if this gives a hint of what the problem may be, here's the partial XF86Config file:

Code:

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection
                                                                               
Section "InputDevice"
                                                                               
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection

I would appreciate any help or comments in this issue,

Best regards,
speedbird

speedbird 06-27-2004 06:28 PM

K, got it to work, if you are a left-handed soul, and are using FC2, and the mouse acts like crazy, this may help you (it certainly worked for me):

Edit /etc/X11/XF86Config

In the Section "ServerLayout" area, comment out the line with the following: InputDevice "DevInputMice" "AlwaysCore"

If you happend to have TWO entries for your mouse, comment 1 out (here's my actual file (snip))

Code:

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "IMPS/2"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5"
        Option            "Emulate3Buttons" "no"
EndSection

#Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
#        Identifier  "DevInputMice"
#        Driver      "mouse"
#        Option            "Protocol" "IMPS/2"
#        Option            "Device" "/dev/input/mice"
#        Option            "ZAxisMapping" "4 5"
#        Option            "Emulate3Buttons" "no"
#EndSection

Restart

sweet,

SB


All times are GMT -5. The time now is 08:11 PM.