-   Fedora (
-   -   Missing eth0 when changing type of networking under VirtualBox (

JockVSJock 03-03-2013 09:53 AM

Missing eth0 when changing type of networking under VirtualBox
Mods: If this needs to move to Virtulization, then ok.

I'm running Fedora 18 in Virtual Box 4.2.6 and when I changed the networking from NAT to Bridged, I have lost my Internet Connection.

The nic shows up as P2P1, instead of eth0.

When doing some research online, I found that I need to go under /etc/networking/sysconfig/networking-scripts

Once I go there, I don't see eth0 file, however I don't see a way to add a file there. I do see P2P1 though..

Under this thread, it is stating to go under /etc/udev to make the modification


Wanted to update, that I put Fedora 18 back to NAT and the NIC shows up as P2P1.

However when I go under /etc/udev I don't see any entries for eth0.

Is there a way to get eth0 added?

netnix99 03-03-2013 02:19 PM


There has been a modification to change the naming convention of the ethernet ports to differentiate between on-board and PCI NICS. P2P1 stands for p<slot#>p<port#> (for PCI NICS), and ethX has benn changed to emX for on board NICS. You can change this back to ethX by removing the package biosdevname and reconfigiguring the /etc/udev/rules.d/70-persistent-net.rules (Red Hat - Fedora may be a little different) to say ethX rather than p2p1. I believe a restart is required for this change to take minimum, a service netowrk restart. I have read that you can alos override this by adding biosdevname=0 to the grub.conf, but I have not tested this myself. Here is a link to the WIKI regarding these changes:

JockVSJock 03-03-2013 04:37 PM

I'm stumped.

I've tried using all of the Network Adapters, and to no avail, still not able to get an ip address and get out onto the Internet.

Right now, my goal is to get Fedora 18 and Ubuntu 12.04 to talk to each other in VirtualBox.

I am trying to assign an ip address to Fedora 18 manually, based on the ip address of Ubuntu.

Ubuntu has the following:
-ip address
-bcast address

There is no gateway address listed and I don't see one from the GUI.

For the Fedora Box, I gave it the following:

-ip address

From Fedora box, I am unable to ping (DNS Server), getting destination unreachable.

I'm not sure what to do to fix this.


netnix99 03-03-2013 05:47 PM

Well, the reason that they will not currently talk to one another is that they are in two different networks, and if they do not hava gateway, they do not how to get out of or back into their own networks. If these machines are running on the same host, I woulod suggest putting them in the same network unless they are in seperate networks for a reason. If you want either of these machines to access the internet, they will need their own individual gateways set. By the IP address, they LOOK like they are in the same network, but the subnet mask tells what networks they are REALLY in.

UBUNTU - (this is a /23 subnet)
Fedora - (this is a /8 subnet)

If you give both machines the same subnet mask, they will talk to each other. They will not talk to the DNS (or internet) without a gateway.

If you give both machines a gateway, they will talk to each other and the internet, even though they are in different networks (different subnet masks).

All times are GMT -5. The time now is 10:36 PM.