-   Fedora (
-   -   Major opcode of failed request: 143 (GLX) (

delite 02-05-2009 07:45 PM

Major opcode of failed request: 143 (GLX)

Not too sure if this should be in the hardware forum?

Basically I was doing the tutorials from crystalspace, then the third set started throwing errors when running and quit. So I did some research and tried installing the fglrx packages (*3) (normally need straight away at install but FC10 seems ok without), so I did. Next I did a clean jam and ran the example, it worked, loaded the world, then after 10 sec's of roaming it froze the system. I ended up rebooting and now whenever I try anything OpenGL it dumps straight off like so...


# glxinfo
name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  11
  Current serial number in output stream:  11

This is my graphics card in my laptop, found using 'lspci':

01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200]
Do you know what I mean?

delite 02-06-2009 08:10 AM

Yes, i've now read this sticky, so sorry for the post. However I did use the livna repositry, but i'll try some more stuff now...

delite 02-06-2009 09:04 AM

I've not looked into 'cos i've not got time right now, but I just got this SELinux report....

SELinux is preventing aticonfig from loading /usr/lib/fglrx/ which requires text relocation.
Detailed Description
[SELinux is in permissive mode, the operation would have been denied but was permitted due to permissive mode.]The aticonfig
application attempted to load /usr/lib/fglrx/ which requires text relocation. This is a potential
security problem. Most libraries do not need this permission. Libraries are sometimes coded incorrectly and request this
permission. The SELinux Memory Protection Tests web page explains how to remove this requirement. You can configure SELinux
temporarily to allow /usr/lib/fglrx/ to use relocation as a workaround, until the library is fixed. Please file
a bug report against this package.

All times are GMT -5. The time now is 01:04 PM.