-   Fedora (
-   -   Madwifi is not compiling in Fedora 9 (

karenin 01-09-2009 09:00 PM

Madwifi is not compiling in Fedora 9
I have a Toshiba Satellite Laptop, and Fedora 9.
Mi wireless adapter recognized as Atheros Communications Inc. AR242X 802.11abg was not working fine in my new home network. Other computers with the same adapter worked well in this network so the network configuration is fine.
I upgraded to kernel 2.6.27 hoping to find a solution but I can't find how to configure my adapter and I cannot compile madwifi for this kernel.
When I type the "make" command I obtain the next error message


Checking requirements... ok.
Checking kernel configuration... ok.
make -C /lib/modules/ SUBDIRS=/home/miguel/Descargas/Madwifi/madwifi-nr-r3366+ar5007 modules
make[1]: Entering directory `/usr/src/kernels/'
  CC [M]  /home/miguel/Descargas/Madwifi/madwifi-nr-r3366+ar5007/net80211/ieee80211_power.o
/home/miguel/Descargas/Madwifi/madwifi-nr-r3366+ar5007/net80211/ieee80211_power.c: In function 'ieee80211_pwrsave':
/home/miguel/Descargas/Madwifi/madwifi-nr-r3366+ar5007/net80211/ieee80211_power.c:246: error: implicit declaration of function '__skb_append'
make[3]: *** [/home/miguel/Descargas/Madwifi/madwifi-nr-r3366+ar5007/net80211/ieee80211_power.o] Error 1
make[2]: *** [/home/miguel/Descargas/Madwifi/madwifi-nr-r3366+ar5007/net80211] Error 2
make[1]: *** [_module_/home/miguel/Descargas/Madwifi/madwifi-nr-r3366+ar5007] Error 2
make[1]: Leaving directory `/usr/src/kernels/'
make: *** [modules] Error 2

I have the ath5k module blacklisted (I don't know if this is a good idea).

Thanks for any idea

lazlow 01-09-2009 10:16 PM

You are aware that madwifi is available via rpmfusion?

karenin 01-10-2009 08:56 AM

Thanks. I installed madwifi via rpm fusion, but it still doesn't work.
As I said, other computers work just fine in this network, and my laptop work fine in other networks.
It seems to be a problem between my laptop and this network....
Any idea?

mickeyboa 01-12-2009 10:22 AM

Save yourself from the problems and just update to FC10, kernel-2.6.27 and it will solve all your problems, kernel-2.6.27 has the drivers for those Atheros cards.

PTrenholme 01-12-2009 11:23 AM

Unfortunately MadWifi support for the AR542x series in ath5k is, to quote from the code, "a work in progress." I'd suggest that you get the madwifi-hal- tarball from the snapshot site. That's mostly the ath_pci module, but it's a more recent release (3879) than the one you're using (3366).

The 2.6.26 and 2.6.27 kernels have been changing the wireless headers and structures so the MadWifi code has to be changed to correspond, and the older release you're using does not seem to be up to date. (The error you quoted is because the library function skb_append was - I presume - changed or eliminated in the newer kernels.)

The rpm-fusion madwifi package is, if I remember correctly, is based on the 0.9... code rather than the newer 0.10... code that supports 64-bit processors, so, if your laptop uses a 64-bit Fedora release, you won't have much luck with the rpm-fusion RPM.

tommyhot 02-10-2009 05:30 AM

PTrenholme: dude, i've registered here just to thank you. madwifi-hal- works perfect for me, even on newest stable kernel ( and debian lenny/sid. you saved me a lot of troubles.. thx again

4ng3ls 02-28-2009 09:15 AM

I had the atheros working seven hours ago but suddenly is not working anymore, i just take a nap and today is not working, the same problem powersave, it looks like someone need to take care of this, or make a better solution, updating is not an option.
rpm is not working, yum is not working on fedora... so...

All times are GMT -5. The time now is 07:31 AM.