LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 08-30-2005, 02:07 AM   #1
abhis_mail2002
Member
 
Registered: Oct 2004
Posts: 61

Rep: Reputation: 15
Logging into text mode defaulty


hi

i am using FC3 and now i want to log into text mode defaulty instead of graphical mode.i want to know which file i have to edit so that i can set my text mode.i dont want to use graphical mode and what changes i have to make in that file.

one more yest i installed redhat on my system it is getting stopped at configuring kernel parameters do any one have idea about this


regards
abhijit
 
Old 08-30-2005, 02:11 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You need to change your default runlevel, which is done by editing the /etc/inittab file (as root). Look for the line

id:5:initdefault:

and change the 5 to a 3 and save the file.
 
Old 08-30-2005, 02:36 AM   #3
abhis_mail2002
Member
 
Registered: Oct 2004
Posts: 61

Original Poster
Rep: Reputation: 15
hi nylex

i did it but it is not effecting it,again i am going to graphical mode only
 
Old 08-30-2005, 02:56 AM   #4
tomj88
Member
 
Registered: Apr 2005
Location: Wolverhampton, England
Distribution: Ubuntu
Posts: 334

Rep: Reputation: 30
If you never want to start in a display manager again, then why not completly uninstall it? Would either solve the problem, or solve the problem and kick up a horrible error saying something about gdm/xdm/kdm has not been found
 
Old 08-30-2005, 04:45 AM   #5
abhis_mail2002
Member
 
Registered: Oct 2004
Posts: 61

Original Poster
Rep: Reputation: 15
hi tom
if suppose in future i need it,then what shall i do it.
i just want the terminal as my default login , and whenever i require i can go into graphical using Startx
 
Old 08-30-2005, 04:47 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
That's strange :/. What does your /etc/inittab file look like?
 
Old 08-30-2005, 05:12 AM   #7
abhis_mail2002
Member
 
Registered: Oct 2004
Posts: 61

Original Poster
Rep: Reputation: 15
inittab This file describes how the INIT process should set up
# the system in a certain run-level.
#
# Author: Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault: /////////////////////////////////////////////////////

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left. Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.
pf:owerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345owerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
x:3:respawn:/etc/X11/prefdm -nodaemon //////////////////////////////
SV:123456:respawn:env - PATH=/usr/local/bin:/usr/sbin:/usr/bin:/bin svscan /service < /dev/null > /dev/console 2> /dev/console



////////////////////This places i made the changes from 5 to 3
 
Old 08-30-2005, 05:16 AM   #8
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally posted by abhis_mail2002
x:3:respawn:/etc/X11/prefdm -nodaemon //////////////////////////////
Did you change this line as well? You shouldn't have, it was only the runlevel that you needed to change, so change it back.
 
Old 08-30-2005, 05:25 AM   #9
abhis_mail2002
Member
 
Registered: Oct 2004
Posts: 61

Original Poster
Rep: Reputation: 15
thankx nylex i got it

do u have any idea about why the system is stopping at


///////////configuring the kernel parameters [ok]
 
Old 08-30-2005, 05:41 AM   #10
tomj88
Member
 
Registered: Apr 2005
Location: Wolverhampton, England
Distribution: Ubuntu
Posts: 334

Rep: Reputation: 30
Quote:
Originally posted by abhis_mail2002
hi tom
if suppose in future i need it,then what shall i do it.
i just want the terminal as my default login , and whenever i require i can go into graphical using Startx
I meant remove the display manager, not x. the display manager is the screen for logging in (graphical screen). You could use startx, kded or the other various programs for loading up your favourite desktop enviroment/window manager
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How change text color using linux in text mode only runlevel 3? Xavius Linux - General 7 05-07-2009 03:19 AM
How to; Suse9.3 prof. text mode to graphical mode anjum Linux - Software 5 07-21-2005 12:36 AM
Booting in text mode versus graphics mode LChalupa Linux - Newbie 3 01-15-2005 08:53 PM
[RedHat 8.0]How can I force it to boot in text mode before logging in? digsy Linux - Newbie 5 03-25-2003 02:15 AM
Logging in with text mode ... what happened to the GUI? orange400 Linux - General 1 03-02-2003 09:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 03:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration