-   Fedora (
-   -   logging in as root on fedora 10 (

andy1974 11-22-2008 08:24 PM

logging in as root on fedora 10
i installed the latest fedora 10 preview but found that i can not log in as root. when i try it says unable to auth user. i thought i might have messed up during install so i reinstalled and still have the same issue. any ideas?

billymayday 11-22-2008 08:28 PM

Most of the Fedora releases block root from logging in through the GUI, although that message doesn't sound right.

Can you log in as you and su to root?

Why do you want to log in as root anyway (you neither should, nor need to)?

andy1974 11-22-2008 08:31 PM

i have always been able to log on as root all the way up to fedora 9. i just like to log on as root to do the admin stuff

billymayday 11-22-2008 08:53 PM

Must be the RH's that block it then.

lazlow 11-22-2008 09:59 PM

I have not had RH or Fedora block(pre F10) out root login(although they can be configured that way).

In F9 they added the nag screen and I THINK in F10 they have gone this route(in the gui). Besides F10 will not be OFFICIALLY released for a few days. Yes, I know about the leaks.

You can do virtually anything you want to by opening a terminal and su - . I often do this with Nautilus. Most of the other system tools just ask for the root password.

andy1974 11-23-2008 10:36 AM

Thanks for the info :)

billymayday 11-26-2008 05:36 PM

Andy, tell me, are you using and non-local authentication methods?

I only ask because I installed F10 yesterday, and had issues with Fedora creating home directories on first login with ldap, so tried to log in as root and got exactly the same message.

I can only assume it was trying to authenticate root with my ldap server (which has no root user entry).


andy1974 11-26-2008 09:30 PM

nah , nothing special. just raw install. heres another odd issue....i was testing the pre relese and had no problems installing the pre relese. However now that it has been officially relesed i downloaded the iso file burned the cd live and now i am getting a error when trying to boot the cd. and i have tried 2 times from 2 diffrent mirrors and get the same. the error is as follows

"Bug in initramfs /init detected dropping to a shell . Good Luck"

i like how it says Good Luck and gives me a glimmer of hope, LOL

any ideas?

billymayday 11-26-2008 09:49 PM

The DVD worked for me for what it's worth.

Standard suggestion - burn it slower.

BallsOfSteel 11-26-2008 10:01 PM

I usually burn all .iso images at 2x. I didn't experience any problems.

andy1974 11-26-2008 10:15 PM

ok i reburned at a slower speed. that did the trick. anyone else try to log in as root?

billymayday 11-27-2008 02:59 AM

I tried (not that I ever do it usually), and no, it tells me the user couldn't be authenticated.

andy1974 11-27-2008 09:20 AM

ok just wanted to make sure it wasnt thanks. have you been able to set up a static ip on F10 ?

crimsonflame123 11-27-2008 09:47 AM

Well, I have developed a disliking for gdm ever since they pulled out the themes in Fedora 9.
And when I saw that they've gotten bolder this time by blocking root, I decided to replace gdm by kdm.
Works like charm and you can log in as root... :)
(Statutory Warning: Spending lot of time as root is not advisable.)

andy1974 11-27-2008 02:15 PM

i havent used KDM, i guess i will try it

All times are GMT -5. The time now is 10:03 AM.