-   Fedora (
-   -   ln: creating symbolic link `/dev/dvd' to `/dev/hdc': Permission denied (

qazwsx27 06-13-2005 01:35 PM

ln: creating symbolic link `/dev/dvd' to `/dev/hdc': Permission denied
I have just installed xine movie player. The player will play files but not from the dvd drive. I have tried 'ln -s /dev/hdc /dev/dvd'. I get "ln: creating symbolic link `/dev/dvd' to `/dev/hdc': Permission denied'. I have tried this command as root and the link is created. I have used the dvd drive as root.

Q: how do I set this up for a user.


satinet 06-13-2005 01:45 PM

Okay not too hard.

If you chmod 666 /dev/hdc and then run ln -s as root a link will be created that any user can use.

Alternatively you can probably add your user to the cdrom or dvd group. usermod +G cdrom

bassically it sounds like u need to chmod ur /dev/hdc to 666 then you should be able to like a ok.

anyway, you don't need to create a link as a users as it just has the same effective permissions as the target file.

qazwsx27 06-14-2005 12:08 PM

Thanks for the reply. Your suggestion works but the permissions seem to revert back when I rebooted and then had to 'chmod 666 hdc' again to play the dvd's with xine. I also had to chmod the mounted directories. chmod 666 /media/cdrecorder1.

When I try to use the user mount tool. I get the error "There are no filesystems which you are allowed to mount or umount. Contact your administrator." I wonder if this is related.

Fedora Core 3


qazwsx27 06-14-2005 02:09 PM

I think I've solved part of the problem. After I installed udev-039-10.FC3.7.i386.rpm the problem seems to have been fixed.

Due to a bug in udev released with Fedora Core 3.
Symlinks to CD-ROM's and DVD-ROM's were not being set up properly.
To fix, obtain a newer version of 'udev'. You can update 'udev' through 'yum'.

Check your version of 'udev':

[mirandam@charon ~]$ rpm -q udev

Fedora Core 3 installs: 039-8.FC3
06-Dec-2004 update: 039-10.FC3.5
16-Dec-2004 update: 039-10.FC3.6
15-Mar-2005 update: 039-10.FC3.7

# rpm -Uvh udev-039-10.FC3.7.i386.rpm

A reboot is required.

All times are GMT -5. The time now is 12:39 PM.