LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 10-23-2017, 11:32 PM   #1
timl
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Fedora,CentOS
Posts: 650

Rep: Reputation: 149Reputation: 149
libreoffice in read only mode


Hi,

I am running Fedora 26 and I recently noticed that all files opened by libreoffice were in read only mode. Eventually I realised I had just booted into a new kernel (4.13.4-200.fc26.x86_64). I reverted back to the old kernel (4.12.14-300.fc26.x86_64) and all was well.

Now along comes another kernel (4.13.5-200.fc26.x86_64) and the same problem occurs all files read only. So I am back to 4.12.14. As my version of LO was quite old I downloaded the latest (5.4.2.2) and the problem persists.

My documents are stored on my samba server so I checked a file on my PC. No problem. I am really not sure where the root of the problem lies a combination of Fedora, LO & Samba?. The last SMB update is dated Sep 24. I can't see any messages in systemctl or the samba logs on both computers (host and server). Has anyone experienced anything similar? I would like to report the bug but which bugzilla? I am tempted to say Fedora.

Cheers
 
Old 10-24-2017, 07:52 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 14,045
Blog Entries: 24

Rep: Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794Reputation: 3794
My first guess would be that it's a permissions issue. Windows does not understand Linux permissions.

The first thing I would do is, on the Samba server, check the permissions of the the document files using the ls -l command and let us know what you find.
 
Old 10-25-2017, 04:27 AM   #3
timl
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Fedora,CentOS
Posts: 650

Original Poster
Rep: Reputation: 149Reputation: 149
Hi Frank and thanks for jogging my memory as I have missed bits - the PCs in question are both running Fedora. The samba server is F25 and my main PC is F26. So the SMB information on my F26 box is largely irrelevant I did not even think about checking permissions but nothing out of the ordinary there (still running the old kernel on the main PC):

Here is the box running libreoffice
Quote:
[tim@eraserhead ~]$ ll /mnt/doco/Docs/Dear\ Diary.odt
-rwxrwxrwx+ 1 tim tim 81340 Oct 25 17:49 '/mnt/doco/Docs/Dear Diary.odt'
while over at the SMB end
Quote:
[tim@Havana ~]$ ll /home/shared/doco/Docs/Dear\ Diary.odt
-rwxrwxrwx. 1 tim tim 81340 Oct 25 17:49 '/home/shared/doco/Docs/Dear Diary.odt'
[tim@Havana ~]$
I'll have to boot the F26 box into one of the contentious kernels to see if permissions are any different. That will be tomorrow as I have run out of time today.

Cheers

Last edited by timl; 10-25-2017 at 04:30 AM.
 
Old 10-25-2017, 10:24 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,677
Blog Entries: 7

Rep: Reputation: 2393Reputation: 2393Reputation: 2393Reputation: 2393Reputation: 2393Reputation: 2393Reputation: 2393Reputation: 2393Reputation: 2393Reputation: 2393Reputation: 2393
Quote:
Originally Posted by timl View Post
rwxrwxrwx
i think these are really weird permissions to have, but who knows, maybe it's a samba thing? :shrugs:
anyhow, with these permissions it MUST be a libreoffice issue, directly or indirectly.
 
Old 10-27-2017, 07:49 PM   #5
timl
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Fedora,CentOS
Posts: 650

Original Poster
Rep: Reputation: 149Reputation: 149
Hi,

I logged this one with redhat

https://bugzilla.redhat.com/show_bug.cgi?id=1506472

The solution suggested
Quote:
So a solution until SMB3 POSIX extensions are available would be to modify your mount options to force SMB1.
Unfortunately eludes me at the moment. Searches to force SMB1 typically result in how to force SMB2/3 or how to disable SMB1. I tried to use the knowledge gained and modify smb.conf
Quote:
min protocol = SMB1
max protocol = SMB1
However my guess work was wrong
Quote:
[tim@Havana ~]$ testparm /etc/samba/smb.conf
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: Ignoring invalid value 'SMB1' for parameter 'min protocol'
Error loading services.
Any suggestions on how to to modify mount options to force SMB1?

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
outline mode in libreoffice purplewelshy Linux - Newbie 8 01-27-2016 07:06 PM
[SOLVED] partition in Read only mode amartlk Linux - Newbie 6 12-17-2011 04:12 AM
read-only mode problem sqon Linux - Newbie 2 01-20-2011 12:48 AM
Open office read only, K-write read/write mode lwtvh Linux - Newbie 1 07-19-2003 11:33 AM
Fs mounted in Read Only , Read Write Mode benjaminrtz Linux - General 2 07-31-2002 02:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 02:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration