-   Fedora (
-   -   Legacy Nvidia driver install problem (

Larry Webb 05-13-2010 08:58 PM

Legacy Nvidia driver install problem
The only access that I have to the internet is a wireless option silver streak wireless modem on windows. I am trying to install drivers for the Nvidia video card that I downloaded to a cd. I went into /etc/yum.repos.d and 0 all the enables and created a new directory as:

name=My Disc
baseurl=file:///media/My Disc\ cd/

yum --disablerepo=* --enablerepo=My Disc

I get an error telling me it can not access the repo.

Any help or suggestions?

smoker 05-13-2010 11:16 PM

Where did you get the drivers from ?

Your repo won't work because there is no repo. Just because you call it a repo doesn't make it so. There is a special tool for creating repos and without using that then you don't have the correct files in place.

If you download the nvidia drivers from nvidia, you don't need a repo, you just run the binary file they provide from run level 3.

Type man createrepo to see if it's on your system. But with only 1 file then it's not a repo anyway, as it will have no way of fulfilling dependencies.

John VV 05-14-2010 12:12 AM

read and fallow the instructions on the fedora web site
" F13, F12 & F11 Nvidia driver guides "
the instructions are there for the 173 and 96 drivers

THERE IS NO nvidia 3d driver on the install cd/dvd -- there NEVER will be
there is a 2 d ONLY nv driver that will be auto installed and will let gnome or kde run

Larry Webb 05-14-2010 03:19 PM

The only internet access I have is a windows machine. John I downloaded the two 96xx drivers (free and non free)you had listed and burned them to a cd. I do not know how to get this modem to work with fedora in a text only. All I want is to get xorg going. Would it be easier to download a driver from nvidia to install? I was trying to get yum to install from the cd but can not get the right commands.

I also tried
yum install //media/cd/My/kmod-nvidia-96xx xorg-x11-drv-nvidia-96xx-libs.i686

That did not work either.

DrLove73 05-14-2010 05:46 PM

You have something terribly wrong if you can not use "nv" pre-installed drivers to run GUI. Your problem then is not nVidia drivers but X-server problem. google little and try to fix it.

Larry Webb 05-14-2010 06:06 PM


Originally Posted by DrLove73 (Post 3968860)
You have something terribly wrong if you can not use "nv" pre-installed drivers to run GUI. Your problem then is not nVidia drivers but X-server problem. google little and try to fix it.

Not getting smart but I have wore the google button out. This problem only occurs with the latest kernels. I have installed an older version of Freespire and Tiny Me with no problems.

The video card is a nvidia MX4000

smoker 05-14-2010 11:08 PM

Which version of Fedora is it ?

Yes it is easier to get the nvidia drivers from nvidia.

What problems are you having in the first place ?

John VV 05-14-2010 11:26 PM

if you are using the driver AND NOT the one made for fedora in the fedora repos
then you need to reinstall the .run EVERY TIME there is a kernel,X11,xorg update

seeing is the .run for the 96 driver dose not change save it to /
and do not delete it

but just to boot into the gui just remove the xorg.conf and fedora will auto use the nv driver

text boot and run this in the text only terminal
-- log in as ROOT --

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old

edit the xorg.conf with " nano" and change
driver " nvidia"
-- to --
driver "nv"

smoker 05-14-2010 11:44 PM

How can you tell the OP to do things when you don't know what the specific problem is, or what the version of fedora is ?

He has no gui and no net connection. Upgrading the kernel is the last problem to worry about.

The nv driver won't work on later versions of fedora if nouveau is enabled, because he won't get past boot.

Let the OP provide the details of the specific problem first before giving random fixes.

John VV 05-15-2010 12:11 AM


Upgrading the kernel is the last problem to worry about.
the OP stated that he updated the kernel

DrLove73 05-15-2010 04:26 AM

OP actually only said that that problem is happening on newest kernels.

OP does not know the difference between install/update from repository and from binary file.

OP does not have internet connection on the Fedora box in question.

Larry, I suggest you follow post #8 so you can get working GUI with 2d incorporated drivers, and then use crossover LAN cable to connect windows and Fedora, if you do not have them connected to a LAN switch, and then in windows create Internet Connection Sharing so Fedora can access the internet via windows box.

Then use Fedora repositories where nVidia drivers are already present, rpmfusion maybe, and you will no longer have problems with those drivers AND you will be able to update Fedora anytime you want.

Larry Webb 05-15-2010 10:25 AM

Let me start over; I bought a used school computer
3.2 gig Pentium 4 - 2 gig mem - 320 gig hd - nvidia mx4000 video card.

I am attempting to install fedora 12. I did a format and new install this morning.

I then used system recovery and used bash as root to:
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
no such file or directory

I then checked and there is a /etc/ directory, a /etc/X11/ directory which is empty.

Yesterday I also tried the "install" option with 'basic video' with no results.

I do not know why the 2d driver does not work. That is all I am interested in at this point.

If it is the computer than why does Tiny Me and Freespire install and work? The reason I want to install fedora is for its large repository.

I bought one of those cd bundles and Suse 11.2, Puppy Linux, Mandrake One 2010, and Knoppix 6.2 have the same problem.

I am beginning to wonder if there is some bios problem, maybe the school had some type of block or something.

I am open to any suggestions and will try and answer questions

DrLove73 I will order a network crossover cable.

John VV 05-15-2010 03:15 PM

" /etc/X11/ directory which is empty."
fedora stopped NEEDING a xorg.conf file a long time ago

tuse use the nvidia tool to make one
apparitions / system tools /nvidia-x display conf

read the fedora nvidia install guide
"F13, F12 & F11 Nvidia driver guides"


rpm -Uvh
yum install kmod-nvidia-96xx xorg-x11-drv-nvidia-96xx-libs.i686

and blacklist nouveau
( this is what i used on fedora 11 ( and current arch and cent )
but it is also just as easy to use the ( seeing as it is about to hit end of life and will not be changing much just reinstall ALL of mesa , and mesa-devel if the run driver is used

DrLove73 05-15-2010 03:47 PM

Search the web for info on how to configure X system on fedora 12 and do so by selecting VESA mode. That should let you run X. Short of recommending CentOS 5.5 that is just out with additional repositories for bundle of desktop software like Skype beta, I do not know what to say. I tried Fedora only once or twice and saw it as irritatingly lacking full control. So I am sticking with CentOS 5.x until CEntOS 6.0 based on Fedora 12 comes out an the end of the year.

Larry Webb 05-29-2010 08:33 PM

Just to inform anyone else with an intel D865 GLC motherboard with a nvidia video card that the video card may not be the reason your fedora 12 will not boot. I found an error 111 IO report and that according to fedora is with the kernel usb routing and that I should try and upgrade or use an older version. I am not giving up, will post more when I have a workable solution other than older.

I have blacklisted the noveau driver.

All times are GMT -5. The time now is 03:28 PM.