LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   Laptop touchpad acts weird in firefox (https://www.linuxquestions.org/questions/fedora-35/laptop-touchpad-acts-weird-in-firefox-582826/)

der_11 09-06-2007 11:50 PM

Laptop touchpad acts weird in firefox
 
I just installed Fedora 7 on my laptop and when I'm in a web browser or similar if I use a quick up/down motion on the pad it makes the page go back/forward accordingly.

Is there a way to disable this? I think I need to change something in my xorg.conf, but I have no idea what to change/add.

So here it is:
Code:

# Xorg configuration created by pyxf86config

Section "ServerLayout"
        Identifier    "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option            "XkbModel" "pc105"
        Option            "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option            "Device" "/dev/input/mice"
        Option            "Protocol" "auto-dev"
        Option            "Emulate3Buttons" "yes"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection


rivalarrival 09-07-2007 09:37 AM

I *think* you need to add:

Code:

Option "HorizScrollDelta" "0"
to this section:

Code:

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option            "Device" "/dev/input/mice"
        Option            "Protocol" "auto-dev"
        Option            "Emulate3Buttons" "yes"
EndSection

Code:

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option            "Device" "/dev/input/mice"
        Option            "Protocol" "auto-dev"
        Option            "Emulate3Buttons" "yes"
        Option      "HorizScrollDelta" "0"
EndSection

This will disable the horizontal scrolling that (I think) is causing the problems.

Additional information and other options are available by typing "man synaptics" in a terminal window.

PTrenholme 09-07-2007 10:23 AM

Or you could search for the Synaptics control program for your GUI and install it. (I use ksynaptics under KDE.)

You may need to add the shared memory options to your xorg.conf file. Here's what mine looks like:
Code:

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
        Option      "SHMConfig" "true"
        Option      "UseShm" "true"
EndSection



All times are GMT -5. The time now is 05:58 PM.