LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   Kernel Panic!! Help please? (https://www.linuxquestions.org/questions/fedora-35/kernel-panic-help-please-226429/)

bangy 09-04-2004 12:35 AM

Kernel Panic!! Help please?
 
I did something really stupid tonight, messing with stuff I didn't really know. Curiosity really screwed me over this time.

I upgraded my original kernel that came with FC2, and now I am getting that

"Kernel panic: no init found", can someone please tell me how I can fix it?

The problem is I did a rpm -Uvh with an RPM I compiled and it has replaced the old (the one that WORKED) one. Now I'm stuck with only 1 non-functional kernel and I really don't want to wipe out the comp.

ppuru 09-04-2004 12:40 AM

wow!

Try getting into rescue mode ... either with the rescuecd that came with the FC2 distribution - OR using CD-1, follow the instructions and gt into rescue mode.

chroot /mnt/sysimage (this is where your salvaged linux lives)

check whether you can rpm -ivh the original kernel in. Then make changes to your grub.conf to get this kernel recognised if it isn't already.

bangy 09-04-2004 12:47 AM

Wow, fast response! I figured out the /mnt/sysimage thru the "df" command :)

Anyways, I'm a little ahead of myself, but assuming I can get the original kernel to work, how can I fix this init error? I wanna try what this new kernel is all about

bangy 09-04-2004 12:54 AM

and also... a little update.

I tried rpm -ivh, it complains about the current kernel(the one that's not working) being newer, so it will not let me install. Is there a way around this? I tried to rpm -e the old kernel, but it's got about 10 other packages that need it, so that's not an option, damn!

bangy 09-04-2004 01:22 AM

--oldpackage

My computer's alive again lol, what an educational night.. But yeah, how would I fix that init error? I want to see if the other kernel is faster!

ppuru 09-04-2004 04:28 AM

What is the init error? Have you compiled in the drivers for ext3/reiserfs? Perhaps you need an initrd file too.

bangy 09-04-2004 03:01 PM

Here's the error, the "......" are lines in between

-------------------------------------------------------------------------------

.Uncompressing Linux.... Ok, booting the kernel
.........
.......
mount: error 19 mounting ext3
......
Kernel panic: No init found. Try passing init= option to kernel

--------------------------------------------------------------------------------

Then it just sits there.


I was following the guide at www.linux-militia.net for installing their CK kernel. http://www.linux-militia.net/kernel/....1-ck6.tar.bz2

Do I need to compile the drivers for ext3/reiserfs too? I'm not quiet sure how to do that.




Update: Nevermind, I got everything running now, silly me =)

ppuru 09-05-2004 01:26 AM

always better to compile the fs drivers into the kernel... although it is not necessary when you use initrd.


All times are GMT -5. The time now is 10:57 PM.