LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   Kernel panic: Fatal exception in interrupt (https://www.linuxquestions.org/questions/fedora-35/kernel-panic-fatal-exception-in-interrupt-205228/)

dickmobbis 07-15-2004 12:16 AM

Kernel panic: Fatal exception in interrupt
 
It was really challenging to make my Lucent softmodem work in FC2 because I'm new to Linux but I managed to do that using drivers ltmodem-2.6-alk-4.tar.bz2 (http://linmodems.technion.ac.il/pack...em/kernel-2.6/). Modem query runs OK. I get the same reply on commands as in Windows (I have FC2 and WinXP installed).
Next step is to dial my ISP.
First I used KPPP and had no luck: the modem dials, I hear usual sounds of establishing connection - then a click (like when I finish session) and
my computer hangs!!! Only RESET helped.
Next time I used wvdial in console mode - I thought I would see some sort of output at least.

Really, after

ATDTP '1232323'
Waiting for CARRIER

I heared a click and some strange errors on the whole screen (many errors like irq_error)

And finally (last 4 lines):

---------------------------------------
Code f3 aa 89 d8 5b 5f c3 90 90 57 83 c9 ff 56 89 c6 31 c0 53 89
<0> Kernel panic: Fatal exception in interrupt
In interrupt handler - not syncing


I'm new to Linux and I don't know how to solve this problem!

My guess was that the interrupt my modem used (irq 5) was shared by some other device so I
opened case and moved it into other PCI slot - it helped a bit - irq changed from 5 to 3 - but still no luck with wvdial or kppp.

I've heared about setserial command to change irq manually and I tried (my soft modem is /dev/ttyLT0):
#/sbin/setserial /dev/ttyLT0 irq 7 (for example, I tried other values)
Wrong value or smth like this - again no luck.

Is this kernel problem? Can I fix this without installing another kernel?
What can I do?

I can get online only from WinXP (here my modem works as it should).
I want to get rid of Win as soon as possible but modem is a serious problem.
I like FC2, I managed to make many things work and I don't want to use another distro (at least for now). Please help me.
I have asked people on LinuxQuestions.org but noone replied.

Thank you in advance.

/***************************************
Kernel - FC2 default: 2.6.5-1.358

AXP2500+
MB Elitegroup K7VTA3 KT333
RAM 256Mb
Video GF4MX440 128 Mb
HDD ST80Gb
****************************************/

P.S. While compiling drivers for my modem I saw such strings in output of 'make':
warning: ltmodem_virtual_interrupt - no CRC check! - or smth like this.
Is this important?

Will new kernel solve the problem? I'm currently downloading 2.6.6.-1.435.2.3.


All times are GMT -5. The time now is 01:58 AM.