LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 11-15-2004, 11:48 AM   #1
Spooky
Member
 
Registered: Dec 2002
Location: Portugal
Distribution: Fedora Core 5
Posts: 82

Rep: Reputation: 15
KDE sound


In my KDE the sound does not work properly ... it works but the sound is delayed... But i gnome it works just fine with no problem.
I am work with FC3 in an Laptop so take tha in mind.

where can i see the configuration of the sound?

thanks

Spooky
 
Old 12-05-2004, 12:41 PM   #2
Apexdv
LQ Newbie
 
Registered: Dec 2004
Location: ATL-GA
Distribution: FC3
Posts: 19

Rep: Reputation: 0
Ditto...

Same prob here. I am using FC3 on a PIII, 933 MHz (desktop). I created a new user account, logged into KDE and the sound worked like a charm. Logged back into Gnome as the new user (worked fine) then back to KDE and boingo...sound issues.

Within Gnome: "Multimedia Systems Selector" is set to Audio= ESD on both and Video= Sink=SDL, Default=v4l . . . if this helps.
 
Old 12-06-2004, 07:08 PM   #3
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
Try going into the KDE control center and go to Sound settings and "Disable Sound Server Startup" ... or something similar to that.
 
Old 12-07-2004, 07:43 AM   #4
Apexdv
LQ Newbie
 
Registered: Dec 2004
Location: ATL-GA
Distribution: FC3
Posts: 19

Rep: Reputation: 0
Question "Sound...Startup"

Within KDE under RH8, in the Sound Server area there was a "Start sound server at startup"....but, I am now using Fedora Core 3 and that option is nowhere to be found. (is my build incomplete or something?) However, within Gnome, I did find a similar option under "Preferences" which I disabled: didn't change anything in KDE, of course.

The absence of the "enable sound server at startup" option within the FC3 KDE control center: is this normal? That was the first thing I looked for.

Keep in mind, if I create a new user, login initially with KDE the sound works great from the get-go. However, once the new login goes into Gnome (still...sound is good) then back into KDE the sound problems emerge. Could this be a bug? Spooky: did you resolve yours?
 
Old 12-07-2004, 05:56 PM   #5
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
In "Sound & Multimedia" > "Sound System" > [x] Enable the sound system

By the way, all your sound output *should* be set to Alsa (if the options exists), most major apps and new apps support Alsa.
 
Old 12-08-2004, 09:10 AM   #6
Sharky01252
Member
 
Registered: Nov 2004
Posts: 31

Rep: Reputation: 15
The Dissable sound server option should still be there in FC3 in the control center under Sound and Multimedia i think,...

I had many many problems with sound under FC3 until i dissabled the sounder server for kd3 and used OSS... Alsa did exactly what u described and played delayed, then i fixed that and the thing skipped all the time and decided to use up all my processor power..
 
Old 12-08-2004, 11:02 AM   #7
Apexdv
LQ Newbie
 
Registered: Dec 2004
Location: ATL-GA
Distribution: FC3
Posts: 19

Rep: Reputation: 0
Quote:
Originally posted by mjmwired
In "Sound & Multimedia" > "Sound System" > [x] Enable the sound system

By the way, all your sound output *should* be set to Alsa (if the options exists), most major apps and new apps support Alsa.
Yes, it does exist. Just the verbage has changed from previous versions (RH8): it used to be "Enable Sound Server at Startup". That is enabled. Too, under the "Hardware" tab I had "Autodetect" listed under the "Select the audio device". Changed that to ALSA, logged out, back in...nothing still.

Apexdv
 
Old 12-08-2004, 11:04 AM   #8
Apexdv
LQ Newbie
 
Registered: Dec 2004
Location: ATL-GA
Distribution: FC3
Posts: 19

Rep: Reputation: 0
Quote:
Originally posted by Sharky01252
The Dissable sound server option should still be there in FC3 in the control center under Sound and Multimedia i think,...

I had many many problems with sound under FC3 until i dissabled the sounder server for kd3 and used OSS... Alsa did exactly what u described and played delayed, then i fixed that and the thing skipped all the time and decided to use up all my processor power..
If I disable the sound server (via the checkbox I presume?) the hardware tab is then disabled (ghosted). How do I activate OSS (or any other such as ALSA) at that point?

Apexdv
 
Old 12-08-2004, 11:17 AM   #9
Apexdv
LQ Newbie
 
Registered: Dec 2004
Location: ATL-GA
Distribution: FC3
Posts: 19

Rep: Reputation: 0
Is it a conflict within Gnome?

Okay, tried the different settings with the sound server both on and off. Still the same issue. The point is, the sound in KDE works perfectly until I log into Gnome, then back to KDE. Is there something within Gnome that is overwriting a config file somewhere?

I know, I know..."use KDE" or "just use Gnome" but both have characteristics that I need/like/enjoy. In RH8 I had no issues with switching between the two all the time (the sound functioned equally well in both).

Perhaps I should reinstall aRts, ALSA, OSS or something? Any suggestions as to the root cause? Any log files I could examine to locate the malfunction?

Thanks,

Apexdv

Last edited by Apexdv; 12-08-2004 at 11:19 AM.
 
Old 12-08-2004, 05:59 PM   #10
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
Try disabling sound events in Gnome. So you know, ALSA and OSS are your kernel supported sound systems. They are basically always "on" since they are the drivers that allow you to output sound. All newer kernels run Alsa by default, OSS is old and soon to be discontinued.

Arts and Esd are the sound systems for KDE and Gnome, respectively. I doubt if reinstalling them will make a difference.

I must ask, why does a person need to login to KDE, then Gnome, then back into KDE? All gnome apps run under KDE, and almost all KDE apps run under Gnome.
 
Old 12-08-2004, 10:26 PM   #11
Apexdv
LQ Newbie
 
Registered: Dec 2004
Location: ATL-GA
Distribution: FC3
Posts: 19

Rep: Reputation: 0
Quote:
Originally posted by mjmwired
Try disabling sound events in Gnome. So you know, ALSA and OSS are your kernel supported sound systems. They are basically always "on" since they are the drivers that allow you to output sound. All newer kernels run Alsa by default, OSS is old and soon to be discontinued.

Arts and Esd are the sound systems for KDE and Gnome, respectively. I doubt if reinstalling them will make a difference.
I had already disabled sound events from within Gnome and still the same.

Quote:
I must ask, why does a person need to login to KDE, then Gnome, then back into KDE? All gnome apps run under KDE, and almost all KDE apps run under Gnome.
I didn't need to login back and forth. Each has their unique characteristics and "appeal". As a relatively new Linux user I am trying to decide which I prefer. I have frequently read about how "John Q Linuxuser" hates KDE but loves Gnome yet "Jane P Useroflinux" thinks Gnome sux and KDE rocks. Just trying to decide for myself. Others within my family (we have a small home network: 5 nodes total) have already began to choose, as well.

Back to the sound-events issue: not sure if I stated it clearly but, the sound does work. If I open Xine, Xmms, etc I can listen to wav's, mp3's, watch mpeg's and vob's, etc. It is only the sound-events within KDE that are not playing. It really bugs me if my system has a feature that will not operate correctly.

By the way: How would I disable the KDE sound server and still have the KDE sound events work via ALSA or OSS? Can that be done and if so, how? And if that works then why wouldn't the sound server operate correctly as it did within RedHat 8?

Last edited by Apexdv; 12-08-2004 at 10:30 PM.
 
Old 12-09-2004, 08:54 AM   #12
Apexdv
LQ Newbie
 
Registered: Dec 2004
Location: ATL-GA
Distribution: FC3
Posts: 19

Rep: Reputation: 0
Noatun makes it work...

Interesting tidbit I just discovered. I was trying all the settings (once again), went to:

"Control Center"
"Sound & Multimedia"
"System Notifications"
"Player Settings..." button
checked the "Use external player:" option and chose "noatun"
"OK"
"Apply"

Now the system sounds are working...strange...



 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how do you turn off sound in KDE if you don't use KDE? solusrex Linux - Software 1 07-29-2005 08:56 PM
KDE blocks sound? cant play sound from other programs. Smurfen Linux - Hardware 1 04-02-2005 07:14 PM
Gentoo 64-bit on AMD. Console sound with ALSA OK, but no sound in KDE. damien Linux - Software 7 02-02-2005 01:05 AM
kde sound options gone except for root, login sound gone memphisSuseUser Linux - Distributions 2 12-10-2004 05:55 PM
Gnome has sound/switch to KDE no sound Lar Fedora 6 11-05-2004 03:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 06:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration