LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 10-20-2005, 12:01 AM   #1
Kerrysl
Member
 
Registered: Oct 2005
Location: Sydney, Australia
Distribution: Fedora 8, (previously FC6, FC5, FC4, FC3, & Mandrake 10)
Posts: 70

Rep: Reputation: 15
kde.org cookie at session start??


I am using FC3 with KDE3.4. I am also using KDM for my login screen (nice wallpaper and different colours for dialog box and buttons). System works fine but at every login to a session I get a cookie notice of a cookie from 'www.kde.org' wanting to be set. If I reject this cookie and then go to Control Center to change any of the login parameters I get this cookie warning being generated again.

Here is a picture of the cookie warning;
http://www.theslavinfamily.com/images/cookie.jpg

Does anyone know what is triggering this cookie, or how to turn it off?
 
Old 10-20-2005, 09:19 PM   #2
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
look thru the KDE control center.......there is an KDE Auto-update daemon working..........you can turn it off............
 
Old 10-21-2005, 03:41 AM   #3
Kerrysl
Member
 
Registered: Oct 2005
Location: Sydney, Australia
Distribution: Fedora 8, (previously FC6, FC5, FC4, FC3, & Mandrake 10)
Posts: 70

Original Poster
Rep: Reputation: 15
Thank you for your reply.

I have had a look through Control Center but can't identify anything. I did find the cookie in the KCookieJar which I manually deleted but that made no difference. I have turned cookies off in Konqueror, but that doesn't stop it either.

The cookie appears on the login screen, even before logging in. It appears before the KDM wallpaper loads. Even if my session type is Gnome, the kde cookie will again makes its appearance on the next login before I select what type of session it is.

The list of running start-up daemons from Service Manager are;
KDED Media Manager
KDE Internet Daemon
KDE Write Daemon
KMILO
Network Status Daemon

I believe this issue started either when I upgraded from KDE 3.3 to 3.4 or maybe when I started using Apache web server for development. I think most likely when I did the upgrade.

Do you have any more information about what I should be looking for?
 
Old 10-21-2005, 06:50 AM   #4
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Rep: Reputation: 30
what happens if you choose to accept all cookies from this domain?

also in control center there is a setting under KDE Components/Session Manager....choose to start with an empty session
also check KDE Components/KDE Performance and do not preload an instance of konqueror at startup
 
Old 10-22-2005, 02:42 AM   #5
Kerrysl
Member
 
Registered: Oct 2005
Location: Sydney, Australia
Distribution: Fedora 8, (previously FC6, FC5, FC4, FC3, & Mandrake 10)
Posts: 70

Original Poster
Rep: Reputation: 15
Thanks for the repy.
I tried both of those but they made no difference. I can understand the logic of those suggestions but I think those things load as KDE is starting up. I think my issue occurs before that.

I was reluctant to try the accept all cookies from this domain option, as I really don't want their cookies unless I choose them. However I did try it and it only has the following effect. For the current session it prevents further cookie warnings. However as soon as the session is ended there is the cookie warning again on the next login.

I really think that it must be triggered by a script that runs after X starts but before KDE loads. Since the contents of the cookie relates to locale it is obviously holding the information of my preferred or currently set locale. However, what I don't understand is why this is being stored or set in a cookie. Surely that info is already stored in config files on the system, so why the cookie.

What is really intriguing is why other people are not reporting the same issue. What is it about my settings or system that triggers the use of cookies at startup?
 
Old 10-22-2005, 06:33 PM   #6
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Rep: Reputation: 30
that is a good question, i never have had anything like that. try creating another user and log in with that one to see if it repeats. also if you are going into x to start with, try going into runlevel 3 and typing startx to see if it happens then too
 
Old 10-23-2005, 03:48 AM   #7
Kerrysl
Member
 
Registered: Oct 2005
Location: Sydney, Australia
Distribution: Fedora 8, (previously FC6, FC5, FC4, FC3, & Mandrake 10)
Posts: 70

Original Poster
Rep: Reputation: 15
OK problem solved.

After a lot of trial and error (removing Apache, Mysql from runlevel 5, putting hidden users back into kdmrc that I had removed, changing login screen to plain colour) all of which failed, I finally stumbled upon the culprit.

In the advanced settings for the background there is the option to use Kwebdesktop to draw the background. This had been set when I was playing with translucency with the composite engine. I switched that off and suddenly no more cookie notices. Also my background screen on the login screen comes up a whole lot faster and without all of the disk thrashing that I was getting with KWebdesktop enabled.

So for anyone that stumbles upon this thread, unless you need KWebdesktop, disable it in Control Center/Login Manager/Background/Advanced Settings.

Thank you jmarshall85 and freakyg for your time & suggestions, they kept me going in the right direction to find a fix. I must say that the response here is a whole lot better than FedoraForums.org where this same question went totally unanswered by anybody. I don't know if this forum has a bigger user base, but it certainly does seem to get questions answered faster than some of the other forums.
 
Old 10-24-2005, 06:22 AM   #8
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Rep: Reputation: 30
glad you got it working and thanks for posting the fix. that is what makes this forum so good
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
session timeout for cookie does not work Linh Programming 2 08-18-2004 02:42 PM
Sorry dumb question - how to start graphical root session in KDE OrganicOrange84 Linux - Newbie 4 08-16-2004 06:29 AM
Command to start remote KDE session on Debian The_Fed Linux - Newbie 1 04-19-2004 04:31 PM
Start New Session KDE Gentoo aeruzcar Linux - General 0 11-02-2003 08:56 PM
KDE cookie prob. CragStar Linux - Distributions 3 06-21-2001 04:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 06:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration