LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 05-11-2009, 11:48 PM   #1
cottonseed
LQ Newbie
 
Registered: May 2009
Distribution: Fedora Core 10
Posts: 4

Rep: Reputation: 0
Installed FC10 on Dell Latitude D600 now CPU at 100%


Hello everyone. This is my 2nd post, so I'll try and get everything in here that I can. Thanks in advance to anyone that can offer some sort of direction.

I installed FC10 with the GNOME Desktop Environment on my Dell Latitude D600. Everything seemed to go smoothly until I started to use the machine. The system is now slow as syrup. Running the System Monitor > Resources screen shows CPU at 75%+ while spending half that time maxed at 100%.

Below is the partial profile I get from System Monitor > System:

Fedora

Release 10 (Cambridge)
Kernel Linux 2.6.27.21-170.2.56.fc10.i686
GNOME 2.24.3

Hardware

Memory : 1009.3 MiB
Processor: Intel(R) Pentium(R) M processor 1.60 GHZ

System Status

Available disk space: 28.6 GiB

Below is the output of lspci

00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet (rev 01)
02:01.0 CardBus bridge: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller (rev 20)
02:01.1 CardBus bridge: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller (rev 20)
02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

I'll provide any other information that I can. I just have no idea where to start looking to see why this machine of mine is running this way.
 
Old 05-11-2009, 11:57 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,525

Rep: Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744
We need to know who the prime suspect(s) is/are. Run this from a terminal and post the output
Code:
top -b -n 1 | head -n 25
 
Old 05-12-2009, 12:09 AM   #3
cottonseed
LQ Newbie
 
Registered: May 2009
Distribution: Fedora Core 10
Posts: 4

Original Poster
Rep: Reputation: 0
Code:
top - 21:00:59 up  6:50,  2 users,  load average: 1.40, 1.35, 1.30
Tasks: 132 total,   2 running, 130 sleeping,   0 stopped,   0 zombie
Cpu(s): 56.6%us,  5.4%sy,  0.8%ni, 36.3%id,  0.4%wa,  0.3%hi,  0.3%si,  0.0%st
Mem:   1033528k total,   845416k used,   188112k free,    90276k buffers
Swap:  2097144k total,        0k used,  2097144k free,   475472k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                          
 2297 root      20   0  117m  27m 9364 R 76.8  2.7  80:55.04 Xorg                                                             
 1977 root      20   0 17672 2840 2312 S  6.5  0.3   7:52.18 NetworkManager                                                   
18844 ereckers  20   0  2424  948  724 R  6.5  0.1   0:00.07 top                                                              
 1764 dbus      20   0 13608 1664  868 S  4.9  0.2   8:29.03 dbus-daemon                                                      
 2779 ereckers  20   0 51656  17m  11m S  1.6  1.8   1:24.74 nm-applet                                                        
 4481 ereckers  20   0 57680  23m  15m S  1.6  2.3 125:23.23 gnome-system-mo                                                  
 5750 ereckers  20   0 63148  16m  10m S  1.6  1.6   0:12.98 gnome-terminal                                                   
    1 root      20   0  2012  780  572 S  0.0  0.1   0:04.22 init                                                             
    2 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 kthreadd                                                         
    3 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 migration/0                                                      
    4 root      15  -5     0    0    0 S  0.0  0.0   0:00.87 ksoftirqd/0                                                      
    5 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 watchdog/0                                                       
    6 root      15  -5     0    0    0 S  0.0  0.0   0:01.82 events/0                                                         
    7 root      15  -5     0    0    0 S  0.0  0.0   0:00.02 khelper                                                          
   81 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 kintegrityd/0                                                    
   83 root      15  -5     0    0    0 S  0.0  0.0   0:00.52 kblockd/0                                                        
   85 root      15  -5     0    0    0 S  0.0  0.0   0:01.21 kacpid                                                           
   86 root      15  -5     0    0    0 S  0.0  0.0   0:00.39 kacpi_notify
Thanks for the simple request. Amazing that I did this (top earlier) and somehow never just searched for the issue. I see a lot of posts with Fedora and Xorg issue, so I am looking into those now.

Last edited by cottonseed; 05-12-2009 at 12:28 AM.
 
Old 05-12-2009, 12:35 AM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 17,525

Rep: Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744Reputation: 2744
Well that was easy - now comes the hard part. You'll have to chase issues with X and Radeon/ATI drivers I would suspect.
 
Old 05-12-2009, 12:40 AM   #5
cottonseed
LQ Newbie
 
Registered: May 2009
Distribution: Fedora Core 10
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks. I'll look into that. I did find this particular bug:

Bug 437255 - Xorg cpu usage jumps up to 97% when running gnome-system-monitor (Resources tab)
https://bugzilla.redhat.com/show_bug.cgi?id=437255

That's not all all of it and I'll look into your suggestions on the video drivers, but I can say that the minute I closed down the System Monitor things started to speed up. There are however, still some crazy pikes up to 50%+ and back down to under 1% for Xorg and the system is not yet correctly tuned.

Last edited by cottonseed; 05-12-2009 at 12:42 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable Bluetooth on Dell Latitude D600 fearofcarpet Linux - Hardware 2 10-14-2007 04:14 PM
Slackware on Dell Latitude D600 esteeven Slackware 5 04-26-2007 01:22 AM
linux on dell latitude d600 leow Linux - Laptop and Netbook 2 12-19-2006 06:06 PM
Dell Latitude D600 and Suse 9.1 karoliina Linux - Laptop and Netbook 3 12-08-2004 06:34 PM
Mandrake 9.1 and graphics on the Dell Latitude D600 Bebo Linux - Laptop and Netbook 17 08-20-2003 02:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 10:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration