-   Fedora (
-   -   Installation Bootloader Fail - SoaS (

crasslogic 09-13-2012 05:21 AM

Installation Bootloader Fail - SoaS
Greets all.
I need help with something please. I have a Dell Optiplex G270, Pentium 4 2.26ghz, 2gb Ram.
Anyway, I recently took out my old 40gb hardrive and put in a 400gb drive. I am trying to install the live image of the Fedora Spin "Sugar On A Stick". At the end of the install, I get a message that there was an error installing the bootloader. I have no idea how to even research this.

First of all, I can install any other OS just fine.
Allow me to detail what i've tried so far.
The hard drive didn't have an OS on it. I first installed Fedora 17 Sugar On A Stick and after the partitioning and copying the live image, I got the bootloader error. I was getting an error from cfdisk when I rebooted into the live CD about one of the partitions being beyond a boundary. Don't recall that exact error.
Anyway, I then booted into Slackware and used fdisk to wipe the partition table. I tried the SoaS install a couple times with different schemes (using LVM, not using LVM, ext4, ext3, a custom layout, etc.) Still the same problem.
Next I fired up Plan9 as a quickie and installed it with no zero problems. Next I fired up Fedora again telling it to use all space and got the bootloader install failure yet again. I then tried Windows XP, and later Slackware and no problems installing and booting either of those. I tried Fedora again, and same error. I cannot figure out what's going on! It's making me crazy, so here I am coming to you from the live CD.

I'm kind of old school. I used Slackware for a good many years a good many years ago! I know how to work with lilo but I don't know anything about grub or grub2. I'm assuming either I simply can't install this, or more likely, i'm going to have to do something manually. I really don't believe it's a problem with my hard drive since none of the other mentioned OSes are having any problems reading it's full capacity or installing something to the MBR.
I greatly appreciate any help. Thanks.

Forgot to mention that when I do boot off the hard drive despite the bootloader installation failure message, it fills about half of my screens with the number 99 and locks up. Never seen that before.

By the by, I did at one point re-download and re-burn the iso just in case, so I'm sure there isn't a problem with the installation media.

2armz 09-13-2012 09:41 AM

have you tried a different hard drive? I had my centos box, start flashing a bunch of 00.000000 something like that. And it pointed towards a hardware problem with my video card. I took it out, and used the on board one and it worked fine. So maybe the hard drive is bad, or another hardware problem.

2armz 09-13-2012 09:44 AM

Also reset the bios, could be a problem as well. I know changing video cards, it acts crazy until i remove the cmos battery, then after a restart, and shutdown, reinstall it. So that could be an issue as well.

crasslogic 09-13-2012 12:23 PM

Messing with the bios didn't do me any good :(
I have to doubt it's the hard drive since all those other OSes worked just fine.
Any other idears?

2armz 09-13-2012 12:48 PM

Might just be a bad distro at the moment. I remember my really first attempt with SuSe10 and I manage to get the one with a bug in it. Search for boot loader bugs for that OS. Weird things happen.

crasslogic 09-14-2012 02:02 PM

I finally solved the issue detailed below this morning. I could not under any circumstance get F17, after finishing the installation, to successfully install the bootloader. After all the crap below, what I finally did to make this work was install the previous version of Fedora (F16, SoaS) which so happened to go all smooth including the bootloader install. I let the installer use the full drive, ext4, NO LVM. Next, I re-did the install for F17 using the option "replace existing linux system" and voila. I don't know what the h*ll could've possibly been so different since all the other OS's worked yet F17 would not, but something in switching between the two versions allowed my install to work and now Sugar and Fedora have a nice 400gb space to reside on. Like I said, all this experimentation and work, and Grub2 would not install no way no how until I nearly gave up and tried this switch from F16 to F17. Go figure.

Take care all. All the best.

All times are GMT -5. The time now is 11:51 AM.