LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 03-30-2006, 04:37 AM   #1
FireGunz
Member
 
Registered: Mar 2006
Distribution: Fedora Core 5 i386 DVD | Kernel 2.6.16-1.2080_FC5 | YUM v2.6.0 | GNOME v2.14.0 |
Posts: 42

Rep: Reputation: 15
How to permanently disable/enable boot-up services for fc5


Hi, can anyone help about

How to permanently disable/enable boot-up services for fc5

due to I got nVidia-glx problem when pc booting up until the login screen. which become 2 colour into the blank screen. if i disable the nVidia-glx during bootup then the login screen back to normal.
 
Old 03-30-2006, 05:19 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
See the man page for chkconfig, example;

chkconfig --levels 345 kudzu off
chkconfig --levels 345 kudzu on

Try removing the rhgb portion from the kernel line in /boot/grub/grub.conf for the blank screen problem. When the grub bootsplash screen is displayed press any key. Highlight the Linux boot choice and press the 'e' key. Highlight the line that begins with something like 'kernel /vmlinuz' and press the 'e' key, delete the 'rhgb' portion and one space. When done press the 'Enter key' followed by the 'b' key.
If this one time change works make it permeant, rpm -e rhgb
 
Old 03-30-2006, 06:35 AM   #3
FireGunz
Member
 
Registered: Mar 2006
Distribution: Fedora Core 5 i386 DVD | Kernel 2.6.16-1.2080_FC5 | YUM v2.6.0 | GNOME v2.14.0 |
Posts: 42

Original Poster
Rep: Reputation: 15
hi Lenard, check with you that you say See the man page for chkconfig? under this forum or in my terminal?

I want to disable the service nVidia-glx (for the time been)

the reason is every time I bootup need to press "i" for interact... (what ever that call) then the splash screen will show the text for detect what I got. so when the Service nVidia glx appear i need to press "N" then the rest i press c then it will contuine by itself then to the login screen (normal)

So which / how I need to do for the setting?

I (root)
type:

Code:
chkconfig --help
chkconfig version 1.3.29 - Copyright (C) 1997-2000 Red Hat, Inc.
This may be freely redistributed under the terms of the GNU Public License.

usage:   chkconfig --list [name]
         chkconfig --add <name>
         chkconfig --del <name>
         chkconfig [--level <levels>] <name> <on|off|reset|resetprioritie
so what should I need to set or type for chkconfig

and as you say level 345 what that mean for ?
 
Old 03-30-2006, 06:42 AM   #4
FireGunz
Member
 
Registered: Mar 2006
Distribution: Fedora Core 5 i386 DVD | Kernel 2.6.16-1.2080_FC5 | YUM v2.6.0 | GNOME v2.14.0 |
Posts: 42

Original Poster
Rep: Reputation: 15
now I have list the nvidia-glx

Code:
chkconfig --list nvidia-glx
nvidia-glx      0:off   1:off   2:on    3:on    4:on    5:on    6:off
so am I going to type (root):

Code:
chkconfig --levels 2345 nvidia-glx off
then as you write below:

Try removing the rhgb portion from the kernel line in /boot/grub/grub.conf for the blank screen problem. When the grub bootsplash screen is displayed press any key. Highlight the Linux boot choice and press the 'e' key. Highlight the line that begins with something like 'kernel /vmlinuz' and press the 'e' key, delete the 'rhgb' portion and one space. When done press the 'Enter key' followed by the 'b' key.
If this one time change works make it permeant, rpm -e rhgb

how to I going do that, could you show me out (me still new for FC also i'm )
 
Old 03-30-2006, 09:18 AM   #5
FireGunz
Member
 
Registered: Mar 2006
Distribution: Fedora Core 5 i386 DVD | Kernel 2.6.16-1.2080_FC5 | YUM v2.6.0 | GNOME v2.14.0 |
Posts: 42

Original Poster
Rep: Reputation: 15
ok, i think should be this way (please see where I'm done the correct way)

type:
Code:
chkconfig --levels 345 nvidia-glx off
type:
Code:
service nvidia-glx stop
then as for -> Try removing the rhgb portion from the kernel line in /boot/grub/grub.conf for the blank screen problem.

you mean edit or delete the grub.conf file (if edit, how using which program to open it OR if delete, how to delete the file?
 
Old 03-30-2006, 09:43 AM   #6
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
Don't delete your grub.conf file! That would be a really bad idea. You want to edit it, using whichever text editor you prefer (though you will need to be root to do so). You will have a line that looks something like this:
Code:
kernel /vmlinuz-2.6.12-10-686-smp root=/dev/sda8 rhgb
You need to change it to something like this:
Code:
kernel /vmlinuz-2.6.12-10-686-smp root=/dev/sda8
In other words, all you need to do is remove the rhgb kernel option. Note that your grub.conf will not look exactly as shown above, but similar - you need to find the line(s) beginning "kernel".
 
Old 03-30-2006, 09:46 AM   #7
FireGunz
Member
 
Registered: Mar 2006
Distribution: Fedora Core 5 i386 DVD | Kernel 2.6.16-1.2080_FC5 | YUM v2.6.0 | GNOME v2.14.0 |
Posts: 42

Original Poster
Rep: Reputation: 15
ok, i got the link for that -> http://www.linuxquestions.org/questi...hreadid=188870
 
Old 03-30-2006, 09:59 AM   #8
FireGunz
Member
 
Registered: Mar 2006
Distribution: Fedora Core 5 i386 DVD | Kernel 2.6.16-1.2080_FC5 | YUM v2.6.0 | GNOME v2.14.0 |
Posts: 42

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Gethyn
Don't delete your grub.conf file! That would be a really bad idea. You want to edit it, using whichever text editor you prefer (though you will need to be root to do so). You will have a line that looks something like this:
Code:
kernel /vmlinuz-2.6.12-10-686-smp root=/dev/sda8 rhgb
You need to change it to something like this:
Code:
kernel /vmlinuz-2.6.12-10-686-smp root=/dev/sda8
In other words, all you need to do is remove the rhgb kernel option. Note that your grub.conf will not look exactly as shown above, but similar - you need to find the line(s) beginning "kernel".
thank you very much. that is what I look for..... someone like you guide fully throught.

Now I understand what you mean for ....

thank you ! thank you !
 
Old 03-30-2006, 11:02 AM   #9
FireGunz
Member
 
Registered: Mar 2006
Distribution: Fedora Core 5 i386 DVD | Kernel 2.6.16-1.2080_FC5 | YUM v2.6.0 | GNOME v2.14.0 |
Posts: 42

Original Poster
Rep: Reputation: 15
well... final it slove the problem. even using

type:
Code:
chkconfig --levels 345 nvidia-glx off

type:
Code:
service nvidia-glx stop
also will do.... thank to Lenard help. thank you.

now does anyone got any idea how to got back the loading splash screen (which you able to switch to show/hide the detail) which after the grub bootsplash screen.
 
Old 03-30-2006, 03:17 PM   #10
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Just add the rhgb postion back the same way you removed it.

Change it from somthing like this;

kernel /vmlinuz-2.6.12-10-686-smp root=/dev/sda8

Back to something like this;

kernel /vmlinuz-2.6.12-10-686-smp root=/dev/sda8 rhgb
 
Old 03-30-2006, 06:01 PM   #11
FireGunz
Member
 
Registered: Mar 2006
Distribution: Fedora Core 5 i386 DVD | Kernel 2.6.16-1.2080_FC5 | YUM v2.6.0 | GNOME v2.14.0 |
Posts: 42

Original Poster
Rep: Reputation: 15
hi Lenard,

I did check it, I still got/have the rhgb at grub.conf ?

but there is no loading screen for me.

any idea? the only thing I did turn off the nvidia glx yesterday. then the loading screen is missing.....

Last edited by FireGunz; 03-30-2006 at 06:02 PM.
 
Old 03-30-2006, 06:15 PM   #12
FireGunz
Member
 
Registered: Mar 2006
Distribution: Fedora Core 5 i386 DVD | Kernel 2.6.16-1.2080_FC5 | YUM v2.6.0 | GNOME v2.14.0 |
Posts: 42

Original Poster
Rep: Reputation: 15
i even turn on the Service nVidia-glx also never get back the loading screen...

type:
Code:
chkconfig --levels 345 nvidia-glx on
type:
Code:
service nvidia-glx start
now i had disable the Service nVidia-glx and also check it I got the "rhgb" at grub.conf

here is my grub.conf at below:

kernel /vmlinuz-2.6.15-1.2054_FC5 ro root=/dev/VolGroup00/LogVo100 rhgb quiet

and still missing the loading screen (interactive)...

Last edited by FireGunz; 03-30-2006 at 06:25 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot failure after upgrading FC5 TR3 to FC5 Official Release fsb1284 Fedora 3 03-25-2006 09:12 AM
How do I permanently disable kded media manager? antis Linux - General 0 11-27-2005 10:18 AM
what are the services i can disable, also disable ads, banners in konqueror? greythorne SUSE / openSUSE 3 03-16-2005 08:30 AM
How to start all the services from command line permanently !! bpandey Linux - General 1 08-26-2004 12:27 AM
How to disable X security permanently danishmr Linux - Security 15 04-09-2004 02:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 09:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration