LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 11-02-2004, 06:58 PM   #16
fc700
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0

for my fc1, the right sequence is

rpm -ivh compat-gcc-7.3-2.96.118.i386.rpm
rpm -ivh compat-libstdc++-7.3-2.96.118.i386.rpm
rpm -ivh compat-libstdc++-devel-7.3-2.96.118.i386.rpm
rpm -ivh compat-gcc-c++-7.3-2.96.118.i386.rpm
 
Old 11-27-2004, 12:54 PM   #17
DaMeon
LQ Newbie
 
Registered: Nov 2004
Location: Mainz
Distribution: Fedora Core 2
Posts: 1

Rep: Reputation: 0
Hello,

I am Using Fedora Core 2

If i try to install compat-libstdc++-devel-8-3.3.4.2.i386.rpm
i get following message

Failed dependencies:
compat-libstdc++ = 8-3.3.4.2 is needed by compat-libstdc++-devel-8-3.3.4

I don't know what i have to install.

another error is

rpm -ivh compat-gcc-c++-8-3.3.4.2.i386.rpm
Error: Failed dependencies:
compat-gcc = 8-3.3.4.2 is needed by compat-gcc-c++-8-3.3.4.2

just rpm -ivh compat-libstdc++-7.3-2.96.126.i386.rpm works.


Thank you for any help.

Greets Marc
 
Old 11-27-2004, 02:28 PM   #18
FunkyRes
Member
 
Registered: Mar 2004
Distribution: CentOS
Posts: 174

Rep: Reputation: 30
It looks like you are trying to install the devel package without the library package.

try:

yum localinstall compat-libstdc++-devel-8-3.3.4.2.i386.rpm

That should then use yum to get anything needed to install it (probably only compat-libstdc++-8-3.3.4.2.i386.rpm)
 
Old 12-11-2004, 09:29 AM   #19
clean_sweep
LQ Newbie
 
Registered: Nov 2004
Location: Chicago
Posts: 12

Rep: Reputation: 0
I am having exactly the same problem. I saw this post and downloaded the three RPMs and tried to install them in the order suggested by FC2tick, but nothing works. I get the same set of errors that hamcycle got. Then I installed yum, but I am not sure how to use it. I tried it, but did not work:

yum install libstdc++-compat
Traceback (most recent call last):
File "/usr/bin/yum", line 22, in ?
import yummain
File "/usr/share/yum/yummain.py", line 21, in ?
import clientStuff
File "/usr/share/yum/clientStuff.py", line 18, in ?
import rpm
ImportError: No module named rpm

Could someone help please? Thanks.
 
Old 09-13-2007, 09:53 AM   #20
viabsb
LQ Newbie
 
Registered: Apr 2004
Posts: 13

Rep: Reputation: 10
libstdc++

I uninstall the lib above and now rpm and yum does not work.
Where do I find the source .gz package of the files needed by rpm?
I need a fresh install from the sources packages to bypass the rpm needs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
libstdc++-libc6.1-1.so.2 cybercullen Linux - Newbie 6 07-08-2009 01:05 PM
Error: libstdc++-libc6.2-2 .so.3 ceenu99 Linux - Software 2 07-14-2005 11:53 PM
how to link to libstdc++-libc6.1-2.so.3? thanhvn Programming 1 03-19-2005 11:13 AM
libstdc++-libc6.2-2.so.3 tommytomato Linux - General 1 12-12-2003 01:07 AM
libstdc++-libc6.2? jpbarto Linux From Scratch 1 04-13-2003 09:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 12:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration