LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 10-25-2007, 09:56 AM   #1
treotan
Member
 
Registered: Jun 2004
Posts: 126

Rep: Reputation: 15
How to install libcrypto.so.4....?


I try to install the software, but it prompts me the following error:

error: Failed dependencies:
libcrypto.so.4 is needed by mapguideenterprise2008-webextension-1.2.0.4103-1.i386
libdb-4.2.so is needed by mapguideenterprise2008-webextension-1.2.0.4103-1.i386
libssl.so.4 is needed by mapguideenterprise2008-webextension-1.2.0.4103-1.i386


How I can install the libcrypto.so.4, libdb-4.2.so and libssl.so.4 into Fedora Core 4 box? Thanks
 
Old 10-25-2007, 10:10 AM   #2
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980
libcrypto.so.4 and libssl.so.4 were provided by the package openssl097a, while libdb-4.2.so is provided by db4. Check carefully the library versions inside the packages because they are updated frequently.
 
Old 10-25-2007, 03:00 PM   #3
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
So run "yum install openssl097a db4" from a terminal window without quotes. Then try installing whatever software you tried installing again.
 
Old 07-08-2008, 02:50 PM   #4
ram636
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
Thanks

Thanks it really worked ... I was trying to install VirtualBox in RHEL 5.0.



Quote:
Originally Posted by shafty023 View Post
So run "yum install openssl097a db4" from a terminal window without quotes. Then try installing whatever software you tried installing again.
 
Old 08-06-2009, 08:12 PM   #5
juliofreitas
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Rep: Reputation: 0
my version of libssl 0.9.8... latest version but i can't install ifstat...

my version of libcrypto is libcrypto.so.6...

i maked a link libcrypto.so.6 to libcrypto.so.4 but don't works


somebody help me please?


*linux: Scientific Linux 5.3 x86_64!
 
Old 08-06-2009, 08:41 PM   #6
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
Quote:
[root@localhost ~]# yum provides */libcrypto.so.4
.
.
.
openssl097a-0.9.7a-9.el5_2.1.x86_64 : The OpenSSL toolkit
Matched from:
Filename : /lib64/libcrypto.so.4
Looks like the answer is still the same.
 
Old 08-07-2009, 06:02 AM   #7
juliofreitas
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Rep: Reputation: 0
i have a latest version of openssl but don't work...

i maked links of libcrypto.so.6 for libcrypto.so.4 ...

$openssl version
OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008

$yum provides */libcrypto.so.4
Loaded plugins: kernel-module
openssl097a-0.9.7a-9.el5_2.1.i386 : The OpenSSL toolkit
Matched from:
Filename : /lib/libcrypto.so.4


openssl097a-0.9.7a-9.el5_2.1.x86_64 : The OpenSSL toolkit
Matched from:
Filename : /lib64/libcrypto.so.4



$sudo rpm -ivh ifstat-1.1-1.1.fc3.rf.x86_64.rpm
warning: ifstat-1.1-1.1.fc3.rf.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 6b8d79e6
error: Failed dependencies:
libcrypto.so.4()(64bit) is needed by ifstat-1.1-1.1.fc3.rf.x86_64
libnetsnmp.so.5()(64bit) is needed by ifstat-1.1-1.1.fc3.rf.x86_64



*Scientific Linux 5.3
 
Old 08-07-2009, 12:49 PM   #8
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
I suspect that the issue may be that you are trying to run a FC3 rpm on el5. EL5 was based on FC6. Trying to run a rpm that was built for a version that many generations apart is unlikely to work.
 
Old 08-10-2009, 07:44 AM   #9
juliofreitas
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Rep: Reputation: 0
now its work!


i installed ifstat-1.1-1.2.el5.rf.x86_64.rpm version

ok, work!


thankz
 
Old 09-28-2011, 08:33 AM   #10
bvbmedia
LQ Newbie
 
Registered: Sep 2011
Posts: 2

Rep: Reputation: Disabled
yum install openssl-devel curl-devel

Or the easy way:

yum groupinstall "Development Tools"

Last edited by bvbmedia; 09-28-2011 at 08:36 AM.
 
Old 09-28-2011, 04:41 PM   #11
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,454

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
bvbmedia please do not drag up a thread from 2007
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
install bind9 error libcrypto trebek Linux - Server 2 04-25-2007 12:40 PM
libcrypto.so.5 spivy66 Fedora 4 06-12-2006 12:10 PM
pine install problem libcrypto.so.0 needed anamika123 Linux - Software 7 04-26-2004 03:58 PM
libcrypto.so.4 conflicts with libcrypto.so.2 for hp driver sid_datta Linux - Newbie 0 07-25-2003 06:06 AM
Where can I get libcrypto.so.4? WorldBuilder Linux - Software 3 07-18-2003 09:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 10:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration