LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 11-09-2005, 01:32 PM   #1
diegocarrera
LQ Newbie
 
Registered: Oct 2005
Posts: 3

Rep: Reputation: 0
how to enable directing rendering on FC4 + ATI


Hi, my name is Diego Carrera.

I installed the ati-8.18.8 driver on FC4-2.6.11 then i wrote "glxinfo" and it display
direct rendering:NO

can somebody tell me how to enable direct rendering?
or somedody have any tutorial about how to do this ?

because i need more FPS because when i write "glxgears".
649 frames in 5.0 seconds = 129.800 FPS

**I have an ATI9600XT video card.

thank in advanced.
Diego Carrera
 
Old 11-10-2005, 06:49 AM   #2
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
You might want to try installing the Linux drivers from ATI's home page.
 
Old 11-10-2005, 06:49 AM   #3
Simon_6162
Member
 
Registered: Jul 2004
Location: UK
Distribution: Fedora, Gentoo, Redhat Enterprise
Posts: 141

Rep: Reputation: 16
Hi,

The, ati drivers are a bit of a pain. It sounds like you havent got them properly installed as that is a low frame rate. if you run the command fglrxinfo that tells you what graphics card drivers you currently are using. If its somthing like ATI RADEON then skip the part about removing and reinstalling drivers, but i'm guessing it will come up MESA ..... if it is mesa then try this

uninstall what you currently have
rpm -e $(rpm -qa | grep fglrx)

then install the prepatched drivers for fedora from this guide
http://www.fedorafaq.org/#radeon

##############
#summary of the guide
##############

you will need to add livna to your yum.conf file (as root)

#set up yum for livna
cd /etc
rm -f yum.conf
wget http://www.fedorafaq.org/samples/yum.conf
rpm -Uvh http://www.fedorafaq.org/yum

#install ati driver
yum install ati-fglrx kernel-module-fglrx-$(rpm -q --queryformat="%{version}-%{release}\n" kernel | tail -n 1)

every time your kernal changes run
yum install kernel-module-fglrx-$(rpm -q --queryformat="%{version}-%{release}\n" kernel | tail -n 1)

###############
#Config new driver
###############
once this is done then just run the command fglrxconfig and that should take you through your graphics card setup with the new drivers
 
Old 11-10-2005, 09:42 AM   #4
diegocarrera
LQ Newbie
 
Registered: Oct 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Insert an image into your message

Hi..
I reinstalled the drivers of AT, and I still have the same problem.

I did :
1. uninstalled the fglrx
2. added livna repository and installed the prepatched drivers (rpm -e $(rpm -qa | grep fglrx))
3. added lines the file on the xorg. (because i have a mainboard biostart 8668 GR and a CPU intel)
4. installed the driver ati-driver-installer-8.18.8-i386.run
5. i configured the fglxconfig (all stepts default)
6. i wrote glxinfo and its display RENDERING: NO

i wrote [root@nodo141 ~] rpm -qa | grep fglrx
its display
"ati-fglrx-8.18.6.1-0.lvn.1.4
kernel-module-fglrx-2.6.11-1.1369_FC4-8.14.13.1-0.lvn.5.4"

i wrote "fglrxinfo" display:
"display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)"

and when i wrote "lspci | grep AGP"
00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]

and i wrote "glxinfo | grep direct"
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect

what could be the problem ?
 
Old 11-10-2005, 10:03 AM   #5
Simon_6162
Member
 
Registered: Jul 2004
Location: UK
Distribution: Fedora, Gentoo, Redhat Enterprise
Posts: 141

Rep: Reputation: 16
OK well the problem is that your still somehow on the mesa driver not the ati one.

I assume you have tried rebooting ?

can you post
what processor you have ?
and can you post the output of
dmesg | tail -n 100

Simon
 
Old 11-10-2005, 01:43 PM   #6
diegocarrera
LQ Newbie
 
Registered: Oct 2005
Posts: 3

Original Poster
Rep: Reputation: 0
I still have de same problem

I assume you have tried rebooting ?
*** of course, i did that

i wrote dmesg | tail -n 100
and display

SELinux: initialized (dev futexfs, type futexfs), uses genfs_contexts
SELinux: initialized (dev pipefs, type pipefs), uses task SIDs
SELinux: initialized (dev sockfs, type sockfs), uses task SIDs
SELinux: initialized (dev proc, type proc), uses genfs_contexts
SELinux: initialized (dev bdev, type bdev), uses genfs_contexts
SELinux: initialized (dev rootfs, type rootfs), uses genfs_contexts
SELinux: initialized (dev sysfs, type sysfs), uses genfs_contexts
SELinux: initialized (dev usbfs, type usbfs), uses genfs_contexts
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written by Donald Becker
ACPI: PCI Interrupt 0000:00:12.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
eth0: VIA Rhine II at 0xe7005000, 00:e0:4c:a1:04:85, IRQ 11.
eth0: MII PHY found at address 1, status 0x7849 advertising 05e1 Link 0000.
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
eth1: DGE-530T Gigabit Ethernet Adapter
PrefPort:A RlmtMode:Check Link State
snd_via82xx: Unknown parameter `'
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 3
PCI: setting IRQ 3 as level-triggered
ACPI: PCI Interrupt 0000:00:11.5[C] -> Link [LNKC] -> GSI 3 (level, low) -> IRQ 3
PCI: Setting latency timer of device 0000:00:11.5 to 64
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
ACPI: PCI Interrupt 0000:00:11.6[C] -> Link [LNKC] -> GSI 3 (level, low) -> IRQ 3
PCI: Setting latency timer of device 0000:00:11.6 to 64
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:10.3[D] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
ehci_hcd 0000:00:10.3: EHCI Host Controller
ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:10.3: irq 11, io mem 0xe7004000
ehci_hcd 0000:00:10.3: USB 2.0 initialized, EHCI 1.00, driver 10 Dec 2004
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
USB Universal Host Controller Interface driver v2.2
SELinux: initialized (dev debugfs, type debugfs), uses genfs_contexts
ACPI: PCI Interrupt 0000:00:10.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:10.0: UHCI Host Controller
uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:10.0: irq 11, io base 0x0000d400
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:10.1[B] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
uhci_hcd 0000:00:10.1: UHCI Host Controller
uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:10.1: irq 5, io base 0x0000d800
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:10.2[C] -> Link [LNKC] -> GSI 3 (level, low) -> IRQ 3
uhci_hcd 0000:00:10.2: UHCI Host Controller
uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:10.2: irq 3, io base 0x0000dc00
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
ACPI: Power Button (FF) [PWRF]
ACPI: Sleep Button (CM) [SLPB]
ibm_acpi: ec object not found
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
EXT3 FS on dm-0, internal journal
kjournald starting. Commit interval 5 seconds
EXT3 FS on hda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
SELinux: initialized (dev hda1, type ext3), uses xattr
SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
Adding 524280k swap on /dev/VolGroup00/LogVol01. Priority:-1 extents:1
SELinux: initialized (dev binfmt_misc, type binfmt_misc), uses genfs_contexts
eth0: link down
eth1: network connection up using port A
speed: 1000
autonegotiation: yes
duplex mode: full
flowctrl: symmetric
role: slave
irq moderation: disabled
scatter-gather: enabled
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
Bluetooth: Core ver 2.7
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.7
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM ver 1.5
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
lp0: using parport0 (interrupt-driven).
lp0: console ready
NET: Registered protocol family 10
Disabled Privacy Extensions on device c03e6820(lo)
IPv6 over IPv4 tunneling driver
eth1: no IPv6 routers present



*** i have a P4 intel 1.8 with 256 ram



Diego

Last edited by diegocarrera; 11-11-2005 at 06:19 AM.
 
Old 11-11-2005, 09:41 AM   #7
xsive
LQ Newbie
 
Registered: Jan 2004
Location: Melbourne, AU
Posts: 14

Rep: Reputation: 0
this driver version does not install correctly under FC4. Grab the stuff from livna as suggested BUT make sure you grab the same driver and kernel module packages that are specific for your FC4 system (in my case, the default 2.6.11.1369)

The method using YUM posted above is good in theory but the latest driver it grabs (ati-fglrx) and the kernel module for your system will most likely mismatch (they did for me) so it won't work. do a "yum search fglrx" and you'll see everything available on livna (if you've added it as an extra repository)

I had to manually download the right RPMs because YUM wouldn't let me grab the specific (older) version of ati-fglrx driver that I wanted.

Good luck.
 
Old 11-13-2005, 04:52 PM   #8
Chris107
LQ Newbie
 
Registered: Nov 2005
Posts: 6

Rep: Reputation: 0
Quote:
Originally posted by Simon_6162
Hi,

The, ati drivers are a bit of a pain. It sounds like you havent got them properly installed as that is a low frame rate. if you run the command fglrxinfo that tells you what graphics card drivers you currently are using. If its somthing like ATI RADEON then skip the part about removing and reinstalling drivers, but i'm guessing it will come up MESA ..... if it is mesa then try this

uninstall what you currently have
rpm -e $(rpm -qa | grep fglrx)

then install the prepatched drivers for fedora from this guide
http://www.fedorafaq.org/#radeon

##############
#summary of the guide
##############

you will need to add livna to your yum.conf file (as root)

#set up yum for livna
cd /etc
rm -f yum.conf
wget http://www.fedorafaq.org/samples/yum.conf
rpm -Uvh http://www.fedorafaq.org/yum

#install ati driver
yum install ati-fglrx kernel-module-fglrx-$(rpm -q --queryformat="%{version}-%{release}\n" kernel | tail -n 1)

every time your kernal changes run
yum install kernel-module-fglrx-$(rpm -q --queryformat="%{version}-%{release}\n" kernel | tail -n 1)

###############
#Config new driver
###############
once this is done then just run the command fglrxconfig and that should take you through your graphics card setup with the new drivers
I'm going to love you forever, I finally got my ATI drivers to work!!!
My GLXGEARS fps went from around 500 to around 4000. I'm pretty sure it could be better but it's a great improvement from where I was.
Thank you so much

Last edited by Chris107; 11-13-2005 at 05:37 PM.
 
Old 12-04-2005, 09:59 AM   #9
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Rep: Reputation: 0
I should add here that after following Simons 6162's Guide Sumary, my ati board was still not working.

Then I followed xsive's advise and did...

"yum install ati-fglrx kernel-module-fglrx-2.6.14-1.1644_FC4smp" because 2.6.14-1.1644_FC4smp is my kernel version!!!

[EDIT]
Now my card is working. Got about 4k TO 5k fps. Nice increase. Next step is to install Americas Army 2.5 ans see what happens.
[/EDIT]

Last edited by CapCavernaX; 12-05-2005 at 07:01 AM.
 
Old 12-04-2005, 11:13 AM   #10
mimithebrain
Member
 
Registered: Nov 2003
Location: ~
Distribution: Ubuntu 10.04
Posts: 843
Blog Entries: 1

Rep: Reputation: 30
Maybe it will help, maybe not.

In gentoo, I emerged ati-drivers (or the equivalent of yum install ati-fglrx)
Tweaked my kernel to match fglrx's kernel expectencies (or equivalent of yum install kernel-modules-blablabla)
Then, modified /etc/modules.autoload.d/kernel-2.6

In there, agpgart loads first (nessessary!)
Then ati_agp loads second (loaded because it's a IGP AGP chipset or something, and I tried without it, it won't work)
Then I load fglrx (of course, nessessary)

I tried to make it work for at least two weeks, and this is what worked. The turning point was when I realized I didn't have a via chipset, and that it was required to have ati_agp loaded if I grepped the keyword IGP in the lspci output.

Hope this helps
 
Old 12-05-2005, 07:10 AM   #11
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Rep: Reputation: 0
Talking

Quote:
Originally Posted by mimithebrain
Maybe it will help, maybe not.
Hmm... yes it may help those with intermediate to advanced knowledge of Linux... those with knowledge ( er me for example ) will need some translation of what you just said!!!

I say this because I have my card working but who knows. I may still need to do a clean install of FC4 soon due to a ACPI problem and may need to start over with ATI drivers...
 
Old 12-05-2005, 12:56 PM   #12
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Rep: Reputation: 0
Quote:
Originally Posted by Simon_6162
#install ati driver
yum install ati-fglrx kernel-module-fglrx-$(rpm -q --queryformat="%{version}-%{release}\n" kernel | tail -n 1)

every time your kernal changes run
yum install kernel-module-fglrx-$(rpm -q --queryformat="%{version}-%{release}\n" kernel | tail -n 1)

Simon_6162, Can you provide a breakdown of what these two commands are telling yum to do? When I ran the command above it did not work.

I then tried your command but instead of all the stuff after ...-fglrx-$ I just went and put the kernel version I have runing. The new command I used was

Code:
yum install kenel-module-fglrx-(MY CURENT KERNEL)
At work now so don't know the correct kernel ver. when get home will edit!!!

that second yum install command was what did it for me. I'm just concerned that lets say I do a new clean FC4 istall, I assume I would just be able to skip...
Code:
yum install kernel-module-fglrx-$(rpm -q --queryformat="%{version}-%{release}\n" kernel | tail -n 1)
...this and just go with my command! or is there something in your command that I would be missing in mine that would not let my command work. What would I have to put in my command to make mine work? See why a break down would help
 
Old 12-05-2005, 02:04 PM   #13
mimithebrain
Member
 
Registered: Nov 2003
Location: ~
Distribution: Ubuntu 10.04
Posts: 843
Blog Entries: 1

Rep: Reputation: 30
I don't know how to help you CapCavernaX , I used FC4 for less then two weeks, then I got tired of it's bugs and switched to Gentoo.

I followed the Gentoo ATI FAQ that you can get on google. Basically, install the kernel drivers (somehow), edit the /etc/modprobe.conf or /etc/modules.conf (or whatever the name of the autoloading module file is named in Fedora Core) to match your needs. Make sure the modules are loaded in the right order, and the right modules are loaded in the first place.

Someone here may need to translate what I wrote in Fedora Core related language
 
Old 12-05-2005, 03:00 PM   #14
CapCavernaX
LQ Newbie
 
Registered: Nov 2005
Location: Boston
Distribution: Fedora Core 4 ( Will try Suse + slackware next )
Posts: 14

Rep: Reputation: 0
What counts is that you tried. Thanks mimithebrain!!!

Can anyone one else shed some light on the issue above?
 
Old 12-05-2005, 05:43 PM   #15
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
What IS the issue?
Your previously edited post suggests you have a working card.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to enable direct rendering. dr_zayus69 Linux - Games 8 06-02-2008 05:10 PM
What is direct rendering and how to enable it. TruongAn Linux - Games 15 11-06-2005 11:31 AM
change resolution + enable direct rendering ringmbr Linux - Hardware 0 05-20-2005 06:48 AM
Enable Direct Rendering rca36 Mandriva 12 03-29-2005 01:15 PM
how to enable direct rendering? marsques Slackware 2 09-07-2004 02:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 05:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration